Для запуска программы из главного меню Windows выполните следующие действия

Введение

назад

Язык Basic

Язык программирования BASIC – Beginner's All purpose Symbolic Instruction Code (универсальный символьный программный код для начинающих) был разработан сотрудниками Дартмутского колледжа (США) в 1964 г. Первоначальная его версия включала всего 14 служебных слов и предназначалась для обучения программированию. С тех пор было создано более 100 версий этого языка, реализованных на различных ЭВМ.

Первый персональный компьютер IBM PC имел 16-разрядный BASIC, разработанный корпорацией IBM. Позже его сменил GW-BASIC и QUICK-BASIC, разработанный корпорацией Microsoft. В QUICK-BASIC была убрана нумерация строк и добавлен компилятор, превращающий BASIC-программу в полноценный исполняемый (.exe) файл. Не оставила без внимания язык BASIC и корпорация Borland, разработавшая в 1987 г. интегрированную среду программирования Turbo-Basic.

Интегрированная среда разработки приложений Visual Basic

Visual Basic развился из первоначального языка Basic и в настоящее время содержит несколько сотен команд, функций и ключевых слов, многие из которых связаны непосредственно с графическим интерфейсом пользователя GUI (Graphical User Interface) операционной системы Windows. Используя Visual Basic даже начинающие программисты могут создавать полезные программы, зная лишь несколько ключевых слов. При этом профессиональные программисты имеют все необходимые средства для разработки сложных приложений, функционирующих под управлением Windows.

В 1992 г. корпорацией Microsoft был разработан и выпущен Visual Basic 1.0 - относительно простой язык программирования для Windows 3.1. Затем были выпущены Visual Basic 3.0, 4.0, 5.0 и наконец Visual Basic 6.0. Версии 5.0 и 6.0 отличаются незначительно: в шестой версии улучшено ядро и добавлен ряд новых функций. ПомимоVisual Basic существует еще язык макросов для приложений Microsoft Office (Word, Excel и т.п.). Он называется VBA (Visual Basic for Application). С его помощью можно разрабатывать макрокоманды для автоматизации работы с приложениями Microsoft Office.

Интегрированная среда разработки приложений Microsoft Visual Basic (в дальнейшем изложении Visual Basic), обладая простыми в обращении средствами визуального проектирования, позволяет в полной мере использовать преимущества графической среды

Windows и быстро конструировать эффективные приложения. Помимо Visual Basic существуют и другие языки визуального программирования с аналогичными возможностями: Borland Delphi, Borland C++ Builder.

Visual Basic – один из первых языков, поддерживающих событийно-управляемое программирование (event-driven programming). Этот стиль хорошо согласуется со стандартом графического пользовательского интерфейса. Традиционно программирование ориентировалось на поэтапное описание конкретного процесса. Однако современные компьютерные приложения слишком сложны и данный стиль программирования для них не подходит.

Основная идея событийно-управляемого программирования заключается в том, что вместо скрупулезного описания каждого шага работы приложения достаточно лишь указать, как необходимо реагировать на различные события (действия пользователя): выбор команды, щелчок или перемещение мыши, нажатие клавиш и др. В результате программист создает не одну большую программу, а приложение, состоящее из набора взаимодействующих процедур, управляемых пользователем.

Программы, или как принято говорить - приложения, разрабатываемы для Windows, имеют, как правило, стандартный пользовательский интерфейс: окна-формы, на которых располагаются окна для текстов или рисунков, меню, кнопки управления и другие элементы. Каждый из этих объектов обладает определенными свойствами: цвет, размеры, надписи и другие. Кроме этого, каждое конкретное приложение в режиме взаимодействия с пользователем посредством вышеупомянутых объектов, выполняет те или иные действия, приводящие к получению определенного результата. Для получения какого-либо конкретного действия должна быть написана соответствующая команда в тексте программы на языке Visual Basic. Таким образом разработка приложения включает следующие этапы:

- создание интерфейса пользователя с использованием средств визуального программирования, в процессе которого на формах размещаются необходимые объекты из набора стандартных элементов интерфейса Windows;

- установка свойств для формы и размещенных на ней объектов (размеры, цвет, надписи и др.);

- написание текста программы, определяющей выполнение приложением необходимых действий.

Разработанная корпорацией Microsoft интегрированная среда разработки приложений Visual Basic объединяет в себе множество функций, позволяющих выполнять визуальное проектирование интерфейса приложения, ввод и редактирование исходного текста программы, компиляцию и отладку приложений.

Приложения, создаваемые в среде Visual Basic принято называть проектами.

назад


Помощь


Новая страница 2

Лабораторный практикум

по дисциплине: "Информатика"

Основы программирования в интегрированной среде разработки приложений Microsoft Visual Basic 6.0

(неполная версия)

Материал недоступен.

Для возврата к предыдущему материалу используйте кнопку "Назад" web-браузера.


Электронный лабораторный практикум по Visual Basic

Лабораторный практикум

по дисциплине: "Информатика"

Основы программирования в интегрированной среде разработки приложений Microsoft Visual Basic 6.0

Общие сведения о Visual Basic

Лабораторная работа № 1 Изучение интегрированной среды и основ работы в Visual Basic

Лабораторная работа № 2 Организация ввода-вывода данных, изменение свойств объектов

Лабораторная работа № 3 Разработка приложений с разветвляющимися и циклическими алгоритмами

Лабораторная работа № 4 Работа с массивами

Лабораторная работа № 5 Работа файлами и строками

Лабораторная работа № 6 Работа с графикой

Лабораторная работа № 7 Разработка многооконных приложений с использованием компонентов на базе стандартных шаблонов и меню

Интерактивное тестирование

Оформление отчетов по лабораторным работам

© Кузьмина Е.А., Минасов Ш.М., Тархов С.В. Свидетельство об отраслевой регистрации.
Уфа, кафедра Информатики УГАТУ, 2004-2005 г.


Тархов Сергей Владимирович

Кузьмина Елена Алексеевна

кандидат технических наук, доцент.

Кафедра информатики
Уфимского государственного авиационного технического университета.

т. (3472) 23-78-76

[На главную страницу]


Тархов Сергей Владимирович

Минасов Шамиль Маратович

кандидат технических наук, доцент

Кафедра информатики
Уфимского государственного авиационного технического университета.

т. (3472) 23-78-76
E-mail: minasov@ufanet.ru

[На главную страницу]


Электронный лабораторный практик

Свидетельство об отраслевой регистрации.

Электронный лабораторный практикум по VisualBasic зарегистрирован в Отраслевом фонде алгоритмов и программ (ОФАП) государственного координационного центра информационных технологий Министерства образования Российской Федерации.

Свидетельство об отраслевой регистрации разработки № 3649 от 10 июня 2004 года.

Исправленная и дополненная версия от 26 апреля 2005 года


Тархов Сергей Владимирович

докторант, кандидат технических наук, доцент.

Кафедра информатики
Уфимского государственного авиационного технического университета.

т. (3472) 23-78-76
E-mail: tarkhov@mail.rb.ru

С 1990 г. преподает дисциплины "Информатика", "Компьютерные технологии", Электронный офис", "Системы подготовки деловой документации", "Организация интерфейса в человеко-машинных системах" и др.

Один из авторов новой инструментально обеспеченной методики преподавания дисциплины “Информатика” и других дисциплин компьютерного профиля для подготовки бакалавров и магистров, внедренной в учебный процесс в ряде вузов региона.

В 1998 году им получен и успешно выполнен грант "Института Открытое общество" (фонд Сороса) "Музей истории отечественных компьютеров", опубликованный http://www.bashedu.ru/konkurs/tarhov/index.htm и размещенный на CD Московского Центра интернет-образования в разделе "Ресурсы Интернета".

Тархов С.В. является автором более 120 научных и методических работ.

Область научный интересов: проектирование информационно-обучающих сред для образовательных систем.

[На главную страницу]


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Функция FormatCurrency

назад

FormatCurrency(Expression[,NumDigitsAfterDecimal [,IncludeLeadingDigit,[UseParensForNegativeNumbers[,GroupDigits]]]])

Новая функция, которая появилась в Visual Basic 6.0
Служит для форматирования числовых выражений, представляющих денежные суммы. Эта функция была введена в качестве альтернативы громоздкой функции Format. Используйте функцию FormatCurrency в силу ее большей читабельности

Возвращаемое значение

Возвращает строковое выражение, отформатированное в виде денежного значения с применением символа валюты, заданного в системной панели управления

Параметры
Часть | Описание
Expression | Обязательный. Форматируемое выражение
NumDigitsAfterDecimal | Необязательный. Числовое значение, задающее число знаков, отображаемых в правой части десятичной дроби. Значением по умолчанию, указывающим, что применяются национальные установки компьютера, является –1
IncludeLeadingDigit | Необязательный. Константа с тремя значениями, которая задает наличие или отсутствие начального нуля при отображении дробных значений. См. значения в разделе «Установки»
UseParensForNegativeNumbers | Необязательный. Константа с тремя значениями, которая указывает, надо ли заключать в круглые скобки отрицательные значения. См. значения в разделе «Установки»
GroupDigits | Необязательный. Константа с тремя значениями, указывающая на необходимость группирования цифр с применением разделителя групп, заданного в национальных установках компьютера. См. значения в разделе «Установки»

Установки

Параметры IncludeLeadingDigit, UseParensForNegativeNumbers и GroupDigits имеют следующие установки:

Константа | Значение | Описание
TristateTrue | –1 | True
TristateFalse | 0 | False
TristateUseDefault | –2 | Применяется установка, соответствующая национальным установкам для компьютера

Примечания

При пропуске одного или нескольких необязательных параметров значения для них присваиваются в соответствии с национальными установками компьютера

Расположение символа валюты по отношению к денежному значению определяется национальными установками для системы

Замечание Все сведения об установках содержатся на закладке Regional Settings Currency, за исключением вводного нуля, информация о котором находится на закладке Number

Пример

' В данном примере функция FormatCurrency
' используется для форматирования числа 100
Print FormatCurrency(100) 'возвращает 100.00р.

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Функция FormatDateTime

назад

FormatDateTime(Date[,NamedFormat])

Новая функция, которая появилась в Visual Basic 6.0
Служит для форматирования величин дат и времени

Возвращаемое значение

Возвращает строковое выражение, отформатированное в виде даты и времени

Параметры
Часть | Описание
Date | Обязательный. Форматируемое выражение для даты и времени
NamedFormat | Необязательный. Числовое выражение, указывающее используемый формат для даты и времени. Если параметр опущен, применяется формат, задаваемый константой vbGeneralDate

Установки

Для параметра NamedFormat используются следующие установки:

Константа | Значение | Описание
vbGeneralDate | 0 | Отображаются дата и/или время. При наличии области даты она отображается в коротком формате для даты. Если присутствует часть, относящаяся к времени, то время отображается в длинном формате для времени. При наличии обеих частей – производится их отображение
vbLongDate | 1 | Отображается дата с использованием длинного формата для даты, заданного национальными установками компьютера
vbShortDate | 2 | Отображается дата с использованием короткого формата для даты, заданного национальными установками компьютера
vbLongTime | 3 | Отображается время с использованием формата для времени, заданного национальными установками компьютера
vbShortTime | 4 | Отображается время с использованием 24-часового формата (hh:mm)

Пример

' В данном примере функция FormatDateTime
' используется для форматирования даты
Print FormatDateTime(1) 'возвращает 31.12.1899

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Функция FormatNumber

назад

FormatNumber(Expression[,NumDigitsAfterDecimal [,IncludeLeadingDigit [,UseParensForNegativeNumbers [,GroupDigits]]]])

Новая функция, которая появилась в Visual Basic 6.0
Служит для форматирования числовых выражений. Эта функция была введена в качестве альтернативы громоздкой функции Format. Используйте функцию FormatNumber в силу ее большей читабельности

Возвращаемое значение

Возвращает значение типа String,содержащее отформатированное числовое выражение

Параметры
Часть | Описание
Expression | Обязательный. Форматируемое выражение
NumDigitsAfterDecimal | Необязательный. Числовое значение, задающее число знаков, отображаемых в правой части десятичной дроби. Значением по умолчанию, указывающим, что применяются национальные установки компьютера, является –1
IncludeLeadingDigit | Необязательный. Константа с тремя значениями, которая задает наличие или отсутствие начального нуля при отображении дробных значений. См. значения в разделе «Установки»
UseParensForNegativeNumbers | Необязательный. Константа с тремя значениями, которая указывает, надо ли заключать в круглые скобки отрицательные значения. См. значения в разделе «Установки»
GroupDigits | Необязательный. Константа с тремя значениями, указывающая на необходимость группирования цифр с применением разделителя групп, заданного в национальных установках компьютера. См. значения в разделе «Установки»

Установки

Для параметров IncludeLeadingDigit, UseParensForNegativeNumbers и GroupDigits используются следующие установки:

Константа | Значение | Описание
TristateTrue | –1 | True
TristateFalse | 0 | False
TristateUseDefault | –2 | Применяется установка, соответствующая национальным установкам для компьютера

Примечания

При пропуске одного или нескольких необязательных параметров значения для них присваиваются в соответствии с национальными установками компьютера

Замечание Все сведения об установках содержатся на закладке Regional Settings Number

Пример

' В данном примере функция FormatNumber
' используется для форматирования числа 100
Print FormatNumber(100) 'возвращает 100,00

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Функция Format

назад

Format (Expression[, Format[, FirstDayOfWeek[, FirstWeekOfYear]]])
Format$ (Expression[, Format[, FirstDayOfWeek[, FirstWeekOfYear]]])

Функция Format служит для форматирования выражения

Возвращаемое значение

Возвращает значение типа Variant (String), содержащее выражение, отформатированное согласно инструкциям, заданным в описании формата

Параметры
Expression
Обязательный аргумент-любое допустимое выражение, подлежащее форматированию
Format
Необязательный аргумент-любое допустимое именованное или определяемое пользователем выражение формата.При форматировании чисел без указания аргумента Format функция Format выдает тот же результат, что и функция Str, хотя эта функция учитывает национальную настройку. Отличие состоит в том, что при преобразовании положительного числа с помощью функции Format пробел в начале строки (на месте знака числа) теряется, а при преобразовании с помощью функции Str останется
FirstDayOfWeek
Необязательный аргумент-константа, определяющая первый день недели
vbUseSystem=0
Используется значение национальных системных установок
vbSunday=1
Воскресенье(по умолчанию)
vbMonday=2
Понедельник
vbTuesday=3
Вторник
vbWednesday=4
Среда
vbThursday=5
Четверг
vbFriday=6
Пятница
vbSaturday
Суббота
FirstWeekOfYear
Необязательный аргумент-числовая константа, указывающая, какую неделю считать первой в году:
vbUseSystem=0
Используется системная информация
vbFirstJan1=1
Неделя,содержащая 1 января
vbFirstFourDays=2
Первая неделя,содержащая как минимум 4 дня нового года
vbFirstFullWeek=3
Первая полная неделя года

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Форматирование числовых и денежных величин

назад

General Number
Отображает число без разделителей групп разрядов
A=123456.789
Print Format(A,"General Number") ' возвратит 123456.789
Currency
Отображает значение с разделителями групп разрядов (если требуется). В настройке США отображает две цифры справа от десятичного разделителя. Обозначение денежной единицы и ее положение относительно числа определяется текущей национальной настройкой
A=123456.789
Print Format(A,"Currency") ' возвратит 123 456,79р.
Fixed
Отображает по крайней мере одну цифру слева и две цифры справа от десятичного разделителя
A=123456.789
Print Format(A,"Fixed") ' возвратит 123456,79
Standard
Отображает по крайней мере одну цифру слева и две цифры справа от десятичного разделителя, а также разделители групп разрядов
A=123456.789
Print Format(A,"Standard") ' возвратит 123 456,79
Percent
Отображает число, умноженное на 100, со знаком процентов (%), добавленным справа. Всегда отображает две цифры справа от десятичного разделителя
A=1.23
Print Format(A,"Percent") ' возвратит 123,00%
Scientific
Использует стандартную экспоненциальную нотацию
A=123456.789
Print Format(A,"Scientific") ' возвратит 1,23E+00
Примечание:При форматировании стандартными форматами числа округляются, а не усекаются по стандартным правилам округления
Пользовательские форматы числовых величин

Пользовательский формат чисел(аргумент format) может содержать до четырех разделов, возможно пустых, разделенных точками с запятой(;).Каждый раздел предназначен для раздельного форматирования следующих категорий чисел:
Число разделов

1
Данный формат применяется ко всем значениям
2
Первый элемент применяется к положительным и нулевым значениям, а второй к отрицательным значениям
3
Первый элемент применяется к положительным значениям, второй к отрицательным значениям, а третий к нулевым значениям
4
Первый элемент применяется к положительным значениям, второй к отрицательным значениям, третий к нулевым значениям, а четвертый к значениям Null
Пример

' Пример формата,содержащего два раздела-первый применяется к положительным и нулевым значениям, а второй к отрицательным значениям
"$#,##0;($#,##0)"
' Если формат содержит символы точки с запятой, между которыми ничего нет, значения, соответствующие пропущенному элементу, изображаются согласно формату положительных значений. Например, следующий формат отображает положительные и отрицательные значения согласно первому элементу, а вместо нулевых значений отображает строку "Нуль"
"$#,##0;;\Н\у\л\ь"

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Форматирование логических величин

назад

Для вывода логических величин предусмотрены только стандартные форматы
Стандартные форматы логических величин
Yes/No
Отображает значение No(Нет),если число равно нулю, в противном случае отображается Yes(Да)
A=123456.789
Print Format(A,"Yes/No") ' возвратит Да
True/False
Отображает значение False(Ложь),если число равно нулю,в противном случае отображается True(Истина)
A=10
Print Format(A,"True/False") ' возвратит Истина
On/Off
Отображает значение Off(Выкл),если число равно нулю,в противном случае отображается On(Вкл)
A=10
Print Format(A,"On/Off") ' возвратит Вкл
Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Форматирование величин дат и времени

назад

General Date
Отображает дату и\или время. Если число имеет и целую, и дробную часть, то изображаются и дата, и время (например, 04.03.93 17:34); если у числа нет дробной части, то отображается только дата (например, 04.03.93); если у числа нет целой части, то отображается только время (например, 17:34). Фактическое изображение даты и времени определяется системной настройкой
A="27.07.66"
Print Format(A,"General Date") ' возвратит 27.07.66
Long Date
Отображает дату согласно длинному системному формату даты
A="27.07.66"
Print Format(A,"Long Date") ' возвратит 27 Июль 1966 г.
Medium Date
Отображает дату согласно среднему формату даты, установленному для языковой версии системы
A="27.07.66"
Print Format(A,"Medium Date") ' возвратит 27-июл-66
Short Date
Отображает дату согласно краткому системному формату даты
A="27.07.66"
Print Format(A,"Short Date") ' возвратит 27.07.66
Long Time
Отображает время согласно длинному системному формату времени: часы, минуты и секунды
A=0.25
Print Format(A,"Long Time") ' возвратит 6:00:00
Medium Time
Отображает значение времени в 12-часовом формате: часы, минуты и индикатор "AM/PM"(если есть в системных установках)
A=0.6
Print Format(A,"Medium Time") ' возвратит 02:24
Short Time
Отображает значение времени в 24-часовом формате
A=0.6
Print Format(A,"Short Time") ' возвратит 14:24
Пользовательские форматы дат и времени
:
Разделитель компонентов времени. В некоторых национальных настройках применяется другой символ. Разделитель компонентов времени используется для разделения компонентов времени (часов, минут и секунд). Фактический символ, используемый в качестве разделителя компонентов времени, определяется текущей национальной настройкой. В России в качестве разделителя компонентов времени используется двоеточие
/
Разделитель компонентов даты. В некоторых национальный настройках применяется другой символ. Разделитель компонентов даты используется для разделения компонентов даты (дня, месяца и года). Фактический символ, используемый в качестве разделителя компонентов даты, определяется текущей национальной настройкой. В России в качестве разделителя компонентов даты используется точка
c
Отображает дату как ddddd и время как ttttt. Если у числа нет дробной части, то отображается только дата; если у числа нет целой части, то отображается только время
d
Выводит номер дня в месяце, содержащий одну или две цифры (1 – 31)
dd
Выводит номер дня в месяце, содержащий одну или две цифры (01 – 31)
ddd
Выводит сокращенное название дня недели (Пн– Вс)
dddd
Выводит полное название дня недели (Понедельник– Воскресенье)
ddddd
Отображает соответствующую числу полную дату (день, месяц и год) согласно краткому системному формату даты.Эквивалентно стандартному формату Short Date
dddddd
Отображает соответствующую числу полную дату (день, месяц и год) согласно длинному системному формату даты.Эквивалентно стандартному формату Long Date
w
Выводит номер дня недели (по умолчанию, от 1 для воскресенья до 7 для субботы),какой день считать первым определяется аргументом FirtsDayOfWeek
ww
Выводит номер недели года (1 – 54),какую недель считать первой определяется аргументом FirtsWeekOfYear
m
Выводит номер месяца, содержащий одну или две цифры (1 – 12). Если символ m следует сразу после символов h или hh, выводится число минут
mm
Выводит номер месяца, содержащий две цифры (01 – 12). Если символ m следует сразу после символов h или hh, выводится число минут
mmm
Выводит сокращенное название месяца (Янв – Дек)
mmmm
Выводит полное название месяца (Январь – Декабрь)
q
Выводит номер квартала года (1 – 4)
y
Выводит номер дня года (1 – 366)
yy
Выводит номер года, состоящий из двух цифр (00 – 99)
yyyy
Выводит номер года, состоящий из трех или четырех цифр (100 – 9999)
h
Выводит число часов, состоящее из одной или двух цифр (0 – 23)
hh
Выводит число часов, состоящее из двух цифр (00 – 23)
n
Выводит число минут, состоящее из одной или двух цифр (0 – 59)
nn
Выводит число минут, состоящее из двух цифр (00 – 59)
s
Выводит число секунд, состоящее из одной или двух цифр (0 – 59)
ss
Выводит число секунд, состоящее из двух цифр (00 – 59)
ttttt
Отображает полное время (часы, минуты и секунды) согласно текущему системному формату времени. В Microsoft Windows формат времени по умолчанию имеет вид "h:mm:ss"
AM/PM
Использует 12-часовую шкалу, добавляя прописные буквы "AM" (до полудня) или "PM" (между полуднем и полуночью)
am/pm
Использует 12-часовую шкалу, добавляя строчные буквы "am" (до полудня) или "pm" (между полуднем и полуночью)
A/P
Использует 12-часовую шкалу, добавляя прописные буквы "A" (до полудня) или "P" (между полуднем и полуночью)
a/p
Использует 12-часовую шкалу, добавляя строчные буквы "a" (до полудня) или "p" (между полуднем и полуночью)
AMPM
Использует 12-часовую шкалу, добавляя текстовую константу, добавляя текстовую константу, заменяющую в текущей системе индикаторы "AM" (до полудня) или "PM" (между полуднем и полуночью). Регистр изображаемой текстовой строки определяется соответствующими системными настройками. В Microsoft Windows по умолчанию используется формат "AM/PM"
Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Форматирование строковых величин

назад

Текстовые величины не имеют стандартных форматов. Пользовательский формат строковых величин может содержать до двух разделов, возможно пустых. Разделы нумеруются слева направо и отделяются друг от друга точкой с запятой(;).Каждый раздел предназначен для раздельного форматирования непустой(1) или пустой(2) строк.
Если раздел 1 пуст, строка формата игнорируется.
Если раздел 2 не задан, то возвращается пустая строка

Символы форматирования

@
Прототип символа для вывода символа или пробела. Если форматируемая строка содержит символ в позиции, соответствующей символу @ в строке формата, то будет выведен этот символ, в противном случае выводится пробел. Строка формата заполняется справа налево, если в ней нет символа (!):
Пример

' возвращается Русский Проект
Print "Русский" & Format("Проект","@@@@@@@")
&
Прототип символа. Выводит символ или не выводит ничего.. Если форматируемая строка содержит символ в позиции, соответствующей символу (&) в строке формата, то в данной позиции будет выведен этот символ; в противном случае данная позиция останется пустой. Строка формата заполняется справа налево, если в ней нет символа (!)
<
Символ нижнего регистра. Преобразует все символы к нижнему регистру
>
Символ верхнего регистра. Преобразует все символы к нижнему регистру
!
Заполнение строки формата слева направо. По умолчанию строка формата заполняется справа налево
Пример
' возвращается Проект  Проект(с двумя пробелами)
Print "Format("Проект","@@@@@@@@!") "Проект"
Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Функция FormatPercent

назад

FormatPercent(Expression[,NumDigitsAfterDecimal [,IncludeLeadingDigit [,UseParensForNegativeNumbers [,GroupDigits]]]])

Новая функция, которая появилась в Visual Basic 6.0
Служит для форматирования числовых выражений в процентном формате. Эта функция была введена в качестве альтернативы громоздкой функции Format. Используйте функцию FormatPercent в силу ее большей читабельности

Возвращаемое значение

Возвращает число, отформатированное в виде процентного отношения (умноженное на 100), с последующим символом %

Параметры
Часть | Описание
выражение | Обязательный. Форматируемое выражение
NumDigitsAfterDecimal | Необязательный. Числовое значение, задающее число знаков, отображаемых в правой части десятичной дроби. Значением по умолчанию, указывающим, что применяются национальные установки компьютера, является –1
IncludeLeadingDigit | Необязательный. Константа с тремя значениями, которая задает наличие или отсутствие начального нуля при отображении дробных значений. См. значения в разделе «Установки»
UseParensForNegativeNumbers | Необязательный. Константа с тремя значениями, которая указывает, надо ли заключать в круглые скобки отрицательные значения. См. значения в разделе «Установки»
GroupDigits | Необязательный. Константа с тремя значениями, указывающая на необходимость группирования цифр с применением разделителя групп, заданного в национальных установках компьютера. См. значения в разделе «Установки»

Установки

Аргументы IncludeLeadingDigit, UseParensForNegativeNumbers и GroupDigits имеют следующие установки

Константа | Значение | Описание
TristateTrue | –1 | True
TristateFalse | 0 | False
TristateUseDefault | –2 | Применяется установка, соответствующая национальным установкам для компьютера

Примечания

При пропуске одного или нескольких необязательных параметров значения для них присваиваются в соответствии с национальными установками компьютера

Замечание Все сведения об установках содержатся на закладке Regional Settings Number
Пример
' В данном примере функция FormatPercent
' используется для форматирования числа 50
Print FormatPercent(50) 'возвращает 500,00%

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


Nick[ec]HomePage >>> VisualBasic >>> Функции VisualBasic

Символы форматирования, применяемые для создания пользовательских форматов числовых величин

назад

0
Прототип цифры. Выводит цифру или нуль. Если форматируемое выражение содержит цифру в позиции, соответствующей прототипу "0" в строке формата, то в данной позиции будет выведена эта цифра; в противном случае в данной позиции будет выведен нуль. Если число цифр в целой или дробной части форматируемого числа меньше, чем число прототипов "0" слева или справа от десятичного разделителя в строке формата, соответственно, то в начало или конец числа будут добавлены недостающие нули. Если количество цифр в дробной части форматируемого числа больше, чем количество прототипов "0" справа от десятичного разделителя в строке формата, то число будет округлено с соответствующей точностью. Если количество цифр в целой части форматируемого числа больше, чем количество прототипов "0" слева от десятичного разделителя в строке формата, то лишние цифры будут выведены без изменения
Print Format(6.789, "00.0000") ' возвратит 06,7890
#
Прототип цифры. Выводит цифру или не выводит ничего. Если форматируемое выражение содержит цифру в позиции, соответствующей символу # в строке формата, то в данной позиции будет выведена цифра; в противном случае данная позиция останется пустой. Отличие данного символа от символа формата "0" состоит в том, что если количество цифр в целой или дробной части форматируемого числа меньше, чем число символов "#" слева или справа от десятичного разделителя в строке формата, соответственно, то недостающие нули в начале или конце числа добавлены не будут
Print Format(6.789, "##.0000") ' возвратит 6,7890
.
Десятичный разделитель. В некоторых национальных настройках десятичным разделителем служит запятая. Десятичный разделитель указывает, сколько цифр следует вывести в целой и дробной части форматируемого числа, т.е. слева и справа от десятичного разделителя. Если строка формата содержит слева от десятичного разделителя только символы "#", то число, меньшее единицы, при выводе будет начинаться с десятичного разделителя. Если требуется, чтобы дробные числа всегда изображались с начальным нулем перед десятичным разделителем, следует использовать символ формата "0" в качестве первого символа строки числового формата. Фактический символ, используемый в качестве десятичного разделителя, определяется установленным в системе числовым форматом. В России в качестве десятичного разделителя используется запятая
Print Format(0.789, "##.0000") ' возвратит ,7890
%
Процентный формат. Выражение умножается на 100. Символ процентов (%) выводится в позиции, соответствующей позиции прототипа в строке формата
Print Format(0.17, "0%") ' возвратит 17%
,
Разделитель групп разрядов. В некоторых национальных настройках в качестве разделителя групп разрядов используется точка. Разделитель групп разрядов разделяет позиции тысяч и сотен в числе, целая часть которого состоит из четырех или большего числа цифр. Стандартное применение разделителя групп разрядов задается в строке формата, в которой пробел окружен символами вывода цифры (0 или #). Два соседних разделителя групп разрядов или разделитель групп разрядов, стоящие сразу перед десятичным разделителем (даже если символ десятичного разделителя не указан явно), означают, что масштаб числа следует изменить, разделив его указанное число раз на 1000 и округлив по мере надобности. Такой способ позволяет выводить большие числа. Например, строка формата "##0,," отображает сто миллионов как 100, а числа, меньшие одного миллиона, как 0. Два соседних разделителя групп разрядов, находящихся в любой другой позиции, обрабатываются как один разделитель групп разрядов. Фактический символ, используемый в качестве разделителя групп разрядов, определяется установленным в системе числовым форматом. В России в качестве разделителя групп разрядов используется пробел
:
Разделитель компонентов времени. В некоторых национальный настройках в качестве разделителя компонентов времени используется другой символ. Разделитель компонентов времени используется для разделения компонентов времени (часов, минут и секунд). Фактический символ, используемый в качестве разделителя компонентов времени, определяется текущей национальной настройкой. В России в качестве разделителя компонентов времени используется двоеточие
Print Format(Now, "h:m:s") ' возвратит к примеру 11:23:35
/
Разделитель компонентов даты. В некоторых национальный настройках в качестве разделителя компонентов даты используется другой символ. Разделитель компонентов даты используется для разделения компонентов даты (дня, месяца и года). Фактический символ, используемый в качестве разделителя компонентов даты, определяется текущей национальной настройкой. В России в качестве разделителя компонентов даты используется точка
E- E+ e- e+
Экспоненциальный формат. Если строка формата содержит хотя бы один прототип цифры (0 или #) справа от символов "E-", "E+", "e-" или "e+", то число выводится в экспоненциальном формате, а между числом и показателем степени помещаются символы "E" или "e". Число цифр в показателе степени определяется числом символов вывода цифры справа от символа экспоненциального формата. Для вывода знака минус (-) перед отрицательными значениями показателя степени следует использовать символы "E-" или "e-"; в этом случае знак перед положительными значениями показателя степени не ставится. Для вывода знака плюс перед положительными значениями показателя степени и знака минус перед отрицательными значениями показателя степени следует использовать символы "E+" или "e+"
- + $ ()
Вывод указанного символа. Для вывода любого не перечисленных здесь символов следует поместить перед ним символ обратной косой черты (\) или заключить символ в прямые кавычки (" ")
\
Вывод следующего символа из строки формата. Многие символы в строке формата имеют специальное назначение и не могут быть выведены в явном виде, если перед ними не стоит символ обратной косой черта. Сам символ "обратная косая черта" при этом не отображается. Наличие данного символа форматирования эквивалентно заключению следующего за ним в строке формата символа в прямые кавычки. Для вывода самого символа "обратная косая черта" следует указать его дважды (\\).Примерами символов, которые не могут быть включены в строку форматирования явным образом, являются символы форматирования даты и времени (a, c, d, h, m, n, p, q, s, t, w, y, / и :), символы форматирования чисел (#, 0, %, E, e, запятая и точка) и символы форматирования строк (@, &, <, > и !)
"ABC"
Вывод строки, заключенной в прямые кавычки (" "). Для представления кавычек в аргументе формат в программе необходимо использовать функцию Chr(34) (34 является кодом символа прямых кавычек ("))

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


форматный вывод

Организация форматного вывода значений

на главную страницу

Функция формат

Форматирование числовых и денежных величин

Форматирование логических величин

Форматирование строковых величин

Форматирование величин дат и времени

Функция FormatCurrency

Функция FormatDateTime

Функция FormatNumber

Функция FormatPercent

Символы форматирования числовых величин

Материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.


Изучение интерфейса и правил работы в пакете Derive

Лабораторная работа: Изучение среды и основ работы в Visual Basic

начало

назад

вперед

конец

вопросы

задания

Цель работы

Целью работы является изучение основных компонентов интегрированной среды разработки приложений Visual Basic, и приобретение начальных навыков работы в среде при создании простейших приложений.

Порядок выполнения работ

  • Запустить программу Visual Basic.

  • В порядке, описанном в методических указаниях, изучить основные компоненты интегрированной среды разработки приложений Visual Basic.

  • Выполнить задания, приведенные в методических указаниях.

  • Сохранить результаты работы на личной дискете.

  • Показать результаты работы преподавателю.

  • Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Задание 1 - запуск Visual Basic и создание нового проекта в Visual Basic

  • Задание 2 - изучение основных компонентов интерфейса Visual Basic

  • Задание 3 - изучение окна конструктора форм и панели элементов управления

  • Задание 4 - создание формы приложения с размещенными на ней объектами и сохранение проекта

  • Задание 5 - запуск приложения и изучение окна редактора исходного кода

  • Задание 6 - создание простейшего приложения

Требования к отчету

Отчет по лабораторной работе - это краткое описание основных компонентов интегрированной среды разработки приложений Visual Basic и файлы результатов выполнения заданий.

Дополнительный материал

Описание компонентов среды Visual Basic 6.0

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы

задания


Заключение и выводы

начало

назад

вперед

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены основные компоненты интегрированной среды разработки приложений Visual Basic, изучены приемы разработки макета формы приложения с размещением на ней стандартных компонентов графического интерфейса прикладных программ, создано простейшее приложение.

Были рассмотрены темы:

  • Задание 1 - запуск Visual Basic и создание нового проекта в Visual Basic

  • Задание 2 - изучение основных компонентов интерфейса Visual Basic

  • Задание 3 - изучение окна конструктора форм и панели элементов управления

  • Задание 4 - создание формы приложения с размещенными на ней объектами и сохранение проекта

  • Задание 5 - запуск приложения и изучение окна редактора исходного кода

  • Задание 6 - создание простейшего приложения

По результатам работы должен быть составлен отчет, содержащий:

  • название, цель и задачи лабораторной работы;

  • краткое описание основных компонентов интегрированной среды разработки приложений Visual Basic;

  • описание приемов создания формы приложения;

  • файл с проектом, представляющим собой форму с размещенными на ней объектами (на дискете);

  • файл с проектом простейшего приложения (на дискете);

  • заключения и выводы.

Дополнительный материал

Описание компонентов среды Visual Basic 6.0

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы

задания


Вопросы к лабораторной работе

начало

назад

вперед

конец

вопросы

задания

  1. Чем Visual Basic отличается от других версий языка Basic?

  2. Что в среде Visual Basic принято называть проектами?

  3. Каким образом можно создать новый проект в среде Visual Basic?

  4. Назовите основные рабочие окна среды Visual Basic

  5. Для чего нужно окно конструктора форм?

  6. Каким образом можно открыть окно конструктора форм?

  7. Для чего нужна сетка в окне конструктора форм?

  8. Как изменить шаг сетки окна конструктора форм?

  9. Для чего нужна панель элементов управления?

  10. Как поместить новые компоненты на панель элементов управления?

  11. Как показать в окне выбора компонентов только активные (отмеченные ключами) пункты?

  12. Как разместить объекты на форме?

  13. Как сохранить подготовленный проект?

  14. Что надо сделать для запуска (выполнения) созданного в Visual Basic приложения?

  15. Для чего предназначен редактор исходного кода?

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Запуск Visual Basic и создание нового проекта (шаблон Standard EXE).

начало

назад

вперед

конец

вопросы

задания

Запустить программу Visual Basic 6.0 можно: из главного меню Windows; используя ярлык на рабочем столе; выполнив файл VB6.EXE

ЗАДАНИЕ 1.
Запустите Visual Basic, используя один из приемов запуска приложений в Windows.

При запуске Visual Basic 6.0 (в дальнейшем изложении - Visual Basic, без указания версии) на экране появляется диалоговое окно New Project (Новый проект), используя которое можно:

- создать новый проект используя шаблоны создания проекта (вкладка New)
- создать новый проект используя мастера создания проекта (вкладка New)
- открыть ранее созданный проект (вкладки Existing и Recent)

Окно создания проекта содержит три вкладки следующего назначения:

- New (Новый) — содержит шаблоны и мастера для создания нового проекта;

- Existing (Существующий) — позволяет открыть ранее созданный проект или проекты-примеры, поставляемые с Visual Basic. Вкладка имеет раскрывающийся список, с помощью которого можно выбрать любую папку на имеющихся ресурсах компьютера;

- Recent (Недавно созданный) — содержит список проектов, открывавшихся в последнее время.

По умолчанию ключ (Don't show dialog in the future), расположенный в нижней части окна выключен.
Выключенный ключ Don't show dialog in the future (не показывать этот диалог в будущем) означает, что это окно будет появляться всегда при запуске Visual Basic
Включенный ключ Don't show dialog in the future (не показывать этот диалог в будущем) означает, что это окно не будет появляться при запуске Visual Basic. НЕ включате этот ключ.

Типы шаблонов и мастеров проекта:

- Standard EXE — стандартное выполняемое приложение;

- ActiveX EXE — выполняемое приложение ActiveX;

- ActiveX DLL — динамическая библиотека ActiveX;

- ActiveX Control — элемент управления ActiveX;

- VB Application Wizard — мастер приложений;

- VB Wizard Manager — мастер создания пользовательских мастеров;

- Data Project — проект управления базой данных;

- IIS Application — приложение, размещаемоt на сервере Web-узла (IIS — Internet Information Server);

- Addin — надстройка, дополнительные утилиты, расширяющие возможности приложений;

- ActiveX Document DLL — динамическая библиотека документов ActiveX;

- ActiveX Document EXE — выполняемое приложение документов ActiveX;

- DHTML Application — приложение, создающее динамические HTML-страницы.

ЗАДАНИЕ 2.
 Создайте новый проект приложения, выбрав в окне создания проекта вкладку New шаблон Standard EXE.

начало

назад

вперед

конец

вопросы

задания


Запуск Visual Basic

назад
Из главного меню Windows. Для этого выполните следующие действия.

1. Нажмите кнопку Пуск, расположенную на панели задач Windows.

2. В открывшемся главном меню Windows:
- выберите подменю Программы;
- в нем Microsoft Visual Basic 6.0 (или, возможно, Microsoft Visual Studio 6.0)
- затем выберите Microsoft Visual Basic 6.0

Используя ярлык на рабочем столе. (если этот ярлык был создан и помещен на рабочий стол).
Выполнив файл VB6.EXE c:\Program Files\Microsoft Visual Studio\VB98\VB6.EXE (путь указан для установки программы Visual Basic по умолчанию).

назад


Для запуска программы из главного меню Windows выполните следующие действия

Основные компоненты интерфейса Visual Basic

начало

назад

вперед

конец

вопросы

задания

После выбора типа проекта (в нашем случае Standard EXE) мы перейдем непосредственно в инструментальную среду проектирования Visual Basic. Ее внешний вид показан на рисунке.

Главное меню (текстовое меню), как и во всех приложениях Microsoft, представляет собой линейку раскрывающихся меню. Оно содержит следующие основные команды: File (Файл), Edit (Правка), View (Вид), Project (Проект), Format (Формат), Debug (Отладка), Run (Запуск), Query (Запрос), Diagram (Диаграмма), Tools (Сервис), Add-Ins (Надстройки), Window (Окно), Help (Справка).

Наиболее часто используемые команды меню отображены в виде кнопок со значками на панели инструментов (пиктографическом меню), размещенной ниже меню.

ЗАДАНИЕ 3.
Используя пиктографическое меню и пункт View (Вид) главного меню, откройте основные рабочие окна среды Visual Basic и расположите их на экране так, чтобы они не перекрывали друг друга.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Текстовое и пиктографическое меню

назад

Главное меню

Наиболее часто используемые команды меню отображены в виде кнопок со значками на стандартной панели инструментов, размещенной ниже меню. Рассмотрим основные команды главного меню.

Меню File (Файл) содержит команды для работы с файлами проекта. Используя эти команды, можно выполнять такие действия, как создание нового проекта, открытие проекта для внесения изменений, добавление проекта для параллельной работы над несколькими проектами или копирование форм из проекта в проект и т. п. Все команды этого меню перечислены в табл. 1- 13 Приложения.

Меню Edit (Правка) содержит команды, предназначенные для редактирования. Часть из них соответствует подобным командам редактирования других приложений Microsoft, например, отменить предыдущую команду, повторить предыдущую команду, вырезать фрагмент текста, скопировать фрагмент в буфер обмена. В составе этого меню целый набор команд для работы с таблицами базы данных: добавлять и удалять поля, назначать первичный ключ в таблице базы данных.

Меню View (Вид) содержит команды вызова окон и панелей инструментальной среды Visual Basic 6.

Меню Project (Проект) содержит команды управления проектом и его элементами. Они позволяют добавить в проект и удалить из него элементы проекта, такие как форма, программный модуль, класс и другие. С помощью команд данного меню вы также можете открыть окно свойств приложения, добавить ссылки на подключаемые библиотеки, добавить дополнительные компоненты на панель элементов.

Меню Format (Формат) содержит большое количество команд форматирования объектов в форме.

Меню Debug (Отладка) содержит команды, предназначенные для отладки приложения. Используя команды этого меню, можно установить точки останова программы и проверить значения выражении и переменных, выполняя программу по шагам.

Меню Run (Запуск) содержит команды управления запуском приложения. Используя команды данного меню, можно запустить приложение на выполнение с компиляцией или без компиляции, приостановить или прервать выполнение приложения.

Меню Query (Запрос) содержит команды создания и выполнения запросов к базе данных. При помощи этого меню, например, можно выполнить запрос, преобразовать результаты запроса в табличный вид.

Меню Diagram (Диаграмма) содержит команды построения диаграммы, отображающей структуру базы данных.

Меню Tools (Сервис) содержит команды управления настройками инструментария среды Visual Basic 6. Они позволяют добавить процедуру и определять ее атрибуты, вызвать окно редактора меню, изменить настройки программы в диалоговом окне Options (Параметры), а также управлять хранилищем проектов SourseSafe.

Меню Add-Ins (Надстройки) содержит команды вызова дополнительных утилит, часто называемых надстройками (add-ins).

Меню Window (Окно) содержит стандартные команды управления окнами. При вызове окон приложения меню Window пополняется соответствующими командами активизации окон приложения. При этом команды активизации окон называются по именам открытых окон.

Меню Help (Справка) содержит команды вызова справочной системы Visual Basic 6. При помощи этого меню можно вызывать справочную систему с различными вариантами представления информации. Отличие между ними состоит в открывающейся по умолчанию вкладке.

Стандартная панель инструментов

Команды, которые часто используются при работе, можно разместить в виде кнопок на панели инструментов. Можно также исключить из панели редко применяемые команды.

Кнопки панели инструментов снабжены всплывающими подсказками.

Стандартная панель инструментов, расположенная под главным меню, показана в том виде, в каком она настроена при установке Visual Basic.

Если эта панель отсутствует в главном окне программы, для ее отображения в меню View (Вид) выберите команду Toolbars (Панели инструментов), а затем значение Standard (Стандартная).

На стандартной панели инструментов расположены кнопки для вызова наиболее часто употребляемых команд меню. Вы можете изменить расположение стандартной панели инструментов, разместив ее в нижней части главного окна, справа или слева. Для этого с помощью кнопки мыши захватите любую границу панели и переместите ее в любое удобное для вас место.

назад


Для запуска программы из главного меню Windows выполните следующие действия

Окна: конструктора форм и панель элементов управления

начало

назад

вперед

конец

вопросы

задания

Основными рабочими элементами среды Visual Basic, с помощью которых выполняется визуальное проектирование приложения являются окно конструктора форм и панель элементов управления.

Окно конструктора форм

В окне конструктора форм визуально конструируются все формы приложения с использованием инструментария среды разработки. Окно конструктора форм открывается автоматически после загрузки среды Visual Basic.

Если окно закрыто, вызвать его можно из главного меню командой Object (Объект) меню View (Вид) или командой View Object контекстного меню объекта, находящегося в группе Forms в проводнике проекта.

Для точного позиционирования объектов в форме в окне имеется сетка. Размер ячеек сетки можно менять. При необходимости сетку можно отключать, воспользовавшись параметрами диалогового окна Options, открываемого командой Options (Параметры) из меню View (Вид).

Размер формы в окне можно изменять, используя маркеры выделения формы и мышь. Для изменения размера формы необходимо установить указатель мыши на маркер и, когда он примет вид двунаправленной стрелки, перемещать до получения требуемого размера.

Панель элементов управления

Панель элементов управления открывается автоматически после загрузки среды Visual Basic. Если панель элементов закрыта, вызывать ее можно из меню View (Вид) командой Toolbox (Панель элементов управления) или воспользоваться кнопкой Toolbox на стандартной панели инструментов.

В составе панели элементов управления содержатся основные элементы (компоненты), размещаемые на форме при ее проектировании — метки, текстовые поля, кнопки, списки и другие элементы для быстрого визуального проектирования макета формы.

Для размещения элементов управления в форме с помощью панели элементов выполните следующие действия:

1. Выделите требуемый элемент управления с помощью мыши.

2. Перейдите в окно конструктора форм. Указатель мыши при этом превратится в крестик, при помощи которого можно установить местоположение размещаемого объекта. Левой кнопкой мыши зафиксируйте позицию нового объекта и, удерживая кнопку, задайте размеры объекта.

Поместить на панель элементов управления компоненты можно используя пункт Components...(Компоненты) контекстного меню, вызываемого правой кнопкой мыши при нахождении курсора на свободной области панели элементов управления. При этом откроется окно выбора компонентов.

Окно выбора компонентов содержит три вкладки:

Controls (Средства управления) - позволяет выбрать компоненты, размещаемые на панели элементов управления. Компоненты хранятся в файлах, имеющих расширение .OCX или в файлах динамических библиотек .DLL. Выбрать файлы можно также вручную, используя кнопку Browse... (Просмотр)

Designers (Проектировщики) - позволяет подключить динамические библиотеки, необходимые для работы создаваемого в среде Visual Basic приложения.

Insertable Objects (Встраиваемые объекты) - позволяет выбрать компоненты, представляющие собой OLE - объекты или программные приложения. Компоненты хранятся в файлах, имеющих расширение .OCX, в файлах динамических библиотек .DLL или в исполняемых файлах .EXE.

Ключ Select Items Only (Только выбранные пункты) позволяет исключить из списка компонентов пункты, не отмеченные ключами выбора.

ЗАДАНИЕ 4.
Разместите на панели элементов управления компоненты Microsoft Windows Commom Controls 6.0.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Создание формы приложения и сохранение проекта

начало

назад

вперед

конец

вопросы

задания

Создание любого приложения в Visual Basic начинается с создания проекта. Проектом является совокупность файлов, входящих в приложение и хранящих информацию о его компонентах. Проект стандартного приложения создается на основе шаблона Standard EXE.

Большинство приложений, созданных в Visual Basic, работают в интерактивном режиме. На экран выводится информация, предназначенная для пользователя программы, и ожидается его ответная реакция в виде ввода данных или команд. Интерактивное приложение в Visual Basic создается на базе формы, являющейся, как правило, основным окном интерфейса, с элементами управления, позволяющими осуществлять взаимодействие с пользователями.

В Visual Basic при создании форм разработчик может использовать шаблоны и мастера, а также конструктор форм. Конструктор форм предназначен для самостоятельной разработки формы с заданными свойствами или для изменения формы, созданной с помощью мастера.

Размещение элементов управления в форме осуществляется следующим образом:

1. На панели элементов управления выбирается необходимый компонент, на основе которого будет создан объект, размещаемый на форме, например TextBox

2. Курсор, принявший вид перекрестия, устанавливается в место предполагаемого размещения объекта в форме.

3. При нажатой левой кнопке мыши прорисовывается рамка требуемого размера. При этом рядом с курсором мыши появляются текущие размеры создаваемого объекта.

4. После того, как кнопка мыши будет отпущена, на форме появится изображение объекта.

Для сохранения проекта выполните следующие действия:

1. В меню File (Файл) выберите команду Save Project (Сохранить проект) или нажмите кнопку Save Project на стандартной панели инструментов.

2. В открывшемся диалоговом окне Save File As список Тип файла содержит значение Form Files, указывая, что сохраняется входящая в приложение форма (файл с расширением .frm). Используя раскрывающийся список Папка, выберите папку, в которой будет сохранена форма, затем в поле Имя файла введите имя формы и нажмите кнопку Сохранить.

3. Так как никаких компонентов, кроме формы, новое приложение не содержит, появляется диалоговое окно Save Project As (Сохранить проект как) для сохранения самого проекта (файлы с расширениями .vbp и vpw). По умолчанию в списке Папка выбрана папка, в которой сохранили форму. Введите наименование проекта и нажмите кнопку Сохранить.

При последующем сохранении проекта Visual Basic по умолчанию сохраняет файлы под их именами. Если же в проект с момента последнего сохранения были добавлены новые компоненты, откроется диалоговое окно Save File As для присвоения им имен.

Замечание: Для облегчения работы с проектом и входящими в его состав файлами, прежде чем сохранять проект, создайте отдельную папку, в которой затем и сохраните все файлы.

ЗАДАНИЕ 5.
Создайте форму, показанную на рисунке, разместив на ней необходимые объекты и сохраните проект на диске в папке, указанной преподавателем.

Замечание: при создании формы используйте компоненты панели элементов управления General и Microsoft Windows Commom Controls 6.0

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Запуск приложения и работа с окном редактора исходного кода

начало

назад

вперед

конец

вопросы

задания

Для запуска (выполнения) созданного в Visual Basic приложения можно:

- выполнить команду Start , расположенную в пункте Run (Выполнить) главного меню;
- нажать кнопку Start на стандартной панели инструментов Visual Basic;
- нажать клавишу <F5> на клавиатуре ПК.

После этого приложение начнет выполнять запрограммированные в нем действия.

ЗАДАНИЕ 6.
Выполните созданное Вами приложение.

После запуска Вашего приложения (созданная Вами форма) приложения Вы сможете:

- заполнять текстовое поле;

- устанавливать значения ключей (флажков) и переключателей;

- выбирать диски;

- перемещаться по папок и выбирать их

- перемещаться по списку фацлов и выбирать их

- перемещать ползунок по шкале вправо и влево.

- активизировать командные кнопки, нажимая их;

Однако при этом никакой взаимосвязи между объектами формы не будет и никаких других действий это приложение выполнять не будет, поскольку для объектов не созданы тексты (коды) процедур.

Для завершения работы приложения можно:

- нажать на крестик в правом верхнем углу формы;
- выполнить команду End , расположенную в пункте Run главного меню;
- нажать кнопку End на стандартной панели инструментов Visual Basic;
- нажать сочетание клавиш Alt + <F4> на клавиатуре ПК.

Окно редактора исходного кода

Редактор кода Code (Код) — это мощный встроенный редактор с удобными средствами ввода текста (исходного кода) программы.

Из меню View (Вид) перейти в редактор кода можно с помощью команды Code (Код). Для быстрого открытия окна редактора кода достаточно дважды щелкнуть левой кнопкой мыши, установив указатель на форме приложения. После начала редактирование кода программы имя открытого окна появляется и в списке команд перехода между окнами Window (Окно) главного меню. Переход между макетом и окном редактора кода можно выполнять, используя список меню Window.

ЗАДАНИЕ 7.
Откройте окно редактора исходного кода (Code) и просмотрите заготовки текста процедур, автоматически сгенерированные средой Visual Basic для созданной Вами формы.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Создание простейшего приложения

начало

назад

вперед

конец

вопросы

задания

Задача: создайте приложение, позволяющее по заданному пользователем программы радиусу R вычислять площадь S и длину окружности L. (S=3.14*R*R; L=2*3.14*R)
Для создания приложения подготовим форму, содержащую два объекта:

1. Кнопку (CommandButton)
2. Текстовое поле (TextBox)

В окне редактора исходного кода ( в процедуре Private Sub Command1_Click() ) наберем текст программы:
ЗАДАНИЕ 8.
Выполните приложение, введите в Текстовое поле (TextBox) вместо слова Text1 некоторое число, например 27, щелкните мышкой по Кнопке (CommandButton) Command1 и получите результат.

начало

назад

вперед

конец

вопросы

задания


Изучение интерфейса и правил работы в пакете Derive

Лабораторная работ а: Организация ввода-вывода данных, изменение свойств объектов

начало

назад

вперед

конец

вопросы

задания

Цель работы

Целью работы является изучение основных компонентов интегрированной среды разработки приложений Visual Basic, и приобретение начальных навыков работы в среде при создании простейших приложений.

Порядок выполнения работ

  • Запустить программу Visual Basic.

  • В порядке, описанном в методических указаниях, изучить правила организации ввода-вывода данных в Visual Basic.

  • Выполнить задания, приведенные в методических указаниях.

  • Сохранить указанные в заданиях результаты работы на личной дискете.

  • Показать результаты работы преподавателю.

  • Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Задание 1 - изучение способов ввода данных в Visual Basic

  • Задание 2 - изучение способов вывода результатов в Visual Basic

  • Задание 3 - изучение возможностей организации форматного вывода данных

  • Задание 4 - изменение названий объектов

  • Задание 5 - создание простого приложения

Требования к отчету

Отчет по лабораторной работе - это краткое описание основных этапов выполнения работы. Он долджен содержать:

  • название, цель и задачи лабораторной работы;

  • описание приемов организации ввода-вывода данных в Visual Basic;

  • файлы проектов с результатами выполнения заданий.

Дополнительный материал:

Организация форматного вывода данных

Описание компонентов среды Visual Basic 6.0

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы

задания


Заключение и выводы

начало

назад

вперед

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены основные приемы организации ввода данных и вывода значений (результатов работы программы) в интегрированной среде разработки приложений Visual Basic, изучены правила организации форматного вывода значений создано приложение, использующее ввод-вывод данных.

Были рассмотрены темы:

  • Задание 1 - изучение способов ввода данных в Visual Basic

  • Задание 2 - изучение способов вывода результатов в Visual Basic

  • Задание 3 - изучение возможностей организации форматного вывода данных

  • Задание 4 - создание простого приложения

По результатам работы должен быть составлен отчет, содержащий:

  • название, цель и задачи лабораторной работы;

  • описание приемов организации ввода-вывода данных в Visual Basic;

  • файлы проектов с результатами выполнения заданий.

Дополнительный материал:

Организация форматного вывода данных

Описание компонентов среды Visual Basic 6.0

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы

задания


Вопросы к лабораторной работе

начало

назад

вперед

конец

вопросы

задания

  1. Какие способы организации ввода данных в Visual Basic Вы знаете?

  2. Как организовать ввод данных с помощью функции функции InputBox?

  3. Как организовать ввод данных с помощью элемента управления TextBox?

  4. Какие способы организации ввода данных в Visual Basic Вы знаете?

  5. Как организовать ввод значения переменной на форму?

  6. Как организовать ввод значения переменной в окно PictureBox?

  7. Как организовать ввод значения переменной в окно TextBox?

  8. Для чего функция Format?

  9. Приведите общий вид функции Format и объясните назначение ее параметров?

  10. Какие символы форматирования применяются для создания пользовательских форматов числовых величин?

начало

назад

вперед

конец

вопросы

задания


Задания к лабораторной работе

Все задания к лабораторной работе

начало

назад

вперед

конец

вопросы

задания

ЗАДАНИЕ 1.
Создайте новый проект приложения и реализуйте ввод данных с помощью функции InputBox и элемента управления TextBox. Сохраните проект на диске. Пример программы.

ЗАДАНИЕ 2.
Создайте форму, разместив на ней компоненты PictureBox и TextBox. Выполните вывод значений переменной на форму, в окно PictureBox и в окно TextBox.

ЗАДАНИЕ 3.
 Используя ранее созданный проект, выполните форматный вывод значений переменной на форму, в окно PictureBox и в окно TextBox. Сохраните проект на диске.
ЗАДАНИЕ 4.
Создайте форму с 3-4 объектами и измените их свойства. Сохраните проект на диске.
ЗАДАНИЕ 5.
Создайте проект и напишите программу вычисления площади сектора Спроектируйте свой, отличающийся от приведенного в примере, программный интерфейс. Используйте различные варианты организации ввода-вывода данных. Для вывода результатов используйте форматный вывод.
Сохраните проект на диске. Пример программы.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Организация ввода данных

начало

назад

вперед

конец

вопросы

задания

Практически любая создаваемая программа, выполняющая заложенные в ней действия должна получить от пользователя исходные данные для работы. Ввод данных как правило осуществляется сразу после запуска программы. Данные могут быт также запрошены для продолжения выполнения программы в процессе ее работы.

С помощью функции InputBox

1. Из модального диалогового окна по запросу приложения сразу после его запуска. При этом не имеет значения, какие объекты расположены на форме, она может быть даже пустой.

 Для этого необходимо в процедуру формы записать оператор (здесь и далее программный код, который должен быть написаны разработчиком приложения выделен жирным шрифтом):

Private Sub Form_Load()
x = InputBox("Введите значение переменной X", "Ввод данных")
End Sub

2. Из модального диалогового окна, после наступления некоторого события, активизирующего InputBox, например при нажатии кнопки на форме.

 Для этого необходимо в процедуру командной кнопки записать оператор:

Private Sub Command1_Click()
x = InputBox("Введите значение переменной X", "Ввод данных")
End Sub

Замечание: Функция InputBox возвращает строковое значение, поэтому если вы вводите числа, то лучше использовать функцию Val, которая преобразует строку в число:
x=Val(InputBox("Введите значение переменной X", "Ввод данных"))

С помощью элемента управления TextBox

Для этого необходимо в процедуру элемента TextBox записать оператор:

Private Sub Command1_Click()
a = Text1
End Sub

ЗАДАНИЕ 1.
 Создайте новый проект приложения и реализуйте ввод данных с помощью функции InputBox и элемента управления TextBox. Сохраните проект на диске.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Организация вывода результатов

начало

назад

вперед

конец

вопросы

задания

Вывод значения переменной на форму с помощью процедуры Print

Private Sub Command1_Click()
x = 127
Print "Значение x="; x
End Sub

Вывод значения переменной в окно PictureBox с использованием метода Print

 Private Sub Command1_Click()
x = 127
Picture1.Print "Значение x=";x
End Sub

Вывод значения переменной в окно TextBox

Private Sub Command1_Click()
x = -326.597
Text1 = x
End Sub

Вывод значения переменной на метку Label

Форма с размещенной на ней меткой Label1

Private Sub Command1_Click()
St = "Значение Х = "
X = -567.12343
Label1.Caption = St & X
End Sub
ЗАДАНИЕ 2.
Создайте форму, разместив на ней компоненты PictureBox и TextBox. Выполните вывод значений переменной на форму, в окно PictureBox и в окно TextBox и на метку Label.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Форматы вывода данных

начало

назад

вперед

конец

вопросы

задания

Для форматирования данных (выражения) в Visual Basic используется функция Format.

Функция Format возвращает значение типа Variant (String), содержащее выражение, отформатированное согласно инструкциям, заданным в описании формата

Общий вид функции (в скобках указаны необязательные параметры, которые можно опустить при обращении к функции):
Format (Expression[, Format[, FirstDayOfWeek[, FirstWeekOfYear]]])

Параметры функции

Параметр Expression
Обязательный аргумент-любое допустимое выражение, подлежащее форматированию.
Параметр Format
Необязательный аргумент-любое допустимое именованное или определяемое пользователем выражение формата. При форматировании чисел без указания аргумента Format функция Format выдает тот же результат, что и функция Str(number) - Возвращает строку, представляющую число), хотя эта функция учитывает национальную настройку. Отличие состоит в том, что при преобразовании положительного числа с помощью функции Format пробел в начале строки (на месте знака числа) теряется, а при преобразовании с помощью функции Str останется

Символы форматирования, применяемые для создания пользовательских форматов числовых величин

0
Прототип цифры. Выводит цифру или нуль.
Print Format(6.789, "00.0000") ' возвратит 06,7890
#
Прототип цифры. Выводит цифру или не выводит ничего.
Print Format(6.789, "##.0000") ' возвратит 6,7890
.
Десятичный разделитель. В некоторых национальных настройках десятичным разделителем служит запятая. Десятичный разделитель указывает, сколько цифр следует вывести в целой и дробной части форматируемого числа, т.е. слева и справа от десятичного разделителя.
Print Format(0.789, "##.0000") ' возвратит ,7890
%
Процентный формат. Выражение умножается на 100. Символ процентов (%) выводится в позиции, соответствующей позиции прототипа в строке формата
Print Format(0.17, "0%") ' возвратит 17%
,
Разделитель групп разрядов. В некоторых национальных настройках в качестве разделителя групп разрядов используется точка. Разделитель групп разрядов разделяет позиции тысяч и сотен в числе, целая часть которого состоит из четырех или большего числа цифр.
:
Разделитель компонентов времени. В некоторых национальный настройках в качестве разделителя компонентов времени используется другой символ.
Print Format(Now, "h:m:s") ' возвратит к примеру 11:23:35
/
Разделитель компонентов даты. В некоторых национальный настройках в качестве разделителя компонентов даты используется другой символ.
E- E+ e- e+
Экспоненциальный формат. Для вывода знака плюс перед положительными значениями показателя степени и знака минус перед отрицательными значениями показателя степени следует использовать символы "E+" или "e+"
- + $ ()
Вывод указанного символа. Для вывода любого не перечисленных здесь символов следует поместить перед ним символ обратной косой черты (\) или заключить символ в прямые кавычки (" ")
\
Вывод следующего символа из строки формата. Примерами символов, которые не могут быть включены в строку форматирования явным образом, являются символы форматирования даты и времени (a, c, d, h, m, n, p, q, s, t, w, y, / и :), символы форматирования чисел (#, 0, %, E, e, запятая и точка) и символы форматирования строк (@, &, <, > и !)
"ABC"
Вывод строки, заключенной в прямые кавычки (" "). Для представления кавычек в аргументе формат в программе необходимо использовать функцию Chr(34) (34 является кодом символа прямых кавычек ("))

Дополнительно: Подробное описание символов форматирования, применяемые для создания пользовательских форматов числовых величин

Параметр FirstDayOfWeek
Необязательный аргумент-константа, определяющая первый день недели
Параметр FirstWeekOfYear
Необязательный аргумент-числовая константа, указывающая, какую неделю считать первой в году:

Дополнительно: Описание параметров FirstDayOfWeek и FirstWeekOfYear

Ниже приведено окно формы программы, демонстрирующей примеры форматирования числовых данных с использованием функции Format.

Фрагмент текста программы, демонстрирующей примеры форматирования числовых данных с использованием функции Format.

ЗАДАНИЕ 3.
Используя ранее созданный проект, выполните форматный вывод значений переменной на форму, в окно PictureBox и в окно TextBox. Сохраните проект на диске.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Символы форматирования функции Format

назад

Общий вид функции:
Format (Expression[, Format[, FirstDayOfWeek[, FirstWeekOfYear]]])
Параметр Format
Необязательный аргумент-любое допустимое именованное или определяемое пользователем выражение формата. При форматировании чисел без указания аргумента Format функция Format выдает тот же результат, что и функция Str(number) - Возвращает строку, представляющую число), хотя эта функция учитывает национальную настройку. Отличие состоит в том, что при преобразовании положительного числа с помощью функции Format пробел в начале строки (на месте знака числа) теряется, а при преобразовании с помощью функции Str останется

Символы форматирования, применяемые для создания пользовательских форматов числовых величин

0
Прототип цифры. Выводит цифру или нуль. Если форматируемое выражение содержит цифру в позиции, соответствующей прототипу "0" в строке формата, то в данной позиции будет выведена эта цифра; в противном случае в данной позиции будет выведен нуль. Если число цифр в целой или дробной части форматируемого числа меньше, чем число прототипов "0" слева или справа от десятичного разделителя в строке формата, соответственно, то в начало или конец числа будут добавлены недостающие нули. Если количество цифр в дробной части форматируемого числа больше, чем количество прототипов "0" справа от десятичного разделителя в строке формата, то число будет округлено с соответствующей точностью. Если количество цифр в целой части форматируемого числа больше, чем количество прототипов "0" слева от десятичного разделителя в строке формата, то лишние цифры будут выведены без изменения
Print Format(6.789, "00.0000") ' возвратит 06,7890
#
Прототип цифры. Выводит цифру или не выводит ничего. Если форматируемое выражение содержит цифру в позиции, соответствующей символу # в строке формата, то в данной позиции будет выведена цифра; в противном случае данная позиция останется пустой. Отличие данного символа от символа формата "0" состоит в том, что если количество цифр в целой или дробной части форматируемого числа меньше, чем число символов "#" слева или справа от десятичного разделителя в строке формата, соответственно, то недостающие нули в начале или конце числа добавлены не будут
Print Format(6.789, "##.0000") ' возвратит 6,7890
.
Десятичный разделитель. В некоторых национальных настройках десятичным разделителем служит запятая. Десятичный разделитель указывает, сколько цифр следует вывести в целой и дробной части форматируемого числа, т.е. слева и справа от десятичного разделителя. Если строка формата содержит слева от десятичного разделителя только символы "#", то число, меньшее единицы, при выводе будет начинаться с десятичного разделителя. Если требуется, чтобы дробные числа всегда изображались с начальным нулем перед десятичным разделителем, следует использовать символ формата "0" в качестве первого символа строки числового формата. Фактический символ, используемый в качестве десятичного разделителя, определяется установленным в системе числовым форматом. В России в качестве десятичного разделителя используется запятая
Print Format(0.789, "##.0000") ' возвратит ,7890
%
Процентный формат. Выражение умножается на 100. Символ процентов (%) выводится в позиции, соответствующей позиции прототипа в строке формата
Print Format(0.17, "0%") ' возвратит 17%
,
Разделитель групп разрядов. В некоторых национальных настройках в качестве разделителя групп разрядов используется точка. Разделитель групп разрядов разделяет позиции тысяч и сотен в числе, целая часть которого состоит из четырех или большего числа цифр. Стандартное применение разделителя групп разрядов задается в строке формата, в которой пробел окружен символами вывода цифры (0 или #). Два соседних разделителя групп разрядов или разделитель групп разрядов, стоящие сразу перед десятичным разделителем (даже если символ десятичного разделителя не указан явно), означают, что масштаб числа следует изменить, разделив его указанное число раз на 1000 и округлив по мере надобности. Такой способ позволяет выводить большие числа. Например, строка формата "##0,," отображает сто миллионов как 100, а числа, меньшие одного миллиона, как 0. Два соседних разделителя групп разрядов, находящихся в любой другой позиции, обрабатываются как один разделитель групп разрядов. Фактический символ, используемый в качестве разделителя групп разрядов, определяется установленным в системе числовым форматом. В России в качестве разделителя групп разрядов используется пробел
:
Разделитель компонентов времени. В некоторых национальный настройках в качестве разделителя компонентов времени используется другой символ. Разделитель компонентов времени используется для разделения компонентов времени (часов, минут и секунд). Фактический символ, используемый в качестве разделителя компонентов времени, определяется текущей национальной настройкой. В России в качестве разделителя компонентов времени используется двоеточие (функция Now возвращает Variant значение, содержащее текущие системные дату и время).
Print Format(Now, "h:m:s") ' возвратит к примеру 11:23:35
/
Разделитель компонентов даты. В некоторых национальный настройках в качестве разделителя компонентов даты используется другой символ. Разделитель компонентов даты используется для разделения компонентов даты (дня, месяца и года). Фактический символ, используемый в качестве разделителя компонентов даты, определяется текущей национальной настройкой. В России в качестве разделителя компонентов даты используется точка
E- E+ e- e+
Экспоненциальный формат. Если строка формата содержит хотя бы один прототип цифры (0 или #) справа от символов "E-", "E+", "e-" или "e+", то число выводится в экспоненциальном формате, а между числом и показателем степени помещаются символы "E" или "e". Число цифр в показателе степени определяется числом символов вывода цифры справа от символа экспоненциального формата. Для вывода знака минус (-) перед отрицательными значениями показателя степени следует использовать символы "E-" или "e-"; в этом случае знак перед положительными значениями показателя степени не ставится. Для вывода знака плюс перед положительными значениями показателя степени и знака минус перед отрицательными значениями показателя степени следует использовать символы "E+" или "e+"
- + $ ()
Вывод указанного символа. Для вывода любого не перечисленных здесь символов следует поместить перед ним символ обратной косой черты (\) или заключить символ в прямые кавычки (" ")
\
Вывод следующего символа из строки формата. Многие символы в строке формата имеют специальное назначение и не могут быть выведены в явном виде, если перед ними не стоит символ обратной косой черта. Сам символ "обратная косая черта" при этом не отображается. Наличие данного символа форматирования эквивалентно заключению следующего за ним в строке формата символа в прямые кавычки. Для вывода самого символа "обратная косая черта" следует указать его дважды (\\).Примерами символов, которые не могут быть включены в строку форматирования явным образом, являются символы форматирования даты и времени (a, c, d, h, m, n, p, q, s, t, w, y, / и :), символы форматирования чисел (#, 0, %, E, e, запятая и точка) и символы форматирования строк (@, &, <, > и !)
"ABC"
Вывод строки, заключенной в прямые кавычки (" "). Для представления кавычек в аргументе формат в программе необходимо использовать функцию Chr(34) (34 является кодом символа прямых кавычек ("))

Использован материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


Для запуска программы из главного меню Windows выполните следующие действия

Дополнительные сведения о функции Format

назад

Общий вид функции:
Format (Expression[, Format[, FirstDayOfWeek[, FirstWeekOfYear]]])
Параметр FirstDayOfWeek
Необязательный аргумент-константа, определяющая первый день недели
vbUseSystem=0
Используется значение национальных системных установок
vbSunday=1
Воскресенье(по умолчанию)
vbMonday=2
Понедельник
vbTuesday=3
Вторник
vbWednesday=4
Среда
vbThursday=5
Четверг
vbFriday=6
Пятница
vbSaturday
Суббота
Параметр FirstWeekOfYear
Необязательный аргумент-числовая константа, указывающая, какую неделю считать первой в году:
vbUseSystem=0
Используется системная информация
vbFirstJan1=1
Неделя, содержащая 1 января
vbFirstFourDays=2
Первая неделя, содержащая как минимум 4 дня нового года
vbFirstFullWeek=3
Первая полная неделя года

Использован материал с сайта Visual Basic - Не для Чайников! © 2002 Беляев Николай. Все права защищены.

назад


Для запуска программы из главного меню Windows выполните следующие действия

Изменение свойств объектов

начало

назад

вперед

конец

вопросы

задания

Для настройки свойств формы, а также размещенных в ней объектов предназначено окно Properties (Свойства) В нем, например, содержатся такие свойства выбранного объекта, как название, высота, ширина, цвет и др.

Диалоговое окно Properties вызывается командой Properties Window (Окно свойств) из меню View (Вид), кнопкой Properties Window на стандартной панели инструментов или командой Properties контекстного меню выбранного объекта. Поскольку форма и элементы управления каждый сами по себе являются объектами, набор свойств в этом окне меняется в зависимости от выбранного объекта. При помощи вкладок Alphabetic (По алфавиту) и Categorized (По категориям) свойства объекта можно просмотреть в алфавитном порядке или по группам (категориям) соответственно.

В нижней части окна вы всегда найдете подсказку, поясняющую назначение выбранного атрибута объекта. Более подробную информацию найдете в справочной системе Visual Basic 6, нажав клавишу <Fl>. При этом необходимо предварительно выделить интересующее вас свойство.

Используя диалоговое окно Properties, можно изменить установленные по умолчанию свойства объектов. Часть свойств объекта, например, размеры и расположение объектов, можно задать перемещением объекта и изменением его размеров с помощью мыши в конструкторе форм.

Ряд свойств, установленных на этапе разработки приложения в окне свойств Properties, допускается изменять при выполнении приложения, написав соответствующие коды в процедурах, создаваемых с помощью редактора кода.

Как правило, форма содержит много объектов. Если выбрать сразу несколько объектов, то в окне свойств отобразятся общие для этих объектов свойства.

В окне свойств Properties можно воспользоваться вкладкой Categorized (По категориям), которая выводит свойства, сгруппированные по типам (категориям). Вкладка Alphabetic (По алфавиту), расположит свойства в алфавитном порядке их названий, что даст возможность быстрее найти нужное свойство.

Рассмотрим основные группы свойств, представленные на вкладке Categorized окна Properties.

Свойства, определяющие внешний вид объекта.

В группе Appearance (Оформление) окна Properties содержатся свойства объекта, которые задают атрибуты его внешнего вида. Основные свойства данной группы:

Caption | - задает текст в строке заголовка объекта;
BorderStyle | - задает стиль рамки объекта;
Palette | - устанавливает цветовую палитру;
Picture | - назначает значок, картинку для объекта. Используя данное свойство формы, можно задать фоновое графическое изображение.

Свойства, определяющие поведение объекта.

Свойства объектов, отвечающие за их поведение, собраны в группе Behavior (Поведение). Основные свойства данной группы:

Causes Validation | - устанавливает признак проверки условия достоверности данных при выходе из объекта;
Enabled | - разрешает или запрещает доступ к объекту;
MaxLength | - устанавливает максимальную длину данных в объекте;
Visible | - устанавливает видимость объекта.

Свойства, определяющие шрифт.

Группа Font (Шрифт) содержит всего одно свойство Font, позволяющее с помощью диалогового окна Выбор шрифта задать шрифт текста объекта, размер, начертание.

Свойства группы Misc задают общие атрибуты объекта, в том числе для его идентификации.

Name | - задает имя объекта;
Text | - устанавливает текст в поле по умолчанию;
Index | - задает уникальный индекс объекта в коллекции;

По имени, указанному в свойстве Name (Имя), объект идентифицируется в форме и в тексте программы. Поэтому необходимо иметь в виду, что в одной форме не может быть двух объектов с одинаковыми именами. По умолчанию это свойство устанавливается автоматически. Вместо имени, заданного по умолчанию, лучше использовать имя, отражающее его смысловое значение.

Свойства позиционирования.

Left | - задает положение объекта по горизонтальной оси от левого края формы или, в общем случае, от объекта-контейнера;
Top | - задает положение объекта по вертикальной оси от его верхнего края до верхней стороны формы;
Width | - задает горизонтальный размер (ширину) объекта;
Height | - задает вертикальный размер (высоту) объекта.

Группа Position (Расположение) окна Properties служит для позиционирования объектов в системе координат формы и установки размеров объектов.

Свойства шкалы размеров объекта.

Свойства группы Scale (Масштаб) устанавливают шкалу максимальных размеров объектов в системе координат формы.

ScaleLeft | - задает максимальное положение объекта по горизонтальной оси;
ScaleTop | - задает максимальное положение объекта по вертикальной оси;
ScaleWidth | - задает максимальный горизонтальный размер (максимальная ширина);
ScaleHeight | - задает максимальный вертикальный размер (максимальная высота).

Дополнительно: Описание некоторых объектов и их основных свойств.

Пример формы с размещенными на ней объектами и измененными свойствами (цвет, шрифт, строка заголовка формы, надписи на объектах и др.

ЗАДАНИЕ 4.
Создайте форму с 3-4 объектами и измените их свойства. Сохраните проект на диске.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Описание некоторых свойств объектов

назад

Форма (Form)

AutoRedraw - способ автоматической перерисовки окна формы. Это свойство определяет, каким образом осуществляется повторное создание (восстановление) формы, например, после сворачивания (и последующего развертывания окна) или перекрытия изображения другими окнами. Если свойству присвоено значение True, то происходит автоматическое восстановление изображения. Если False (по умолчанию) – вызывается процедура обработки события перерисовки и выполняется код, написанный программистом.

BackColor - цвет фона окна формы. Значения цвета определяются шестнадцатеричной константой. В поле параметров окна свойств, можно из палитры цветов выбрать нужный цвет.

Border Style - тип границ окна и строки заголовка формы. Границы и строка заголовка окна могут отсутствовать (None), очерчиваться линиями, а окно иметь постоянный размер (Fixed Single), окно может быть масштабируемо (Sizeable) и др. Выбрать необходимое значение можно из раскрывающегося списка. Изменение этого свойства допускается только на этапе разработки приложения.

Caption - название формы, размещаемое в строке заголовка. Это свойство содержит текст, выводимый в строку заголовка окна формы.

Enabled - доступ. Любой объект по умолчанию обладает свойством Enabled (активизирован, доступен), т.е. установлено значение True. Если установлено значение False – объект неактивен (блокируется воздействие на объект (форму) любых событий, связанных с мышью или клавиатурой).

FontName - название шрифта, используемого в объектах формы. Смена шрифта действует лишь на новый объект, размещенный на форме, не влияет на уже имеющиеся объекты.

FontSize - размер шрифта. Измеряется в пунктах. Пункт – стандартная единица измерения, равная 0,035 см.

ForeColor - основной цвет. Это цвет текста или графических изображений. Устанавливается с помощью палитры цветов аналогично свойству BackColor.

Height, Width - размер формы - высота и ширина. Определяется в twips. 1 twip=0.0018 см.

Icon (значок). Значок, в который превращается свернутая форма.

Name - имя. Свойство задает имя формы в программном коде, изменять которое в период выполнения программы нельзя.

Picture - картинка. Это свойство позволяет отобразить на окне формы растровую картинку (bitmap picture). Для изменения свойства в период выполнения программы используется функция LoadPicture.

Top, Left - верхняя и левая координаты окна. Свойства определяют позиционирование формы на экране. Координаты измеряются в twips.

WindowState -состояние окна. Свойство определяет, в каком виде окно отображается на экране: нормальном (Normal), свернутом в значок (Minimized) или развернутом (Minimized).

Окна рисунков и изображений (PictureBox)

Эти объекты обладают свойствами Enabled, Height, Width, Top, Left, Name, Picture, поведение которых аналогично поведению свойств формы. Однако, координаты объекта в случае свойств Height, Width, Top, Left, относительны, а не абсолютны, т. е. они измеряются как смещение от начала координат формы, а не экрана (это касается всех элементов, расположенных на форме). Свойство Picture позволяет выводить на экран либо растровую картинку (bitmap), либо значок (icon).

Stretch - подгонка. Это свойство имеют окна изображений. По умолчанию оно False, что означает, что элемент управления (окно) подгоняется под размеры загружаемого в него изображения. Значение True означает, что изображение подгоняется под элемент управления.

Метки (Label)

Alignment - выравнивание. Способ выравнивания текста на метке: по левой границе, по правой и по центру.

AutoSize - подгонка размера. True – размер метки автоматически подгоняется под размер текста. False – метка сохраняет заданный размер, а лишние символы отсекаются.

BorderStyle - тип границ. Метка может либо иметь контур, либо нет.

Caption - название. Свойство содержит текст, отображаемый в поле метки.

Текстовые окна (TextBox)

MaxLenth - максимальная длина. По умолчанию значение равно нулю, что означает, что в текстовое окно можно вводить любое количество символов. Если значение свойства не равно нулю, то Visual Basic ограничивает количество символов заданной величиной.

MultiLine - количество строк. Значение True разрешает ввод нескольких строк текста, нажимая Enter. False запрещает ввод более одной строки текста.

Text - текст, размещенный в текстовом окне до ввода другого текста. С помощью этого свойства программа распознает, какой именно текст введен пользователем.

Текстовое окно не реагирует на события, связанные с мышью, но позволяет отслеживать нажатие любой клавиши.

Командные кнопки, флажки, переключатели (CommandButton, CheckBox, OptionButton)

Cancel - отмена. Это свойство связано только с командными кнопками. True – щелчок кнопки эквивалентен нажатию клавиши Escape. Значение True у свойства может иметь только одна командная кнопка на форме.

Default - по умолчанию. Поддерживается лишь командными кнопками. True – щелчок кнопки эквивалентен нажатию клавиши Enter. Значение True у свойства может иметь только одна командная кнопка на форме.

Value - состояние. Значение этого свойства отражает состояние флажка или переключателя. Для переключателя: True – переключатель активен (в центре кружочка жирная точка); False – переключатель неактивен (точка отсутствует). Для флажка: 0 – флажок не помечен, 1 – флажок установлен (в центре крестик), 2 – флажок затенен (имеет блеклый вид).

назад


Для запуска программы из главного меню Windows выполните следующие действия

Создание формы приложения и сохранение проекта

начало

назад

вперед

конец

вопросы

задания

Напишем программу вычисления площади сектора при известных: наружном диаметре D1, внутреннем диаметре D2 и центральном угле A.

Площадь кольца можно вычислить по формуле:

S = 3,14*(D1/2-D2/2)^2*A/360

Пример формы рабочего окна программы

На форме размещены:

- три текстовых поля (TextBox) для ввода исходных данных;

- графическое поле (PictureBox) для вывода результатов вычислений (значения площади сектора);

- метки (Label) для поясняющих надписей рядом с полями для ввода-вывода данных;

- метки (Label) для вывода текста и значения процента площади сектора от площади кольца (вывод данных на метку);

- фреймы (Frame) для для функционального объединения однотипных элементов в группы;

- кнопка (CommandButton) для запуска программы вычислений.

При создании формы изменены свойства объектов - их цвет и шрифт.

Может быть спроектирован и другой интерфейс программы с использованием различных вариантов оформления формы и организации ввода-вывода данных.

Текст программы нахождения площади сектора.

ЗАДАНИЕ 5.
Создайте проект и напишите программу вычисления площади сектора Спроектируйте свой, отличающийся от приведенного в примере, программный интерфейс. Используйте различные варианты организации ввода-вывода данных. Для вывода результатов используйте форматный вывод.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы

задания


Изучение интерфейса и правил работы в пакете Derive

Лабораторная работа: Разветвляющиеся и циклические алгоритмы

начало

назад

вперед

конец

вопросы

задания

Цель работы

Целью работы является изучение возможностей разработки приложений с разветвляющимися и циклическими алгоритмическими структурами

Порядок выполнения работ

  • Запустить программу Visual Basic.

  • Изучить правила использования операторов условного перехода и операторов циклов.

  • Изучить возможности разработки приложений с разветвляющимися и циклическими алгоритмическими структурами и контроля за их выполнением с использованием объектов Visual Basic: ключ, переключатель, ползунок, индикатор процесса выполнения программы.

  • Выполнить задания, приведенные в методических указаниях.

  • Сохранить результаты работы на личной дискете.

  • Показать результаты работы преподавателю.

  • Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Задание 1 - изучение операторов условного перехода.

  • Задание 2 - разработка приложения с разветвляющимися алгоритмическими конструкциями.

  • Задание 3 - изучение операторов организации циклов.

  • Задание 4 - разработка приложения с циклическими структурами.

  • Задание 5 - изучение возможностей использования ключей, переключателей, ползунков.

  • Задание 6 - изучение возможностей использования ползунка и индикатора процесса.

Требования к отчету

Отчет по лабораторной работе - это краткое описание основных этапов выполнения работы. Он должен содержать:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • блок-схемы алгоритмов разработанных программ

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы

задания


Заключение и выводы

начало

назад

вперед

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены возможностей разработки приложений с разветвляющимися и циклическими алгоритмическими структурами, реализованными как с использованием операторов условного перехода и организации циклов языка Visual Basic, так и с использованием объектов Visual Basic: ключ, переключатель, ползунок, индикатор процесса выполнения программы.

Были рассмотрены темы:

  • Задание 1 - изучение операторов условного перехода.

  • Задание 2 - разработка приложения с разветвляющимися алгоритмическими конструкциями.

  • Задание 3 - изучение операторов организации циклов.

  • Задание 4 - разработка приложения с циклическими структурами.

  • Задание 5 - изучение возможностей использования ключей, переключателей, ползунков.

  • Задание 6 - изучение возможностей использования ползунка и индикатора процесса.

По результатам работы должен быть составлен отчет, содержащий:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы

задания


Вопросы к лабораторной работе

начало

назад

вперед

конец

вопросы

задания

  1. Какие операторы используются для организации условного перехода?

  2. Какие логические отношения могут использоваться в операторах условного перехода?

  3. Что такое логическое выражение?

  4. Какие логические операции могут использоваться в логических выражениях?

  5. В каких случаях используется Конструкция Select Case?

  6. Какой оператор используется для организации цикла при известном числе повторений?

  7. Какие операторы используются для организации циклов при известном заранее числе повторений?

  8. Каким образом организовать выход из цикла до исчерпания значений его параметра?

  9. Для чего используется объект Ключ?

  10. Для чего используется объект Переключатель?

  11. Для чего используется элемент управления (объект) Ползунок?

  12. В каких случаях используется Индикатор процесса?

начало

назад

вперед

конец

вопросы

задания


Задания к лабораторной работе

Все задания к лабораторной работе

начало

назад

вперед

конец

вопросы

задания

ЗАДАНИЕ 1.
Создайте проект и напишите программу вычисления корней квадратного уравнения a*x^2+b*x+c=0. Предусмотрите условный переход и вывод результата решения уравнения для равных корней (x1=x2 при D=0). Спроектируйте свой, отличающийся от приведенного в примере, программный интерфейс. Для вывода результатов используйте форматный вывод. Сохраните проект на диске.
Создайте вариант проекта с использованием конструкции Select Case.
Сохраните проект на диске. Пример программы.
ЗАДАНИЕ 2.
Создайте проект "Поиск простых чисел" и напишите программу, определяющую, сколько среди целых чисел от M до N простых чисел и выводящую их. Используйте для организации циклов конструкцию Do...Loop.
Сохраните проект на диске.
ЗАДАНИЕ 3.
Создайте проект, позволяющий вычислять одну из величин: длину окружности (2*3,1415*R), площадь круга ( 3,1415*R*R), площадь или периметр квадрата по заданному значению R. (R- радиус окружности, вписанной в квадрат)
Для выбора вычисляемой величины используйте Переключатель.
При выводе результатов используйте форматный или бесформатный вывод в зависимости от выбранного значения ключа.
При создании проекта используйте различные варианты ввода-вывода данных (см. лабораторную работу №2).
Сохраните проект на диске.
ЗАДАНИЕ 4.
Создайте проект "Поиск простых чисел" и напишите программу, определяющую, сколько среди целых чисел от M до N простых чисел и выводящую их. Используйте для организации циклов конструкцию Do...Loop. Используйте ползунки для задания значений чисел M и N и индикатор процесса. Предусмотрите возможность очистки окна вывода результатов при его переполнении. Сохраните проект на диске. Пример программы 1, Пример программы.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Программирование условий в V isual Basic

начало

назад

вперед

конец

вопросы

задания

Операторы в программе выполняются в той последовательности, в которой они записаны. Однако достаточно часто требуется изменить порядок выполнения операторов в зависимости от выполнения (или невыполнения) определенного условия. В Visual Basic, как и во всех языках программирования, существуют управляющие конструкции, предназначенные для управления порядком выполнения команд.

Различают три типа управляющих операторов, позволяющих программировать разветвляющиеся алгоритмы:

1. If ... Then ...

2. If ... Then ... Else ...

3. Select Case ...

Основанием для принятия решений в управляющих конструкциях являются логические ( условные) выражения.

В операторах If ...Then ... и If ...Then ... Else ... условие и выполняемые при соблюдении условий действия располагаются в одной строке.

В том случае, если при выполнении условия требуется выполнение блока операторов, используются многострочные операторы, имеющие следующий синтаксис:

IF логическое выражение Then

операторы

End If

Конструкция If ... Then ... применяется, когда необходимо выполнить определенные действия в зависимости от некоторого условия.

IF условие Then

Конструкции для обработки истинного условия

Конструкция If ... Then ... Else ... используется в том случае, когда необходимо выполнить разные действия в зависимости от условия.

IF условие Then .

Конструкции для обработки истинного условия

Else

Конструкции для обработки ложного условия

End If

Ключевое слово End if обозначает конец многострочной конструкции и его наличие в операторе в этом случае обязательно.

Конструкция Select Case позволяет обрабатывать в программе несколько условий. Эта конструкция состоит из анализируемого выражения и набора операторов CASE на каждое возможное значение выражения.

Select Case Селектор

СASE значение 1

конструкция 1

CASE значение 2

конструкция 2

. . .

End Select

Работает эта конструкция следующим образом. Сначала Visual Basic вычисляет значение заданного в конструкции выражения - Селектора. Затем полученное значение сравнивается со значениями, задаваемыми в операторах CASE конструкции. Если найдено искомое значение, выполняются команды, приписанные данному оператору CASE. После завершения выполнения конструкций управление будет передано конструкции, следующей за ключевым словом End Select.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Логические выражения

назад

Логические выражения — это такие выражения, которые возвращают одно из двух значений: True (Истина) или False (Ложь). Логические выражения содержат логические отношения (операции сравнения): = (равно), > (больше), < (меньше), <> (не равно), >= (больше или равно), <= (меньше или равно)

Логические отношения могут быть связаны логическими операциями:

AND (И) реализует конъюнкцию логических значений — возвращает значение True (Истина), если все участвующие в операции выражения имеют значение True. В остальных случаях возвращается значение False (Ложь);

OR (ИЛИ) реализует дизъюнкцию логических значений — возвращает значение True, если хотя бы одно из участвующих в операции выражений имеет значение True. В случае, когда все выражения имеют значение False, возвращается значение False;

XOR (Исключающее ИЛИ) — возвращает значение True (Истина), если только одно из участвующих в операции выражений имеет значение True. В остальных случаях возвращается значение False;

NOT (HE) реализует инверсию логических значений — операция отрицания. Возвращает обратное для значения выражения значение, то есть если выражение равно True, то возвращается False и наоборот, если значение выражения равно False, то возвращается значение True.

назад


Для запуска программы из главного меню Windows выполните следующие действия

Создание приложения, реализующего алгоритм с разветвлением

начало

назад

вперед

конец

вопросы

задания

Напишем программу для решения квадратных уравнений a*x^2 + b*x + c = 0

Чтобы решить такое уравнение, нужно найти дискриминант и затем, корни.

Дискриминант ищется по формуле:

D = b*b - 4*a*c

А корни:

Если дискриминант > 0, то

X1 = (b + (корень из D)) / (2*a)
X2 = (b - (корень из D)) / (2*a)

Если дискриминант = 0, то

X1 = X2 = b / (2*a)

Если дискриминант < 0, то корней не существует.

Блок-схема алгоритма решения задачи

Пример реализации интерфейса приложения (окна формы проекта) для решения квадратного уравнения

На форме размещены:

- текстовые окна (TextBox), предназначенные для ввода исходных данных;

- метки (Label) для подписи текстовых окон;

- графическое окно (PictureBox) для вывода результатов решения уравнения;

- фрейм для визуального объединения компонентов формы;

- кнопки для выполнения действий приложения.

Может быть спроектирован и другой интерфейс программы с использованием различных вариантов организации ввода-вывода данных.

Текст программы решения квадратного уравнения. В нем для нахождения не равных друг другу и равных друг другу корней используются одни и те же формулы, то есть не проверяется условие равенства нулю дискриминанта.

ЗАДАНИЕ 1.
Создайте проект и напишите программу вычисления корней квадратного уравнения a*x^2+b*x+c=0. Предусмотрите условный переход и вывод результата решения уравнения для равных корней (x1=x2 при D=0). Спроектируйте свой, отличающийся от приведенного в примере, программный интерфейс. Для вывода результатов используйте форматный вывод. Сохраните проект на диске.

Создайте вариант проекта с использованием конструкции Select Case. Сохраните проект на диске.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Программирование циклов в V isual Basic

начало

назад

вперед

конец

вопросы

задания

В программах Visual Basic для выполнения повторяющихся действий используются циклы. Они бывают трех типов:

1. For ... Next

2. For Each ... Next

3. Do ... Loop

Конструкция For...Next выполняет последовательность команд определенное число раз. Такую конструкцию называют циклом, а выполняемые ею программные коды — телом цикла.

For Счетчик = НачальноеЗначение То КонечноеЗначение [Step Шаг]

конструкции

Next [счетчик]

Первый аргумент конструкции — Счетчик — определяет имя переменной, которая будет "считать" количество выполнений цикла. Параметр НачальноеЗначение указывает числовое значение, которое присваивается переменной-счетчику при первом проходе цикла. Цикл выполняется до тех пор, пока значение счетчика не превысит КонечноеЗначение, указанное после ключевого слова To. После каждого прохода цикла значение счетчика изменяется на величину Шаг, указанную за ключевым словом Step. Ключевое слово Next обозначает конец тела цикла и является обязательным.

Конструкция For Each ... Next используется для обработки всех элементов некоторого набора объектов, например массива. Ее удобно использовать в том случае, когда количество обрабатываемых элементов не известно.

For Each Элемент In группа

конструкции

Next элемент

При использовании конструкции For Each ... Next необходимо иметь в виду, что для набора объектов параметр Элемент может быть только переменной типа Variant, общей переменной типа Object или объектом, перечисленным в Object Browser. Для массивов параметр Элемент может быть только переменной типа Variant.

Конструкция Do...Loop с ключевым словом While выполняется до тех пор, пока задаваемое в цикле условие истинно.

Do While Условие

Конструкции

Loop

и

Do

Конструкции

Loop While Условие

Аргумент конструкции Условие является логическим выражением, значение которого проверяется перед каждым проходом цикла. Если это значение равно True, то выполняется последовательность команд, которые расположены между Do while и ключевым словом Loop. Эти конструкции образуют тело цикла. Если при очередном проходе цикла условие равно False, то происходит выход из цикла и управление передается конструкции, следующей за Loop.

Конструкция Do ... Loop с ключевым словом Until выполняется до тех пор, пока задаваемое в цикле условие ложно.

Do Until Условие

Конструкции

Loop

и

Do

Конструкции

Loop Until Условие

В циклах может быть использован оператор Exit. В некоторых случаях необходимо прервать выполнение цикла до его завершения. Это можно сделать с помощью команды безусловного перехода Exit. Команда Exit завершает выполнение цикла и передает управление следующей за циклом конструкции.

Синтаксис этого оператора внутри цикла For выглядит так: Exit For. Внутри цикла Do синтаксис оператора Exit Do.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Создание приложения, реализующего алгоритм с циклом

начало

назад

вперед

конец

вопросы

задания

Программа на использование циклов.

Определить, сколько среди целых чисел от M до N простых чисел и вывести их?. Простым считается число делящееся без остатка на единицу и на само себя.

Блок-схема алгоритма решения задачи

Пример реализации интерфейса приложения (окна формы проекта) для решения задачи нахождения простых чисел.

Текст программы.

Для нахождения простых чисел используются вложенные друг в друга циклы с параметрами. Переменная k используется для определения количества простых чисел.

Переменная p (остаток от деления k на 19) позволяет организовать перенос выводимых чисел на следующую строку графического окна (PictureBox).

Приведенный текст программы с полным перебором не является оптимальным для решения данной задачи и служит только примером использования циклов в Visual Basic.

ЗАДАНИЕ 2.
Создайте проект "Поиск простых чисел" и напишите программу, определяющую, сколько среди целых чисел от M до N простых чисел и выводящую их. Используйте для организации циклов конструкцию Do...Loop. Остальные элементы программы и ее интерфейс возьмите из приведенного выше примера.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Использование объектов: ключ, переключатель, ползунок

начало

назад

вперед

конец

вопросы

задания

Ключ (флажок)

Ключ (CheckBox) позволяет сделать активной какую либо опцию приложения.

На рисунке показан фрагмент формы с двумя расположенными на ней ключами.

Переключатель (поля выбора или «радиокнопки»)

Переключатель (OptionButton) позволяет выбрать одну из возможных опций, представленных в форме в виде списка.

На рисунке показан фрагмент формы с двумя расположенными на ней переключателями.

Пример проекта (приложения), реализованного с использованием ключей и переключателей, позволяющего выполнять одно из выбранных арифметических действий над двумя заданными числами.

Текст программы на Visual Basic:

Private Sub Command1_Click()
If Check2.Value Then Picture1.Cls
If Option1.Value Then x = Val(Text1) + Val(Text2)
If Option2.Value Then x = Val(Text1) - Val(Text2)
If Option3.Value Then x = Val(Text1) * Val(Text2)
If Option4.Value Then x = Val(Text1) / Val(Text2)
If Check1.Value Then Picture1.Print Round(x) Else Picture1.Print x
End Sub

ЗАДАНИЕ 3.
Создайте проект, позволяющий вычислять одну из величин: длину окружности (2*3,1415*R), площадь круга ( 3,1415*R*R), площадь или периметр квадрата по заданному значению R (смотри рисунок)

Для выбора вычисляемой величины используйте Переключатель.

При выводе результатов используйте форматный или бесформатный вывод в зависимости от выбранного значения ключа.

При создании проекта используйте различные варианты ввода-вывода данных (см. лабораторную работу №2).

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Использование объектов: ползунок и индикатор процесса

начало

назад

вперед

конец

вопросы

задания

Ползунок (Slider)

Элемент управления Ползунок позволяет вводить в программу числовые значения путем перемещения указателя ползунка.

Индикатор процесса (ProgressBar) выполнения программы

Некоторые операции приложения могут выполняться довольно долго, например, обработка большого массива данных или сложная выборка из базы данных, содержащей огромное количество записей. В этой ситуации пользователь начинает беспокоиться, не зависла ли программа.

Работа продолжительных задач может сопровождаться отображением на экране индикатора процесса выполнения.

Пример программы с использованием ползунка и индикатора процесса.

Определить, сколько среди целых чисел от M до N простых чисел и вывести их?.

Пример реализации интерфейса приложения (окна формы проекта) для решения задачи нахождения простых чисел. Значения переменных M и N вводятся с помощью ползунков. Для индикации процесса поиска простых чисел использован индикатор процесса.

Текст программы.

ЗАДАНИЕ 4.
Используя ранее созданный проект "Поиск простых чисел" (с циклами Do...Loop) исправьте форму (сохранив старый проект на дискете) и напишите программу, определяющую, сколько среди целых чисел от M до N простых чисел и выводящую их.
Сохраните проект на диске.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Окна: проводника проекта, макета формы и редактора исходного кода

начало

назад

вперед

конец

вопросы

задания

Окно проводника проекта

Окно проводника проекта Project (Проект) позволяет легко и быстро просматривать состав и свойства выбранного проекта, перемещаться между проектами, если их открыто сразу несколько, копировать необходимые объекты из окна одного проекта в другой. Окно проводника проекта очень похоже на аналогичное окно проводника системы Windows и работа в нем осуществляется как же, как в проводнике системы Windows.

Проводник проекта можно вызвать командой Project Explorer (Проводник проекта) меню View (Вид) или комбинацией клавиш <Ctrl>+<R>.

При нажатии правой кнопки мыши в окне проводника появляется контекстное меню, содержащее команды для добавления, сохранения, удаления форм, элементов управления и других объектов.

Панель управления окна проводника проекта содержит три кнопки, которые имеют следующее назначение:

View code | - открывает окно редактора с кодом программы, выбранного в проводнике объекта;
View Object | - открывает в конструкторе форм выбранный объект;
Toggle Folders | - включает/выключает отображение папок.

Окно макета формы

Окно макета формы Form Layout (Макет формы) вызывается командой Form Layout Window из меню View.

В этом окне показывается уменьшенное изображение проектируемой формы в том виде, как эта форма будет выглядеть на экране монитора при выполнении приложения. Размеры формы в окне макета Form Layout пропорциональны размерам изображения монитора в этом же окне, то есть все реальные пропорции в точности соблюдены. Для проверки формы в работающем приложении откройте окно макета формы и запустите форму командой Start (Старт) из меню Run (Запуск).

При этом форма запускается точно в том виде, как она будет выглядеть в работающем приложении.


Массивы

Объявление массивов в Visual Basic

В Visual Basic существуют массивы фиксированного размера и динамические массивы. Массив фиксированного размера имеет неизменный размер, заданный при его объявлении. Динамические массивы могут изменять размер в процессе выполнения.

Объявление массива фиксированного размера

Как и любой тип данных, массив необходимо объявлять. Ниже приведен синтаксис объявления:

{ Dim | Private | Public I Static} имяМассива (<размер1> [, <размер2>] ...) [As типДанных] [, имяМассива (<размер1> [, <размер2>] ...) [As типДанных}] . . .

Существует 3 способа объявления массива фиксированного размера, которые зависят от области его видимости:

· создание глобального массива – объявляется с помощью оператора Public в секции Declarations модуля;

· создание глобального массива уровня модуля – объявляется с помощью оператора Private в секции Declarations модуля;

· создание локального массива – объявляется с помощью оператора Private в процедуре;

Размер массива может задаваться тремя способами:

· объявление только верхней границы массива, при этом нижняя граница массива по умолчанию принимает значение равное 0.

Dim arr(20) as integer ‘ создание массива из 21 элемента

· объявляется нижняя и верхняя границы изменения индекса

Dim arr(11 to 20) as integer ‘ создание массива из 10 элементов

· размер массива не объявляется

Dim arr() as integer ‘ создание массива, размерность неизвестна

Объявление динамического массива

В случае, когда размер массива заранее неизвестен, Visual Basic позволяет использовать динамические массивы, размеры которых можно изменять во время выполнения. Применение динамических массивов позволяет эффективно управлять памятью, выделяя память под большой массив лишь на то время, когда этот массив используется, а затем освобождая ее.

Создание динамического массива осуществляется следующим образом:

  1. Объявляется массив с помощью ключевых слов, используемых при создании массива фиксированного размера. Список размерностей массива остается пустым. При объявлении глобального массива необходимо выбрать ключевое слово Public, при объявлении массива на уровне модуля — Dim, при объявлении массива в процедуре — Dim или static. Например,
Dim massive() As Integer
  2. С помощью выполняемого оператора ReDim указывается размерность массива в виде числа или выражения. Синтаксис оператора ReDim аналогичен синтаксису оператора объявления массива фиксированного размера. Например, размерность массива может быть задана любым из следующих способов:

ReDim massive(x)

ReDim massive(20)

ReDim massive(1 To 20)

При выполнении оператора ReDim данные, размещенные в массиве ранее, теряются. Это удобно в том случае, если данные вам больше не нужны, и вы хотите переопределить размерность массива и подготовить его для размещения новых данных. Если вы хотите изменить размер массива, не потеряв при этом данных, то необходимо воспользоваться оператором ReDim с ключевым словом preserve. Например, приведенный ниже программный код увеличивает размер массива на единицу без потери хранящихся в массиве данных:

ReDim Preserve massive(X)

Но при использовании ключевого слова Preserve можно поменять только последний аргумент, задающий размерность массива.

Для определения границ статического или динамического массива можно использовать функции Lbound и Ubound, которые возвращают соответственно нижнюю и верхнюю границу массива:

Lbound(arrname [, dimension])

Ubound(arrname [, dimension])

arrname – массив, для которого требуется определить границу;

dimension – номер размерности, для которой требуется определить границу.

Примеры:

1. Объявление одномерных массивов

Dim Sum(50) As Integer

Public Name(17) As String

Private Ln(11 to 31) As Double

2. Объявление многомерных массивов

Dim XYCol(100,100,16) As Integer

Public Tempr(15 to 30, 1 to 24) As Integer

3. Объявление статических массивов

Dim vArr(4 To 20, 5 То 70)

MsgBox "Нижняя граница 1-го измерения: " & LBound (vArr, 1)

' результат - 4

MsgBox "Нижняя граница 2-го измерения: " & LBound (vArr, 2)

'результат — 5

4. Объявление динамических массивов

Dim dArr()

ReDim dArr(l To 2, б То 10)

MsgBox "Нижняя граница 1-го измерения: " & LBound(dArr, 1) )

' результат - 1

MsgBox "Нижняя граница 2-го измерения: " & LBound(dArr, 2) )

'результат — 6

Поскольку Lbound и Ubound не воспринимают переменные, отличные от массивов, в скользких случаях имеет смысл до их использования проверить предварительно переменную с помощью IsArray.

IsArray(функция)

Сложнее обстоит дело с неинициализированным динамическим массивом, поскольку в VB/VBA нет средств для его проверки. Здесь можно использовать стандартный метод проверки по ошибке:

Dim vArr(20) As Integer

Dim t as Bool

t = IsArray(vArr)


Типовые алгоритмы задач на масси

Типовые алгоритмы задач на массивы

Одномерные массивы:

  • поиск суммы элементов при заданном условии

  • поиск количества элементов при заданном условии

  • поиск произведения элементов при заданном условии

  • поиск минимального элемента

  • поиск максимального элемента

Двумерные массивы:

  • поиск суммы элементов при заданном условии

  • поиск количества элементов при заданном условии

  • поиск произведения элементов при заданном условии

  • поиск минимального элемента

  • поиск максимального элемента

Для возврата к предыдущему материалу используйте кнопку "Назад" браузера.


Изучение интерфейса и правил работы в пакете Derive

Лабораторная работа: Работа с массивами

начало

назад

вперед

конец

вопросы

задания

Цель работы

Целью работы является изучение возможностей разработки приложений и получение практических навыков решения типовых задач с использованием одномерных и двумерных массивов.

Порядок выполнения работ

  • Запустить программу Visual Basic.

  • Изучить правила работы с одномерными и двумерными массивами - описание, ввод-вывод элементов массива, операции с элементами массива.

  • Выполнить задания, приведенные в методических указаниях.

  • Сохранить результаты работы на личной дискете.

  • Показать результаты работы преподавателю.

  • Хранить файлы результатов работы на личной дискете до завершения семестра.

Темы:

  • Задание 1 - изучение правил описания и ввода вывода элементов массива .

  • Задание 2 - разработка приложения с использованием одномерного массива.

  • Задание 3 - разработка приложения с использованием двумерного массива.

  • Задание 4 - разработка приложения с выводом элементов двумерного массива в таблицу (повышенной сложности)

Требования к отчету

Отчет по лабораторной работе - это краткое описание основных этапов выполнения работы. Он должен содержать:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • блок-схемы алгоритмов разработанных программ;

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с

начало

назад

вперед

конец

вопросы

задания


Заключение и выводы

начало

назад

вперед

конец

вопросы

задания

В процессе выполнения лабораторной работы были рассмотрены возможностей разработки приложений с использованием одномерных и двумерных массивов.

Были рассмотрены темы:

  • Задание 1 - изучение правил описания и ввода вывода элементов массива .

  • Задание 2 - разработка приложения с использованием одномерного массива.

  • Задание 3 - разработка приложения с использованием двумерного массива.

  • Задание 4 - разработка приложения с выводом элементов двумерного массива в таблицу. (повышенной сложности)

По результатам работы должен быть составлен отчет, содержащий:

  • название, цель и задачи лабораторной работы;

  • схематические рисунки форм разработанных проектов;

  • блок-схемы алгоритмов разработанных программ;

  • исходные текст программ на Visual Basic для разработанных проектов;

  • файлы проектов с результатами выполнения заданий;

  • заключения и выводы.

Список литературы

  1. Браун С. Visual Basic 6.0: учебный курс. С-Пб, "Питер", 1999 -322с.

начало

назад

вперед

конец

вопросы

задания


Вопросы к лабораторной работе

начало

назад

вперед

конец

вопросы

задания

  1. Что такое массив?

  2. Что называется размером массива?

  3. Могут ли элементы одного и того же массива иметь разный тип?

  4. Как выполняется обращение к элементам массива?

  5. Что понимается под диапазоном значений индекса массива?

  6. Как задается размерность массива при его описании?

  7. Какое значение принимает нижняя граница диапазона значений индекса по умолчанию?

  8. Чем ограничена верхняя граница диапазона значений индекса?

  9. Как можно организовать ввод элементов одномерного массива?

  10. Как можно организовать ввод элементов двумерного массива?

  11. Как можно организовать вывод элементов одномерного массива?

  12. Как можно организовать вывод элементов двумерного массива?

  13. Для чего при работе с массивами используется функция Split?

  14. Как организовать вывод элементов двумерного массива в таблицу?

Интерактивное тестирование

начало

назад

вперед

конец

вопросы

задания


Задания к лабораторной работе

Все задания к лабораторной работе

начало

назад

вперед

конец

вопросы

задания

ЗАДАНИЕ 1.
Решите задачи на работу с одномерными массивами (см. варианты индивидуальных заданий) с использованием ввода элементов из текстового поля. Для вывода результатов расчета используйте графические окна и форматный вывод.
Сохраните проект на диске. Пример программы.

ЗАДАНИЕ 2.
Решите задачи на работу с двумерными массивами (см. варианты индивидуальных заданий) с использованием ввода элементов массива из модального диалогового окна по запросу приложения или из текстового окна. Для вывода результатов расчета используйте графические окна.
Сохраните проект на диске. Пример программы, Пример программы.

ЗАДАНИЕ 3 (повышенной сложности).
Решите задачу № 3 на работу с двумерными массивами (см. варианты индивидуальных заданий) с использованием вывода элементов массива в таблицу.

Сохраните проект на диске.

Варианты индивидуальных заданий.

Вариант 1 | Вариант 2 | Вариант 3 | Вариант 4 | Вариант 5
Вариант 6 | Вариант 7 | Вариант 8 | Вариант 9 | Вариант 10
Вариант 11 | Вариант 12 | Вариант 13 | Вариант 14 | Вариант 15
Вариант 16 | Вариант 17 | Вариант 18 | Вариант 19 | Вариант 20
Вариант 21 | Вариант 22 | Вариант 23 | Вариант 24 | Вариант 25
Вариант 26 | Вариант 27 | Вариант 28 | Вариант 29 | Вариант 30

Помощь: типовые алгоритмы задач на одномерные и двумерные массивы.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Основные сведения о массивах

начало

назад

вперед

конец

вопросы

задания

Задачи обработки информации с использованием одномерных и двумерных массивов

Многие задачи, решаемые с помощью компьютера, связаны с обработкой больших объемов информации, представляющей совокупность данных, объединенных единым математическим содержанием или связанных между собой по смыслу. Часто такие данные представляются в виде линейных или прямоугольных таблиц.

В линейной таблице каждый элемент имеет соответствующий порядковый номер. В прямоугольной таблице каждый элемент имеет два номера: номер строки (по вертикали) и номер столбца (по горизонтали).

Примером обработки табличных данных может служить следующая задача. В процессе полета летательного аппарата через определенный интервал времени фиксируются значения скорости и высоты полета. После завершения полета данные обрабатываются, и находится максимальная скорость и максимальная высота полета.

Для сборки теоретического материала по тематике лабораторной работы рекомендуется пройти входное тестирование.

Требования к браузеру для тестирования

Используйте Internet Explorer либо Netscape Navigator версии 4.0 и выше.

В браузере должен быть разрешен запуск активного содержания.

Если тест не запустился, возможно он блокирован антивирусным монитором. Попробуйте запустить тест повторно. Если это не помогло, отключите монитор на время тестирования.

Необходимые пояснения

Тесты представляют собой последовательность вопросов и вариантов ответов, из которых следует выбрать верный. Как только Вы указываете Ваш вариант ответа, выводится новый вопрос и так вплоть до окончания тестирования. Количество вопросов для разных тестов варьируется.

По окончанию теста выводится страница с "Работой над ошибками", где Вы получаете возможность проверить себя и увидеть свои ошибки.

В любой момент в процессе тестирования Вы можете воспользоваться подсказкой, вызвав ее прямо со страницы с вопросом, либо прервать тест и вернуться к началу.

Начать тестирование.

начало

назад

вперед

конец

вопросы

задания


Основные сведения о массивах

В программировании табличные данные представляются в виде массивов.

Массив — это упорядоченная совокупность однотипных данных, с каждым из которых связан упорядоченный набор целых чисел, называемых индексами.

Все элементы массива, как правило, имеют одинаковый тип. Однако если массив имеет тип variant, то отдельные элементы могут содержать данные разных типов. Например, одни элементы могут быть числами, другие — строками или объектами.

Массив характеризуется именем, размерностью и размером.

Массив представляет собой набор переменных с одним именем и разными индексами. Каждая такая переменная называется элементом массива.

Массивы могут быть одномерными и многомерными. Размерностью массива называется количество его измерений.

Размером массива называется количество хранящихся в нем элементов. Размер массива ограничен объемом оперативной памяти и типом данных элементов массива.

Имя массива образуется по общему правилу образования имен, т. е. представляет собой идентификатор, например A, Bl, C8 и т. д. Имя массива не должно совпадать с именем ни одной простой переменной, используемой в той же программе.

Работа с массивом сводится к действиям над его элементами. Для того чтобы указать, какой элемент в данный момент используется, достаточно задать его порядковый номер, который приписывается к имени соответствующего массива в виде индекса. Количество индексов определяется размерностью массива. Таким образом, элементы массива обозначаются переменной с индексами.

Запись переменной с индексами состоит из имени массива и следующего за ним списка индексов.

Правило написания списка индексов зависит от конкретного языка программирования

Обращение к элементам массива выполняется по индексу. Индекс элемента указывается в круглых скобках после имени массива.

Например,

strNames(l), strNames(2), strNames(l0) - являются элементами массива с именем strNames.

Индексы определяют положение элемента в массиве. Число индексов определяет размерность массива, т.е. форму его компоновки: одномерный, двумерный и т. д. Одномерный массив соответствует линейной таблице. Его элемент обозначается переменной с одним индексом. Многомерны массив обозначается переменной с количеством индексов, соответствующим размерности массива.

Двумерный массив описывает в программе прямоугольную таблицу. Его элементы обозначаются переменной с двумя индексами.

Например, C8([I, J), С8{2, 1), где первый индекс обозначает номер строки, а второй — номер столбца.

Для записи элементов массива в память компьютера нужно выделить для их хранения необходимое количество (массив) ячеек памяти, которое определяется размером массива. Размеры массива задаются границами изменения индексов по каждому измерению (минимальное и максимальное значение индекса).

По умолчанию применяется так называемая нумерация с нулевой базой, т.е. элементы массива нумеруются, начиная с 0.

В программе для каждого массива должны быть указаны его параметры: имя, размерность и размеры. Эта информация нужна для резервирования необходимого объема памяти для хранения числовых значений; она задается специальным оператором описания массивов.

В зависимости от области видимости, которую должен иметь массив, для его объявления используются операторы: Public, Private, Dim и Static.

Диапазон значений индекса массива имеет верхнюю и нижнюю границу значений. При описании массива после его имени в скобках задается верхняя граница диапазона значений индекса. Эта граница не может превышать диапазона, представляемого типом Long. По умолчанию, нижней границей диапазона значений индекса является 0, но нижнюю границу можно и указать явно.

Для ввода/вывода массива в программе используют операторы цикла.

В программе элементы массива можно использовать точно так же, как и простую переменную.

Для возврата к предыдущему материалу используйте кнопку "Назад" web-браузера.


Переменные, константы и типы данных в Visual Basic

Переменные

Переменная представляет собой зарезервированное место в оперативной памяти для временного хранения данных. Каждая переменная имеет собственное имя. После того как переменной присвоено значение, ее можно использовать в программе вместо самого значения.

Имена переменных

Для того чтобы сделать переменные более наглядными и простыми для чтения, рекомендуется давать им имена, имеющие определенное смысловое значение. Существует несколько правил задания имен переменных;

- имя переменной может содержать не более 255 символов;

- имя переменной может содержать любые буквы и цифры;

- первый символ в имени переменной должен быть буквой;

- в имени переменной должны отсутствовать пробелы;

- имя должно быть уникальным в пределах области видимости.

Список ограничений достаточно велик, но ошибки будут выявлены при проверке синтаксиса программы.

Например, допустимы следующие имена переменных:

CurrentNum, Total, Date_of_birth

Следующие имена недопустимы:

1Time, $Total, Date of birth

Типы данных

В Visual Basic вы можете применять следующие типы данных:

- числовой:

-    integer - 2 байта: целые числа от —32768 до 32767,

-    Long - 4 байта: целые числа от —2 147483648 до 2 147483648,

-    Single - 4 байта: десятичные числа с плавающей точкой:
отрицательные -3,4^38 ... -1,4^-45, положительные: 1,4^-45 .. 3,4^38,

-    Double - 8 байт: десятичные числа с плавающей точкой:
отрицательные -1,7^-308 ... -4,9^-324,
положительные 4,9^-324 ... l,7^+308,

-    Currency - 8 байт десятичные числа с фиксированной точкой,
целая часть числа может содержать до 15 цифр, а дробная — до 4.

- строковый (String) - строки как фиксированной (до 216 символов), так и переменной длины (до 231 символов). При использовании ASCCII кодировки для каждого символа строки выделяется один байт, а при использовании кодировки Unicode — два байта. Кроме этого выделяется 10 байт для строки в целом.

- типа дата (Date) –для хранения даты и времени. Переменная этого типа требует 8 байт в оперативной памяти;

- байтовый (Byte) - 1 байт: для хранения двоичных;

- логический (Boolean) - для хранения данных, принимающих одно из двух значений: True (Истина) или False (Ложь). По умолчанию переменной данного типа присваивается значение False;

- произвольный (variant) – универсальный тип данных. Переменная этого типа может хранить любой из выше описанных типов данных.;

- объектный (object) - для хранения ссылок на объекты используется тип данных object. Каждая переменная данного типа требует 4 байта.

В наименованиях переменных рекомендуется использовать префиксы, отражающие тип переменной и область ее действия. При таком обозначении переменных повышается читабельность программы и снижается количество ошибок программирования.

Тип данных | Префикс | Пример
Boolean | bin | binSuccess
Byte | byt | bytImage
Currency | cur | curPrice
Date | dtm | dtmFinish
Double | dbl | dblSum
Integer | int | intQuantity
Long | Ing | IngTotal
Single | sng | sngLength
String | str | strLastname
Variant | vnt | vntValue

Объявление переменной

В Visual Basic используется явное и неявное объявление переменной. Явное объявление осуществляется операторами Dim, private, Static, public, которые имеют следующий синтаксис:

Dim имяПеременной [As типДанных]

Private имяПеременной [As типДанных]

Static имяПеременной [As типДанных]

Public имяПеременной [As типДанных]

Операторы Dim, Private, static, public определяют область действия переменной.

Dim - уровень отдельной процедуры или модуля;

Private - уровень модуля;

Public - уровень всех модулей приложения.

Переменные уровня процедуры доступны только в процедуре, в которой они были объявлены. Такие переменные называются локальными. Переменные, объявленные с помощью зарезервированного слова Dim существуют только во время выполнения процедуры. Если их объявить с помощью зарезервированного слова Static (статические переменные), то они будут существовать в течение всего времени выполнения приложения. Этим определяется жизненный цикл переменной. Чтобы объявить все локальные переменные в процедуре статическими, можно поместить зарезервированное слово Static перед заголовком процедуры. С помощью одного оператора вы можете объявлять несколько переменных, разделяя их запятыми.

Примеры объявления переменных:

Private bInSuccess As Boolean

Dim strLastname As String, dblSum As Double

Предпочтительнее использовать явное объявление переменных. в случае неявного объявления переменной ее тип определяется при первом операторе присвоения, и в этот же момент переменной будет выделена память. Если вы не используете специальные концевые символы, определяющие тип переменной, ей будет присвоен тип variant.

Присваивая имена переменным с учетом области ее действия, придерживайтесь следующего формата:

Область действия переменной | Префикс | Пример
Глобальная | g | gdtmFinish
Локальная внутри модуля | m | msngLength
Локальная внутри процедуры | нет префикса | strLastname

Для создания глобальной переменной, в раздел General Declarations главного модуля приложения помещают оператор public.

Например:

Public gdtmFinish As Date

Для объявления переменной, локальной внутри модуля или формы, используют оператор private или Dim в разделе General Declarations модуля или формы. В этом случае объявленная переменная будет доступна для всех входящих в форму или модуль процедур, но в то же время недоступной в процедурах других модулей и форм.

Переменные, локальные на уровне процедуры, создаются операторами Dim или static внутри процедуры.

Например:

Sub CalcTotal

Dim bSuccess As Boolean

. . .

End Sub

Для возврата к предыдущему материалу используйте кнопку "Назад" web-браузера.


Вектора в математике

Вектора и матрицы в математике

В высшей математике совокупность табличных величин, представленных в виде линейных таблиц называют векторами

,

а в виде прямоугольных таблиц – матрицами.

Матрица элементов из некоторого пространства S размера m×n — это объект из пространства Sm×n, координаты которого упорядочены по строкам и столбцам. При транспонировании матрицы A ее строки становятся столбцами и наоборот. Матрица, получаемая из A транспонированием, обозначается AT, например для матрицы

получаем

Вектором называется одномерный массив чисел. Например,

является вектором из трех элементов. Стандартной формой вектора мы будем считать вектор-столбец, т. е. n×1 матрицу; при его транспонировании получается вектор-строка

xT = (2 3 5).

Вектор, i-й элемент которого равен 1, а все остальные элементы равны 0, называют единичным вектором и обозначают ei. Количество элементов единичного вектора обычно определяется из контекста.

Нулевой матрицей называется матрица, все элементы которой равны 0. Такая матрица обычно обозначается O. Ее размер также обычно определяется из контекста.

Часто встречаются квадратные матрицы — матрицы размера n×n. Рассмотрим некоторые виды таких матриц:

1. У диагональной матрицы все внедиагональные элементы равны нулю (aij = 0 при i <> j), поэтому она может быть задана перечислением элементов, стоящих на диагонали.

2. Единичной матрицей называется диагональная матрица, диагональ которой заполнена единицами. При этом столбцами такой матрицы служат векторы e1, e2, …, en.

3. У верхне-треугольной матрицы все элементы под главной диагональю равны нулю (uij = 0 при i > j):

4. А у нижне-треугольной матрицы все элементы над главной диагональю равны нулю (lij = 0 при i < j):

5. Матрица перестановки имеет в точности одну единицу в каждой строке и в каждом столбце; на всех прочих местах у нее стоят нули. Пример матрицы перестановки:

Умножение вектора x на матрицу перестановки приводит к перестановке его элементов.

6. Симметрическая матрица удовлетворяет условию A = AT. Такая матрица, например:

Для возврата к предыдущему материалу используйте кнопку "Назад" web-браузера.


Создание приложения с одномерными массивами

начало

назад

вперед

конец

вопросы

задания

Решим задачу на одномерные массивы.

В одномерном массиве, содержащим N элементов найти сумму положительных элементов.

Блок схема алгоритма решения задачи.

Начало программы. Описываются массивы и, при необходимости, другие переменные. Вводится значение количества элементов в одномерном массиве. Переменной S, предназначенной для вычисления искомой суммы, присваивается значение, равное нулю. Организуется цикл с параметрами по переменной i, являющейся индексом элементов массива. Выполняется ввод элементов массива. В цикле ыполняется проверка, является ли текущий элемент массива положительным числом (большим нуля). Если условие проверки выполнено (элемент массива положительный), то выполняется суммирование - к текущему значению переменной S прибавляется значение элемента массива. Выполняется вывод значения найденной суммы. Конец программы.

Пример реализации формы приложения. В текстовом поле (TextBox), рядом с которым расположена метка (Label) задается количество элементов массива. Ввод элементов массива - из текстового поля (TextBox) . В качестве разделителя значений элементов массива используется пробел. Результаты расчета выводятся графическое поле (PictureBox).

На форме размещен поясняющий текст в элементах управления Метка (Label) Для ввода количества элементов массива использован элемент Текстовое поле (TextBox) Для ввода элементов массива использован элемент Текстовое поле (TextBox) На форме размещен поясняющий текст в элементах управления Метка (Label) Для активизации событийной процедуры использован элемент Кнопка управления (Command) Для вывода вычисленной суммы использовано Графическое поле (PictureBox)

Текст программы.

Описывается массив из 51 элемента. Массив состоит из десятичных чисел с плавающей точкой. Заголовок событийной процедуры, активизируемой по нажатию кнопки на форме приложения. Очистка графического окна вывода результатов. Обныление переменной, в которой производится вычисление суммы. Оператор, присваивающий переменной av, являющейся строковой переменной, значения элементов массива, введенных в текстовом поле через пробел. Цикл с параметрами для работы с элементами массива. Присвоение переменной с индексом значений элементов массива при одновременном их преобразовании из строковых значений в числовые (функция val). Проверка, является ли элемент массива положительным с использованием условного оператора, и если да - то выполнение операции суммирования. Признак завершения цикла (граница цикла). Вывод найденной суммы в Графическое поле. Завершение событийной процедуры.

Дополнительный материал: алгоритмы типовых задач (поиск сумм, произведений, максимума минимума и др.)

ЗАДАНИЕ 1.
Решите задачи на работу с одномерными массивами (см. раздел "Задания") с использованием ввода элементов из текстового поля. Для вывода результатов расчета используйте графические окна и форматный вывод.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Создание приложения с двумерными массивами

начало

назад

вперед

конец

вопросы

задания

Решим задачу на двумерные массивы.

В двумерном массиве размерности N на M найти сумму элементов, кратных числу 3.

Блок схема алгоритма решения задачи.

Начало программы. Описываются массивы и, при необходимости, другие переменные. Вводится значение количества элементов двумерного массива. Переменной S, предназначенной для вычисления искомой суммы, присваивается значение, равное нулю. Организуется циклы с параметрами, вложенные друг в друга, по переменным i и j, являющbvbcz индексами элементов массива. Выполняется ввод элементов массива. В цикле ыполняется проверка, делится ли текущий элемент массива на число 3 без остатка. Если условие проверки выполнено (элемент массива положительный), то выполняется суммирование - к текущему значению переменной S прибавляется значение элемента массива. Выполняется вывод значения найденной суммы. Конец программы.

Пример реализации формы приложения. Ввод элементов массива - построчный из модального диалогового окна по запросу приложения с помощью функции InputBox. Вывод элементов двумерного массива в графическое поле (PictureBox).

Для ввода данных использована функция InputBox Для ввода количества элементов массива по каждому измерению использован элемент Текстовое поле (TextBox) Для активизации событийной процедуры использован элемент Кнопка управления (Command) На форме размещен поясняющий текст в элементах управления Метка (Label) Для вывода матрицы использовано Графическое поле (PictureBox) Для вывода суммы использовано Графическое поле (PictureBox) На форме размещен поясняющий текст в элементах управления Метка (Label)

Текст программы.

Описывается двумерный массив из 260151 элемента (51х51). Массив состоит из десятичных чисел с плавающей точкой. Заголовок событийной процедуры, активизируемой по нажатию кнопки на форме приложения. Очистка графического окна вывода результатов. Обныление переменной, в которой производится вычисление суммы. Присвоение текстовой переменной строкового значения, которое булет выводиться в окне ввода данных. Цикл с параметрами для работы с элементами массива. Присвоение переменной X строки с элементами массива. Оператор, присваивающий переменной av, являющейся строковой переменной, значения строки элементов двумерного массива. Цикл с параметрами для работы с элементами строки двумерного массива. Присвоение переменной с индексами значений элементов массива (очередной строки) при одновременном из преобразовании из строковых значений в числовые (функция val). Проверка, делится ли элемент массива на 3 без остатка (с использованием условного оператора), и если да - то выполнение операции суммирования. Вывод строки элементов массива в Графическое поле. Признак завершения цикла (граница цикла). Присвоение переменной av пустой строки (обнулений переменной) для ее повторного использования при вводе очередной строки массива. Переход к следующей строке в Графическом поле, предназначенном для вывода матрицы. Признак завершения цикла (граница цикла). Вывод найденной суммы в Графическое поле. Завершение событийной процедуры.
ЗАДАНИЕ 2.
Решите задачи на работу с двумерными массивами в соответствии с индивидуальным заданием (см. раздел "Задания") с использованием ввода элементов массива из модального диалогового окна по запросу приложения. Для вывода результатов расчета используйте графические окна.

начало

назад

вперед

конец

вопросы

задания


Для запуска программы из главного меню Windows выполните следующие действия

Вывод элементов двумерного массива в таблицу

начало

назад

вперед

конец

вопросы

задания

Еще одна задача на двумерные массивы (повышенной сложности).

Дан двумерный массив размерности N на M. По выбору пользователя программы найти:

- сумму элементов массива

- произведение элементов массива

- значения максимального и минимального элементов массива

Пример реализации формы приложения с выводом элементов двумерного массива в таблицу.

Ниже приведен текст программы.

Для вывода результатов использована таблица - объект MSFlexGrid1. В процедуре Private Sub Command2_Click() создается таблица, размерностью n+1 строк и m+1 столбцов. Дополнительная строка и столбец в таблице нужны для простановки номеров (на форме эти элементы таблицы имеют серый фон).

В программе задается ширина ячеек таблицы (), т.е. определяются значения параметров ColWidth. Они различны для первой (ширина равна 300) и последующих (ширина равна 700) колонок.

Для вывода значений элементов массива использован форматный вывод данных.

ЗАДАНИЕ 3. (повышенной сложности)
Решите задачу №3 на работу с двумерными массивами в соответствии с индивидуальным заданием (см. раздел "Задания") с использованием вывода элементов массива в таблицу.

начало

назад

вперед

конец

вопросы

задания


Типовые алгоритмы

назад

Алгоритмы поиска минимального числа из двух заданных чисел.

Например даны два числа А и В (А¹В). Найти минимальное из этих чисел.

Задача может быть решена с использованием алгоритмов, в первом из которых использована базовая структура «выбор», а вором – «условный переход».

Максимальное число можно найти аналогично.

а)

б)

Алгоритм вычисления суммы элементов конечного функционального ряда.

Вычислить сумму ряда [image] .

Блок схемы алгоритмов ( а и б ) решения задачи абсолютно идентичны, но в первой блок-схеме для обозначения цикла использована базовая структура «цикл с параметром», во второй – «цикл с предусловием».

Перед циклом значение переменной S, в которой должна накапливаться сумма, необходимо обнулить (присвоить ей начальное значение, равное нулю), иначе сумма будет вычислена неверно.

Алгоритмы вычисления:

- произведения конечного функционального ряда;

- возведения заданного числа в целую степень;

- вычисления значения факториала.

Вычислить произведение конечного функционального ряда

.

Перед циклом переменной P, в которой должно накапливаться произведение, должно быть присвоено значение, равное единице, иначе произведение будет вычислена неверно.

Возвести заданное число X в целую степень N (XN).

N – целое положительное число.

Перед циклом переменной C, в которой будет вычисляться степень, должно быть присвоено значение, равное единице.

Вычислить значение факториала числа N (N!).

N – целое положительное число.

Перед циклом переменной F, в которой будет вычисляться факториал, должно быть присвоено значение, равное единице.

назад


Объявление массива

В Visual Basic существуют массивы фиксированного размера и динамические массивы. Массив фиксированного размера имеет неизменный размер, заданный при его объявлении. Динамические массивы могут изменять размер в процессе выполнения.

Объявление массива фиксированного размера

Как и любой тип данных, массив необходимо объявлять. Ниже приведен синтаксис объявления:

{ Dim | Private | Public I Static} имяМассива (<размер1> [, <размер2>] ...) [As типДанных] [, имяМассива (<размер1> [, <размер2>] ...) [As типДанных}] . . .

Существует 3 способа объявления массива фиксированного размера, которые зависят от области его видимости:

· создание глобального массива – объявляется с помощью оператора Public в секции Declarations модуля;

· создание глобального массива уровня модуля – объявляется с помощью оператора Private в секции Declarations модуля;

· создание локального массива – объявляется с помощью оператора Private в процедуре;

Размер массива может задаваться тремя способами:

· объявление только верхней границы массива, при этом нижняя граница массива по умолчанию принимает значение равное 0.

Dim arr(20) as integer ‘ создание массива из 21 элемента

· объявляется нижняя и верхняя границы изменения индекса

Dim arr(11 to 20) as integer ‘ создание массива из 10 элементов

· размер массива не объявляется

Dim arr() as integer ‘ создание массива, размерность неизвестна

Для возврата к предыдущему материалу используйте кнопку "Назад" браузера.


Оператор цикла с параметром

В программах Visual Basic для выполнения повторяющихся действий используются циклы.

Конструкция For...Next выполняет последовательность команд определенное число раз. Такую конструкцию называют циклом, а выполняемые ею программные коды — телом цикла.

For Счетчик = НачальноеЗначение То КонечноеЗначение [Step Шаг]

конструкции

Next [счетчик]

Первый аргумент конструкции — Счетчик — определяет имя переменной, которая будет "считать" количество выполнений цикла. Параметр НачальноеЗначение указывает числовое значение, которое присваивается переменной-счетчику при первом проходе цикла. Цикл выполняется до тех пор, пока значение счетчика не превысит КонечноеЗначение, указанное после ключевого слова To. После каждого прохода цикла значение счетчика изменяется на величину Шаг, указанную за ключевым словом Step. Ключевое слово Next обозначает конец тела цикла и является обязательным.

Для возврата к предыдущему материалу используйте кнопку "Назад" браузера.


Оператор условного перехода

В операторах условного перехода If ...Then ... и If ...Then ... Else ... условие и выполняемые при соблюдении условий действия располагаются в одной строке.

В том случае, если при выполнении условия требуется выполнение блока операторов, используются многострочные операторы, имеющие следующий синтаксис:

IF логическое выражение Then

операторы

End If

Конструкция If ... Then ... применяется, когда необходимо выполнить определенные действия в зависимости от некоторого условия.

IF условие Then

Конструкции для обработки истинного условия

Конструкция If ... Then ... Else ... используется в том случае, когда необходимо выполнить разные действия в зависимости от условия.

IF условие Then .

Конструкции для обработки истинного условия

Else

Конструкции для обработки ложного условия

End If

Ключевое слово End if обозначает конец многострочной конструкции и его наличие в операторе в этом случае обязательно.

Для возврата к предыдущему материалу используйте кнопку "Назад" браузера.


Общий подход к решению задач на массивы (на пр имере одномерного массива)

Задача: в одномерном массиве, содержащим N элементов найти сумму положительных элементов.

Прежде чем приступить к алгоритмизации задачи и составлению программы, необходимо представить себе, как бы вы решали задачу без использования компьютера. Для этого запишем математическую формулировку задачи и рассмотрим общий подход к ее решению.

Для заданного одномерного массива из n элементов введем обозначение A и запишем массив в виде вектора-строки

.

Обозначим искомую сумму как S.

Очевидно, что до начала решения задачи значение S должно быть равно нулю. В соответствии с условием задачи массив A может содержать положительные и отрицательные числа. Для решения задачи необходимо последовательно рассматривать элементы массива, начиная с a1 до aN.

Если очередной элемент массива ai является положительным (т.е. ai >0), то значение S должно быть увеличено на величину ai.

Задача может быть представлена как нахождение суммы в конечном числовом ряду, причем суммирование выполняется при соблюдении заданного условия

Рассмотрим пример.

Дан массив A, состоящий из 7 элементов: А = (10, -4, 2, 3, -17, 5, -12), среди которых есть положительные и отрицательные. Необходимо найти сумму положительных элементов.

В начале решения задачи значение суммы положительных элементов равно нулю.

Просматривая массив слева направо, мы видим, что положительными элементами являются 1-й, 3-й, 4-й и 6-й элементы массива. Очевидно, что при просмотре массива и нахождении положительного элемента его значение нужно добавить к уже накопленной ранее сумме, т.е. алгоритм решения задачи будет следующим:

1. Находим 1-й элемент в массиве. Его значение равно 10, элемент положительный. Сумма положительных элементов на этом этапе решения задачи будет равна 10.

2. Находим 2-й элемент в массива. Он меньше нуля (отрицательный). Сумма не изменяется.

3. Находим 3-й элемент в массиве. Его значение равно 2, элемент положительный. Сумма положительных элементов на этом этапе решения задачи будет равна 12.

4. Находим 4-й элемент в массиве. Его значение равно 3, элемент положительный. Сумма положительных элементов на этом этапе решения задачи будет равна 15.

5. Находим 5-й элемент в массиве. Он меньше нуля (отрицательный). Сумма не изменяется.

6. Находим 6-й элемент в массиве. Его значение равно 5, элемент положительный. Сумма положительных элементов на этом этапе решения задачи будет равна 20.

7. Находим 7-й элемент в массиве. Он меньше нуля (отрицательный). Сумма не изменяется.

В результате последовательного выполнения однотипных семи шагов алгоритма мы нашли искомую сумму положительный элементов массива. В нашем примере она равна 20.

Для возврата к предыдущему материалу используйте кнопку "Назад" web-браузера.


Разработка алгоритма решения задачи (на примере одномерного массива)

Задача: в одномерном массиве, содержащим N элементов найти сумму положительных элементов.

Разработка алгоритма решения задачи начинается с составления укрупненной блок-схемы алгоритма.

Затем выполняется детализация отдельных его блоков.

1. Алгоритм ввода элементов одномерного массива.

2. Алгоритма вычисления суммы положительных элементов одномерного массива.

Детализируя укрупненную блок схему алгоритма путем подстановки блоков ввода массива и вычисления суммы положительных элементов массива, получим полностью детализированный алгоритм решения задачи.

Как видно на блок схеме, решение задачи нахождения суммы элементов одномерного массива выполняется путем последовательного анализа элементов массива и вычисления суммы начиная с первого элемента и завершая элементом с номером N. Это дает возможность оптимизировать алгоритм, объединив ввод данных и вычисление суммы положительных элементов в одном цикле. В результате получим окончательный алгоритм решения задачи.

Для возврата к предыдущему материалу используйте кнопку "Назад" web-браузера.


Разработка алгоритма решения задачи (на примере одномерного массива)

Задача: в одномерном массиве, содержащим N элементов найти сумму положительных элементов.

Алгоритм решения задачи разрабатывается в несколько этапов.

На первом этапе составляется укрупненный алгоритм, а затем он детализируется и, по возможности, оптимизируется

Схема детализация и оптимизации укрупненного алгоритма решения задачи.

Для возврата к предыдущему материалу используйте кнопку "Назад" web-браузера.


Одномерные массивы

Поиск суммы элементов при заданном условии

Для возврата к предыдущему материалу используйте кнопку "Назад" браузера.


Одномерные массивы

Поиск количества элементов при заданном условии

Для возврата к предыдущему материалу используйте кнопку "Назад" браузера.


Одномерные массивы

Поиск произведения элементов при заданном условии

Для возврата к предыдущему материалу используйте кнопку "Назад" браузера.


Одномерные массивы

Поиск минимального элемента

Для возврата к предыдущему материалу используйте кнопку "Назад" браузера.


Одномерные массивы

Поиск максимального элемента

Для возврата к предыдущему материалу используйте кнопку "Назад" браузера.


Ссылки на теоретический материал

В соответствии с результатами тестирования для Вас сформирован теоретический материал.

Последовательно ознакомьтесь с теоретическим материалом а затем продолжите изучение материала лабораторной работы (кнопка "Вперед").

Теоретический материал по каждой теме открывается в новом окне браузера. Рекомендуется не закрывать эти окна до завершения работы с лабораторным практикумом, поскольку Вы сможете при необходимости просмотреть теоретический материал.

1. Сведения о массивах

2. Вектора и матрицы в математике

3. Переменные, константы и типы данных в Visual Basic

4. Объявление массивов в Visual Basic

5. Общий подход к решению задач на массивы

6. Разработка алгоритма решения задачи

Открыть теоретический материал

вперед


Ссылки на теоретический материал

В соответствии с результатами тестирования для Вас сформирован теоретический материал.

Последовательно ознакомьтесь с теоретическим материалом а затем продолжите изучение материала лабораторной работы (кнопка "Вперед").

Теоретический материал по каждой теме открывается в новом окне браузера. Рекомендуется не закрывать эти окна до завершения работы с лабораторным практикумом, поскольку Вы сможете при необходимости просмотреть теоретический материал.

1. Основные сведения о массивах

2. Объявление массивов в Visual Basic

3. Разработка алгоритма решения задачи

Открыть теоретический материал

вперед


Ссылки на теоретический материал

В соответствии с результатами тестирования для Вас сформирован теоретический материал.

Последовательно ознакомьтесь с теоретическим материалом а затем продолжите изучение материала лабораторной работы (кнопка "Вперед").

Теоретический материал по каждой теме открывается в новом окне браузера. Рекомендуется не закрывать эти окна до завершения работы с лабораторным практикумом, поскольку Вы сможете при необходимости просмотреть теоретический материал.

1. Основные сведения о массивах

3. Схема детализация укрупненного алгоритма решения задачи

Открыть теоретический материал

вперед


Ссылки на теоретический материал

В соответствии с результатами тестирования для Вас сформирован теоретический материал.

О знакомьтесь с теоретическим материалом а затем продолжите изучение материала лабораторной работы (кнопка "Вперед").

Теоретический материал будет открыт в новом окне браузера. Рекомендуется не закрывать это окно до завершения работы с лабораторным практикумом, поскольку Вы сможете при необходимости просмотреть теоретический материал.

1. Основные сведения о массивах

Открыть теоретический материал

вперед


Вариант № 1

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Найти количество отрицательных элементов массива.

  2. Найти сумму максимальных элементов массива.

  3. Найти среднее арифметическое максимальных и минимальных элементов массива и элементов с четными номерами индексов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить произведение элементов, значения которых равны заданному числу F.

  2. Найти местоположения минимальных (номера индексов) максимальных элементов массива.

  3. Найти среднее арифметическое максимальных и минимальных элементов массива в каждом из столбцов.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 2

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Найти количество положительных элементов массива.

  2. Найти сумму минимальных элементов массива.

  3. Элементы массива упорядочены по убыванию элементов. Переупорядочить массив по возрастанию его элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить сумму элементов, значения которых равны заданному числу F.

  2. Заменить элемент с индексом, равным заданному числу F значением максимального элемента.

  3. При условии что матрица квадратная (N = M), сделать матрицу симметричной относительно главной диагонали, заменяя при отсутствии симметрии меньший элемент на больший.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 3

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Найти значение максимального элемента массива.

  2. Найти произведение минимального элемента массива и элемента с номером M.

  3. Упорядочить массив по возрастанию элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить произведение элементов, значения которых не кратны заданному числу F.

  2. Найти частное от деления максимального элемента массива и элемента с номером L.

  3. Упорядочить массив по убыванию элементов сверху вниз и слева направо

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 4

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Найти значение минимального элемента массива.

  2. Найти сумму минимального элемента массива и элемента с номером M.

  3. Упорядочить массив по убыванию элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить сумму элементов, имеющих нечетные значения.

  2. Заменить все максимальные элементы значениями, равными заданному числу L.

  3. При условии что матрица квадратная (N = M), поменять на диагоналях матрицы значения с максимальными и минимальными элементами.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 5

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить количество элементов, значения которых больше заданного числа M.

  2. Заменить элементы с четными индексами, значением минимального элемента.

  3. Элементы массива упорядочены по возрастанию элементов. Переупорядочить массив по убыванию его элементов..

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить произведение элементов, имеющих четные значения.

  2. Найти количество минимальных элементов массива.

  3. Элементы массива упорядочены по возрастанию элементов в столбцах. Переупорядочить массив по убыванию его элементов в столбцах.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 6

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить количество элементов, значения которых меньше заданного числа M.

  2. Заменить элементы с четными индексами, значением максимального элемента.

  3. Найти среднее арифметическое максимальных и минимальных элементов массива и элементов с нечетными номерами индексов..

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить сумму элементов, значения которых кратны заданному числу F.

  2. Найти местоположения (номера индексов) минимальных элементов массива.

  3. При условии что матрица квадратная (N = M), сделать матрицу симметричной относительно главной диагонали, заменяя при отсутствии симметрии больший элемент на меньший

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 7

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить количество элементов, значения которых равны заданному числу M.

  2. Найти произведение максимальных элементов массива.

  3. Элементы массива упорядочены по убыванию элементов. Переупорядочить массив по возрастанию его элементов..

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить произведение элементов, имеющих нечетные значения.

  2. Найти разность максимального элемента массива и элемента с номером L.

  3. Найти среднее арифметическое максимальных и минимальных элементов массива и элементов, имеющих четные значения.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 8

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить количество элементов, значения которых кратны заданному числу M.

  2. Найти произведение минимальных элементов массива.

  3. Упорядочить массив по возрастанию элементов..

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить произведение элементов, значения которых меньше заданного числа F.

  2. Заменить элемент с индексом, равным заданному числу F значением максимального элемента.

  3. При условии что матрица квадратная (N = M), заполнить главную диагональ матрицы значениями сумм элементов ее столбцов.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 9

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить количество элементов, значения которых не кратны заданному числу M.

  2. Найти сумму максимального элемента массива и элемента с номером M.

  3. Упорядочить массив по убыванию элементов..

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить сумму элементов массива с четными значениями индексов его элементов.

  2. Найти местоположения (номера индексов) максимальных элементов массива.

  3. Элементы массива упорядочены по возрастанию элементов в строках. Переупорядочить массив по убыванию его элементов в строках.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 10

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить количество элементов, имеющих четные значения.

  2. Найти разность максимального элемента массива и элемента с номером M.

  3. Элементы массива упорядочены по возрастанию элементов. Переупорядочить массив по убыванию его элементов..

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить сумму элементов массива с нечетными значениями индексов его элементов.

  2. Найти произведение максимальных элементов массива.

  3. Упорядочить массив по возрастанию элементов сверху вниз и слева направо

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 11

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить количество элементов, имеющих нечетные значения.

  2. Найти произведение максимального элемента массива и элемента с номером M.

  3. Найти среднее арифметическое максимальных и минимальных элементов массива и элементов с четными номерами индексов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить произведение элементов, значения которых больше заданного числа F.

  2. Заменить все минимальные элементы значениями, равными заданному числу L.

  3. При условии что матрица квадратная (N = M), заполнить главную диагональ матрицы значениями минимальных элементов ее строк.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 1 2

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить сумму элементов, значения которых больше заданного числа M.

  2. Заменить все максимальные элементы значениями, равными заданному числу M.

  3. Элементы массива упорядочены по убыванию элементов. Переупорядочить массив по возрастанию его элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Найти количество отрицательных элементов массива.

  2. Найти сумму максимальных элементов массива.

  3. Найти среднее арифметическое максимальных и минимальных элементов массива и элементов с четными номерами индексов.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 1 3

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить сумму элементов, значения которых меньше заданного числа M.

  2. Найти количество минимальных элементов массива.

  3. Упорядочить массив по возрастанию элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить произведение элементов, значения которых кратны заданному числу F.

  2. Найти разность максимального элемента массива и элемента с номером L.

  3. Элементы массива упорядочены по убыванию элементов в строках. Переупорядочить массив по возрастанию его элементов в строках.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 1 4

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить сумму элементов, значения которых равны заданному числу M.

  2. Заменить элемент с индексом, равным заданному числу M значением максимального элемента.

  3. Упорядочить массив по убыванию элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Найти количество положительных элементов массива.

  2. Найти сумму минимальных элементов массива.

  3. Элементы массива упорядочены по убыванию элементов в строках. Переупорядочить массив по возрастанию его элементов в строках.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 1 5

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить сумму элементов, значения которых кратны заданному числу M.

  2. Найти местоположения (номера индексов) минимальных элементов массива.

  3. Элементы массива упорядочены по возрастанию элементов. Переупорядочить массив по убыванию его элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Найти значение максимального элемента массива.

  2. Найти произведение минимального элемента массива и элемента с номером L.

  3. Упорядочить массив по возрастанию элементов. сверху вниз и слева направо.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 1 6

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить сумму элементов, значения которых не кратны заданному числу M.

  2. Заменить элемент с индексом, равным заданному числу M значением минимального элемента.

  3. Найти среднее арифметическое максимальных и минимальных элементов массива и элементов с нечетными номерами индексов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Найти значение минимального элемента массива.

  2. Найти сумму минимального элемента массива и элемента с номером L.

  3. Найти номера строк, все элементы которых положительны.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 1 7

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить сумму элементов, имеющих четные значения.

  2. Заменить все минимальные элементы значениями, равными заданному числу M.

  3. Элементы массива упорядочены по убыванию элементов. Переупорядочить массив по возрастанию его элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить количество элементов, значения которых больше заданного числа F.

  2. Заменить элементы с четными индексами, значением минимального элемента.

  3. Все элементы с наибольшим значением заменить суммой положительных элементов.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 1 8

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить сумму элементов, имеющих нечетные значения.

  2. Заменить все максимальные элементы значениями, равными заданному числу M.

  3. Упорядочить массив по возрастанию элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить количество элементов, значения которых меньше заданного числа F.

  2. Заменить элементы с четными индексами, значением максимального элемента.

  3. Найти номера строк, все элементы которых отрицательны.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 1 9

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить произведение элементов, значения которых больше заданного числа M.

  2. Заменить все минимальные элементы значениями, равными заданному числу M.

  3. Упорядочить массив по убыванию элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить произведение элементов, значения которых не кратны заданному числу F.

  2. Найти количество максимальных элементов массива.

  3. Упорядочить массив по возрастанию элементов слева направо и сверху вниз.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 20

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить произведение элементов, значения которых меньше заданного числа M.

  2. Заменить элемент с индексом, равным заданному числу M значением максимального элемента.

  3. Элементы массива упорядочены по возрастанию элементов. Переупорядочить массив по убыванию его элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить количество элементов, значения которых равны заданному числу F.

  2. Найти произведение максимальных элементов массива.

  3. Найти произведение элементов строки, содержащие наибольший по модулю элемент.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 21

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить произведение элементов, значения которых равны заданному числу M.

  2. Найти местоположения минимальных (номера индексов) максимальных элементов массива.

  3. Найти среднее арифметическое максимальных и минимальных элементов массива и элементов, имеющих нечетные значения.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить количество элементов, значения которых кратны заданному числу F.

  2. Найти произведение минимальных элементов массива.

  3. Найти произведение элементов столбца, содержащие наибольший по модулю элемент.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 22

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить произведение элементов, значения которых кратны заданному числу M.

  2. Найти разность максимального элемента массива и элемента с номером M.

  3. Элементы массива упорядочены по убыванию элементов. Переупорядочить массив по возрастанию его элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить количество элементов, значения которых не кратны заданному числу F.

  2. Найти сумму максимального элемента массива и элемента с номером L.

  3. Найти произведение элементов столбца, содержащие наименьший по модулю элемент.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 23

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить произведение элементов, значения которых не кратны заданному числу M.

  2. Найти количество максимальных элементов массива.

  3. Упорядочить массив по возрастанию элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить количество элементов, имеющих четные значения.

  2. Найти разность максимального элемента массива и элемента с номером L.

  3. При условии что матрица квадратная (N = M), найти сумму элементов над главной диагональю.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 24

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить произведение элементов, значения которых не кратны заданному числу M.

  2. Найти частное от деления максимального элемента массива и элемента с номером M.

  3. Упорядочить массив по убыванию элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить количество элементов, имеющих нечетные значения.

  2. Найти произведение максимального элемента массива и элемента с номером L.

  3. При условии что матрица квадратная (N = M), найти произведение элементов под главной диагональю.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 25

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить произведение элементов, имеющих четные значения.

  2. Найти количество минимальных элементов массива.

  3. Элементы массива упорядочены по возрастанию элементов. Переупорядочить массив по убыванию его элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить сумму элементов, значения которых больше заданного числа F.

  2. Заменить все максимальные элементы значениями, равными заданному числу L.

  3. При условии что матрица квадратная (N = M), найти значение максимального элемента под главной диагональю.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 26

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить произведение элементов, имеющих нечетные значения.

  2. Найти разность максимального элемента массива и элемента с номером M.

  3. Найти среднее арифметическое максимальных и минимальных элементов массива и элементов, имеющих четные значения.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить сумму элементов, значения которых меньше заданного числа F.

  2. Найти количество минимальных элементов массива.

  3. При условии что матрица квадратная (N = M), поменять местами элементы главной и побочной диагонали.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 27

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить сумму элементов массива с четными значениями индексов его элементов.

  2. Найти местоположения (номера индексов) минимальных элементов массива.

  3. Элементы массива упорядочены по убыванию элементов. Переупорядочить массив по возрастанию его элементов..

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить произведение элементов массива с не четными значениями индексов его элементов.

  2. Заменить элемент с индексом, равным заданному числу L значением минимального элемента.

  3. Найти среднее арифметическое максимальных и минимальных элементов массива и элементов, имеющих нечетные значения.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 28

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить сумму элементов массива с нечетными значениями индексов его элементов.

  2. Найти произведение максимальных элементов массива.

  3. Упорядочить массив по возрастанию элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить сумму элементов, значения которых не кратны заданному числу F.

  2. Заменить элемент с индексом, равным заданному числу F значением минимального элемента.

  3. При условии что матрица квадратная (N = M), найти максимальный по модулю элемент на побочной диагонали и заменить его значением произведением элементов матрицы.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 29

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить произведение элементов массива с четными значениями индексов его элементов.

  2. Заменить все минимальные элементы значениями, равными заданному числу M.

  3. Упорядочить массив по убыванию элементов.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить произведение элементов массива с четными значениями индексов его элементов.

  2. Заменить все минимальные элементы значениями, равными заданному числу L.

  3. При условии что матрица квадратная (N = M), заполнить побочную диагональ матрицы значениями сумм элементов ее столбцов.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Вариант № 1

Вариант № 30

Индивидуальные задания к лабораторной работе № 4

Задания на одномерные массивы

Дан одномерный массив из N элементов.

  1. Определить произведение элементов массива с не четными значениями индексов его элементов.

  2. Заменить элемент с индексом, равным заданному числу M значением минимального элемента.

  3. Найти среднее арифметическое максимальных и минимальных элементов массива и элементов, имеющих нечетные значения.

Задания на двумерные массивы

Дан двумерный массив размерностью N x M элементов.

  1. Определить сумму элементов, имеющих четные значения.

  2. Заменить все минимальные элементы значениями, равными заданному числу L.

  3. При условии что матрица квадратная (N = M), заполнить главную диагональ матрицы значениями максимальных элементов ее строк.

Примечание: Задачу № 3 на двумерные массивы решить с использованием вывода элементов массива в таблицу.

назад


Новая страница 1

Пример оформления отчета по лабораторной работе

Начало

Вперед


Новая страница 2

Пример оформления отчета по лабораторной работе

Начало

Назад Вперед


Новая страница 3

Пример оформления отчета по лабораторной работе

Начало

Назад Вперед


Новая страница 4

Пример оформления отчета по лабораторной работе

Начало

Назад Вперед


Новая страница 5

Пример оформления отчета по лабораторной работе


Отчет по лабораторной работе офо

Оформление отчетов по лабораторным работам

Отчеты по лабораторным работам оформляются на листах формата А4 (210 х 297 мм).

Текст отчета пишется от руки (не печатается на принтере).

Блок-схемы алгоритмов вычерчиваются в соответствии с требованиями ГОСТ 19.701-90 (международный стандарт ИСО 5807-85).

Требования к содержанию отчетов приведены в описаниях лабораторных работ.

Пример оформления отчета по лабораторной работе "Работа с массивами"

Начало


Требования к браузеру для тестир

Требования к браузеру для тестирования

Используйте Internet Explorer либо Netscape Navigator версии 4.0 и выше.

В браузере должен быть разрешен запуск активного содержания.

Если тест не запустился, возможно он блокирован антивирусным монитором. Попробуйте запустить тест повторно. Если это не помогло, отключите монитор на время тестирования.

Необходимые пояснения

Тесты представляют собой последовательность вопросов и вариантов ответов, из которых следует выбрать верный. Как только Вы указываете Ваш вариант ответа, выводится новый вопрос и так вплоть до окончания тестирования. Количество вопросов для разных тестов варьируется.

По окончанию теста выводится страница с "Работой над ошибками", где Вы получаете возможность проверить себя и увидеть свои ошибки.

В любой момент в процессе тестирования Вы можете воспользоваться подсказкой, вызвав ее прямо со страницы с вопросом, либо прервать тест и вернуться к началу.

Для возврата к предыдущему материалу используйте кнопку "Назад" web-браузера.


Интерактивный тест к лабораторному комплексу по Visual Basic

Интерактивные тесты

Версия для локального пользования не включает скрипты теста "Защита лабораторной работы" и "зачет".
Для работы с ними следует обратиться на наш сайт

После выбора номера раздела щелкните по ссылке "Начать тестирование"

Выберите раздел :

Начать тестирование | 1. | Изучение интегрированной среды и основ работы в Visual Basic
 | 2. | Организация ввода-вывода данных, изменение свойств объектов
 | 3. | Разработка приложений с разветвляющимися и циклическими алгоритмами
 | 4. | Работа с массивами
 | 5. | Работа файлами и строками
 | 6. | Работа с графикой
 | 7. | Разработка многооконных приложений

Требования к браузеру для тестирования

Используйте Internet Explorer либо Netscape Navigator версии 4.0 и выше.

В браузере должен быть разрешен запуск активного содержания.

Необходимые пояснения

Тесты представляют собой последовательность вопросов и вариантов ответов, из которых следует выбрать верный. Как только Вы указываете Ваш вариант ответа, выводится новый вопрос и так вплоть до окончания тестирования. Количество вопросов для разных тестов варьируется.

По окончанию теста выводится страница с "Работой над ошибками", где Вы получаете возможность проверить себя и увидеть свои ошибки.

В любой момент в процессе Вы можете воспользоваться подсказкой, вызвав ее прямо со страницы с вопросом, либо прервать тест и вернуться к началу.

Начало


Настройка переметров теста

в файле producerLocal.html

    строки 18 и 19
var howMany =
        1. можно задать режим выдачи всех имеющихся вопросов
        2. можно указать количество вопросов. которые будут задаваться обучаемому. Они выбираются случайно из общего количества вопросов

    строка 23
var id=
    настройка вывода результатов (id=0 без разбора и ссылок), (id=1 разбор теста), (id=2 ссылки), (id=3 разбор теста и ссылки).

    строка 27
    задание количества вариантов уровней сложности теоретического материала (при этом id должен быть равен 4)
 var numtheory = 3


Новая страница 2

Файл с тестовыми заданиями
по выбранной Вами тематике

недоступен


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|26 Jan 2005 22:22:36 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|TARKHOV\\Сережа vti_modifiedby:SR|TARKHOV\\Сережа vti_timecreated:TR|26 Jan 2005 22:22:36 -0000 vti_cacheddtm:TX|26 Jan 2005 22:22:36 -0000 vti_filesize:IR|1053 vti_cachedtitle:SR|Новая страница 2 vti_cachedbodystyle:SR| vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language en-us HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1252 vti_charset:SR|windows-1252 vti_language:SR|en-us vti_title:SR|Новая страница 2 vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Mar 2004 06:39:22 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|TARKHOV\\Сережа vti_modifiedby:SR|TARKHOV\\Сережа vti_timecreated:TR|13 Mar 2004 06:39:22 -0000 vti_cacheddtm:TX|13 Mar 2004 06:39:22 -0000 vti_filesize:IR|1250 vti_cachedtitle:SR|On-Line Test Probability Theory vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../designer.js S|questions.js S|../producerGlobal.js vti_cachedsvcrellinks:VX|FSUS|Курс\\ по\\ Visual\\ Basic/tests/designer.js NSUS|Курс\\ по\\ Visual\\ Basic/tests/test-1/questions.js FSUS|Курс\\ по\\ Visual\\ Basic/tests/producerGlobal.js vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_title:SR|On-Line Test Probability Theory vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Mar 2004 06:39:22 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|TARKHOV\\Сережа vti_modifiedby:SR|TARKHOV\\Сережа vti_timecreated:TR|13 Mar 2004 06:39:22 -0000 vti_cacheddtm:TX|13 Mar 2004 06:39:22 -0000 vti_filesize:IR|1250 vti_cachedtitle:SR|On-Line Test Probability Theory vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../designer.js S|questions.js S|../producerGlobal.js vti_cachedsvcrellinks:VX|FSUS|Курс\\ по\\ Visual\\ Basic/tests/designer.js NSUS|Курс\\ по\\ Visual\\ Basic/tests/test-2/questions.js FSUS|Курс\\ по\\ Visual\\ Basic/tests/producerGlobal.js vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_title:SR|On-Line Test Probability Theory vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Mar 2004 06:39:22 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|TARKHOV\\Сережа vti_modifiedby:SR|TARKHOV\\Сережа vti_timecreated:TR|13 Mar 2004 06:39:22 -0000 vti_cacheddtm:TX|13 Mar 2004 06:39:22 -0000 vti_filesize:IR|1250 vti_cachedtitle:SR|On-Line Test Probability Theory vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../designer.js S|questions.js S|../producerGlobal.js vti_cachedsvcrellinks:VX|FSUS|Курс\\ по\\ Visual\\ Basic/tests/designer.js NSUS|Курс\\ по\\ Visual\\ Basic/tests/test-3/questions.js FSUS|Курс\\ по\\ Visual\\ Basic/tests/producerGlobal.js vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_title:SR|On-Line Test Probability Theory vti_backlinkinfo:VX|


Интерактивный тест

Интерактивные тесты

Вы можете проверить свои знания, используя интерактивные тесты "Для самопроверки".

Начать тестирование

Необходимые пояснения

Тесты представляют собой последовательность вопросов и вариантов ответов, из которых следует выбрать верный. Как только Вы указываете Ваш вариант ответа, выводится новый вопрос и так вплоть до окончания тестирования. Количество вопросов для разных тестов варьируется.

По окончанию теста выводится страница с "Работой над ошибками", где Вы получаете возможность проверить себя и увидеть свои ошибки.

В любой момент в процессе Вы можете воспользоваться подсказкой, вызвав ее прямо со страницы с вопросом, либо прервать тест и вернуться к началу.

Требования к браузеру для тестирования

Используйте Internet Explorer либо Netscape Navigator версии 4.0 и выше.

В браузере должен быть разрешен запуск активного содержания.

Для возврата к предыдущему материалу используйте кнопку "Назад" браузера.


Интерактивный тест

Ваш броузер не поддерживает фреймы (Наверное надо добавить к сожалению).

Для просмотра данного документа используйте Netscape 2.0 или выше, либо MSIE 3.0 и выше.

Перейти к Первой странице сайта


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 May 2005 15:55:18 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|SERG\\Тархов vti_modifiedby:SR|SERG\\Тархов vti_timecreated:TR|19 Apr 2005 19:03:46 -0000 vti_title:SR|Интерактивный тест vti_backlinkinfo:VX|VB(АДАПТИВНЫЙ\\ 2)/lr4/question.htm vti_nexttolasttimemodified:TW|02 May 2005 15:55:06 -0000 vti_cacheddtm:TX|02 May 2005 15:54:49 -0000 vti_filesize:IR|3418 vti_cachedtitle:SR|Интерактивный тест vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|Q|../default.css H|javascript:\\ checkBrowser();void(0); vti_cachedsvcrellinks:VX|NQUS|VB(АДАПТИВНЫЙ\\ 2)/tests/default.css SHUS|javascript:\\ checkBrowser();void(0); vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ Charset=Windows-1251 Author Ivan\\ Degtiarenko vti_charset:SR|windows-1251


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 May 2005 11:55:40 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|SERG\\Тархов vti_modifiedby:SR|SERG\\Тархов vti_timecreated:TR|19 Apr 2005 17:34:11 -0000 vti_title:SR|Интерактивный тестc vti_backlinkinfo:VX|VB(АДАПТИВНЫЙ\\ 2)/tests/test-4/starttest0.html vti_nexttolasttimemodified:TW|02 May 2005 11:54:41 -0000 vti_cacheddtm:TX|02 May 2005 11:55:40 -0000 vti_filesize:IR|2160 vti_cachedtitle:SR|Интерактивный тестc vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../designer.js S|questions.js S|../producerGlobal.js vti_cachedsvcrellinks:VX|FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/designer.js FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/test-4/questions.js FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/producerGlobal.js vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 May 2005 12:02:11 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|SERG\\Тархов vti_modifiedby:SR|SERG\\Тархов vti_timecreated:TR|19 Apr 2005 18:23:03 -0000 vti_title:SR|Интерактивный тестc vti_backlinkinfo:VX|VB(АДАПТИВНЫЙ\\ 2)/tests/test-4/starttest1.html vti_nexttolasttimemodified:TW|02 May 2005 11:55:42 -0000 vti_cacheddtm:TX|02 May 2005 12:02:11 -0000 vti_filesize:IR|2164 vti_cachedtitle:SR|Интерактивный тестc vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../designer.js S|questions.js S|../producerGlobal.js vti_cachedsvcrellinks:VX|FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/designer.js FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/test-4/questions.js FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/producerGlobal.js vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 May 2005 11:58:27 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|SERG\\Тархов vti_modifiedby:SR|SERG\\Тархов vti_timecreated:TR|19 Apr 2005 17:34:22 -0000 vti_title:SR|Интерактивный тестc vti_backlinkinfo:VX|VB(АДАПТИВНЫЙ\\ 2)/tests/test-4/starttest2.html vti_nexttolasttimemodified:TW|02 May 2005 11:56:15 -0000 vti_cacheddtm:TX|02 May 2005 11:58:27 -0000 vti_filesize:IR|2163 vti_cachedtitle:SR|Интерактивный тестc vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../designer.js S|questions.js S|../producerGlobal.js vti_cachedsvcrellinks:VX|FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/designer.js FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/test-4/questions.js FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/producerGlobal.js vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 May 2005 11:58:48 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|SERG\\Тархов vti_modifiedby:SR|SERG\\Тархов vti_timecreated:TR|19 Apr 2005 17:34:29 -0000 vti_title:SR|Интерактивный тестc vti_backlinkinfo:VX|VB(АДАПТИВНЫЙ\\ 2)/tests/test-4/starttest3.html vti_nexttolasttimemodified:TW|02 May 2005 11:56:17 -0000 vti_cacheddtm:TX|02 May 2005 11:58:48 -0000 vti_filesize:IR|2163 vti_cachedtitle:SR|Интерактивный тестc vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../designer.js S|questions.js S|../producerGlobal.js vti_cachedsvcrellinks:VX|FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/designer.js FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/test-4/questions.js FSUS|VB(АДАПТИВНЫЙ\\ 2)/tests/producerGlobal.js vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|19 Apr 2005 15:55:26 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|SERG\\Тархов vti_modifiedby:SR|SERG\\Тархов vti_timecreated:TR|19 Apr 2005 15:55:26 -0000 vti_cacheddtm:TX|19 Apr 2005 15:55:26 -0000 vti_filesize:IR|798 vti_cachedtitle:SR|Новая страница 2 vti_cachedbodystyle:SR| vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language en-us HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1252 vti_charset:SR|windows-1252 vti_language:SR|en-us vti_title:SR|Новая страница 2 vti_backlinkinfo:VX|


Интерактивный тест к лабораторному комплексу по Visual Basic

Ваш броузер не поддерживает фреймы (Наверное надо добавить к сожалению).

Для просмотра данного документа используйте Netscape 2.0 или выше, либо MSIE 3.0 и выше.

Перейти к Первой странице сайта


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|26 Jan 2005 22:15:30 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|TARKHOV\\Сережа vti_modifiedby:SR|TARKHOV\\Сережа vti_timecreated:TR|26 Jan 2005 22:15:30 -0000 vti_cacheddtm:TX|26 Jan 2005 22:15:30 -0000 vti_filesize:IR|1279 vti_cachedtitle:SR|Интерактивный тест к лабораторному комплексу по Visual Basic vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../designer.js S|questions.js S|../producerGlobal.js vti_cachedsvcrellinks:VX|FSUS|Visual\\ Basic\\ (АДАПТИВНЫЙ)/tests/designer.js FSUS|Visual\\ Basic\\ (АДАПТИВНЫЙ)/tests/test-4-1/questions.js FSUS|Visual\\ Basic\\ (АДАПТИВНЫЙ)/tests/producerGlobal.js vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_title:SR|Интерактивный тест к лабораторному комплексу по Visual Basic vti_backlinkinfo:VX|Visual\\ Basic\\ (АДАПТИВНЫЙ)/tests/test-4-1/index.html


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|26 Jan 2005 21:48:28 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|TARKHOV\\Сережа vti_modifiedby:SR|TARKHOV\\Сережа vti_timecreated:TR|26 Jan 2005 21:48:28 -0000 vti_cacheddtm:TX|26 Jan 2005 21:48:28 -0000 vti_filesize:IR|1110 vti_cachedtitle:SR|Новая страница 2 vti_cachedbodystyle:SR| vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language en-us HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1252 vti_charset:SR|windows-1252 vti_language:SR|en-us vti_title:SR|Новая страница 2 vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Mar 2004 06:39:22 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|TARKHOV\\Сережа vti_modifiedby:SR|TARKHOV\\Сережа vti_timecreated:TR|13 Mar 2004 06:39:22 -0000 vti_cacheddtm:TX|13 Mar 2004 06:39:22 -0000 vti_filesize:IR|1250 vti_cachedtitle:SR|On-Line Test Probability Theory vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../designer.js S|questions.js S|../producerGlobal.js vti_cachedsvcrellinks:VX|FSUS|Курс\\ по\\ Visual\\ Basic/tests/designer.js NSUS|Курс\\ по\\ Visual\\ Basic/tests/test-5/questions.js FSUS|Курс\\ по\\ Visual\\ Basic/tests/producerGlobal.js vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_title:SR|On-Line Test Probability Theory vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Mar 2004 06:39:22 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|TARKHOV\\Сережа vti_modifiedby:SR|TARKHOV\\Сережа vti_timecreated:TR|13 Mar 2004 06:39:22 -0000 vti_cacheddtm:TX|13 Mar 2004 06:39:22 -0000 vti_filesize:IR|1250 vti_cachedtitle:SR|On-Line Test Probability Theory vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../designer.js S|questions.js S|../producerGlobal.js vti_cachedsvcrellinks:VX|FSUS|Курс\\ по\\ Visual\\ Basic/tests/designer.js NSUS|Курс\\ по\\ Visual\\ Basic/tests/test-6/questions.js FSUS|Курс\\ по\\ Visual\\ Basic/tests/producerGlobal.js vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_title:SR|On-Line Test Probability Theory vti_backlinkinfo:VX|


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|13 Mar 2004 06:39:22 -0000 vti_extenderversion:SR|6.0.2.6353 vti_author:SR|TARKHOV\\Сережа vti_modifiedby:SR|TARKHOV\\Сережа vti_timecreated:TR|13 Mar 2004 06:39:22 -0000 vti_cacheddtm:TX|13 Mar 2004 06:39:22 -0000 vti_filesize:IR|1250 vti_cachedtitle:SR|On-Line Test Probability Theory vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../designer.js S|questions.js S|../producerGlobal.js vti_cachedsvcrellinks:VX|FSUS|Курс\\ по\\ Visual\\ Basic/tests/designer.js NSUS|Курс\\ по\\ Visual\\ Basic/tests/test-7/questions.js FSUS|Курс\\ по\\ Visual\\ Basic/tests/producerGlobal.js vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_title:SR|On-Line Test Probability Theory vti_backlinkinfo:VX|


Интегрированная среда визуального объектно

Интегрированная среда
визуального объектно-ориентированного программирования Visual Basic 6.0

на главную страницу

Начало работы.. 2

Компоненты рабочей среды.. 3

Главное меню.. 3

Стандартная панель инструментов. 4

Окно конструктора форм.. 4

Панель элементов управления. 5

Окно редактора меню.. 5

Окно свойств. 6

Окно просмотра объектов. 7

Окно макета формы.. 8

Окно редактора исходного кода. 8

Окно проводника проекта. 8

Окно локальных переменных. 9

Окно контроля работы приложения. 9

Окно ручного ввода и выполнения команд.. 10

Настройка среды разработки. 10

Вкладка настроек редактора. 11

Вкладка стилей текста. 12

Вкладка настроек общих свойств среды.. 12

Вкладка настройки окон. 13

Вкладка Environment 14

Вкладка Advanced. 14

ПРИЛОЖЕНИЕ.. 16

Команды меню File. 16

Команды меню Edit 16

Команды меню View.. 17

Команды меню Project 17

Команды меню Format 18

Команды меню Debug. 18

Команды меню Run. 18

Команды меню Query. 18

Команды меню Diagram.. 19

Команды меню Tools. 19

Команды меню Add-Ins. 20

Команды меню Window.. 20

Команды меню Help. 20

Кнопки стандартной панели инструментов. 20

Кнопки панели элементов управления. 21

Начало работы

При запуске Visual Basic 6 на экране появляется диалоговое окно New Project (Новый проект), используя которое можно выбрать шаблон для нового проекта, запустить мастера создания проекта или открыть ранее созданный проект (рис. 1).

Рис. 1 Окно создания проекта

Это окно содержит вкладки следующего назначения:

- New (Новый) — содержит шаблоны и мастера для создания нового проекта;

- Existing (Существующий) — позволяет открыть ранее созданный проект или проекты-примеры, поставляемые с Visual Basic 6. Вкладка имеет раскрывающийся список, с помощью которого можно выбрать любую папку на имеющихся ресурсах компьютера;

- Recent (Недавно созданный) — содержит список проектов, открывавшихся в последнее время;

Для создания нового проекта используется вкладка New. На ней можно выбрать один из следующих типов шаблона проекта:

- Standard EXE — стандартное выполняемое приложение;

- ActiveX EXE — выполняемое приложение ActiveX;

- ActiveX DLL — динамическая библиотека ActiveX;

- ActiveX Control — элемент управления ActiveX;

- VB Application Wizard — мастер приложений;

- VB Wizard Manager — мастер создания пользовательских мастеров;

- Data Project — проект управления базой данных;

- IIS Application — приложение, размещаемое на сервере Web-узла (IIS — Internet Information Server);

- Addin — надстройка, дополнительные утилиты, расширяющие возможности приложений;

- ActiveX Document DLL — динамическая библиотека документов ActiveX;

- ActiveX Document EXE — выполняемое приложение документов ActiveX;

- DHTML Application — приложение, создающее динамические HTML-страницы.

к началу

Компоненты рабочей среды

После выбора типа проекта пользователь переходит непосредственно в инструментальную среду проектирования Visual Basic 6. Ее внешний вид показан на рис. 2

Рис. 2 Инструментальная среда Visual Basic 6.

Элементы среды:

- главное меню;

- стандартная панель инструментов;

- панель элементов управления;

- окно проводника проекта (Project);

- конструктор форм;

- окно свойств (Properties);

- окно макета формы (Form Layout);

- окно просмотра объектов (Object Browser);

- редактор исходного кода.

к началу

Главное меню

Главное меню, как и во всех приложениях Microsoft, представляет собой линейку раскрывающихся меню. Оно содержит следующие основные команды: File (Файл), Edit (Правка), View (Вид), Project (Проект), Format (Формат), Debug (Отладка), Run (Запуск), Query (Запрос), Diagram (Диаграмма), Tools (Сервис), Add-Ins (Надстройки), Window (Окно), Help (Справка).

Наиболее часто используемые команды меню отображены в виде кнопок со значками на стандартной панели инструментов, размещенной ниже меню. Рассмотрим основные команды главного меню.

Меню File (Файл) содержит команды для работы с файлами проекта. Используя эти команды, можно выполнять такие действия, как создание нового проекта, открытие проекта для внесения изменений, добавление проекта для параллельной работы над несколькими проектами или копирование форм из проекта в проект и т. п. Все команды этого меню перечислены в табл. 1- 13 Приложения.

Меню Edit (Правка) содержит команды, предназначенные для редактирования. Часть из них соответствует подобным командам редактирования других приложений Microsoft, например, отменить предыдущую команду, повторить предыдущую команду, вырезать фрагмент текста, скопировать фрагмент в буфер обмена. В составе этого меню целый набор команд для работы с таблицами базы данных: добавлять и удалять поля, назначать первичный ключ в таблице базы данных.

Меню View (Вид) содержит команды вызова окон и панелей инструментальной среды Visual Basic 6.

Меню Project (Проект) содержит команды управления проектом и его элементами. Они позволяют добавить в проект и удалить из него элементы проекта, такие как форма, программный модуль, класс и другие. С помощью команд данного меню вы также можете открыть окно свойств приложения, добавить ссылки на подключаемые библиотеки, добавить дополнительные компоненты на панель элементов.

Меню Format (Формат) содержит большое количество команд форматирования объектов в форме.

Меню Debug (Отладка) содержит команды, предназначенные для отладки приложения. Используя команды этого меню, можно установить точки останова программы и проверить значения выражении и переменных, выполняя программу по шагам.

Меню Run (Запуск) содержит команды управления запуском приложения. Используя команды данного меню, можно запустить приложение на выполнение с компиляцией или без компиляции, приостановить или прервать выполнение приложения.

Меню Query (Запрос) содержит команды создания и выполнения запросов к базе данных. При помощи этого меню, например, можно выполнить запрос, преобразовать результаты запроса в табличный вид.

Меню Diagram (Диаграмма) содержит команды построения диаграммы, отображающей структуру базы данных.

Меню Tools (Сервис) содержит команды управления настройками инструментария среды Visual Basic 6. Они позволяют добавить процедуру и определять ее атрибуты, вызвать окно редактора меню, изменить настройки программы в диалоговом окне Options (Параметры), а также управлять хранилищем проектов SourseSafe.

Меню Add-Ins (Надстройки) содержит команды вызова дополнительных утилит, часто называемых надстройками (add-ins).

Меню Window (Окно) содержит стандартные команды управления окнами. При вызове окон приложения меню Window пополняется соответствующими командами активизации окон приложения. При этом команды активизации окон называются по именам открытых окон.

Меню Help (Справка) содержит команды вызова справочной системы Visual Basic 6. При помощи этого меню можно вызывать справочную систему с различными вариантами представления информации. Отличие между ними состоит в открывающейся по умолчанию вкладке.

к началу

Стандартная панель инструментов

Команды, которые часто используются при работе, можно разместить в виде кнопок на панели инструментов. Можно также исключить из панели редко применяемые команды.

Кнопки панели инструментов снабжены всплывающими подсказками.

Стандартная панель инструментов, расположенная под главным меню, показана на рис. 3 (в том виде, в каком она настроена при установке Visual Basic 6).

Рис. 3 Стандартная панель инструментов

Если эта панель отсутствует в главном окне программы, для ее отображения в меню View (Вид) выберите команду Toolbars (Панели инструментов), а затем значение Standard (Стандартная).

На стандартной панели инструментов расположены кнопки для вызова наиболее часто употребляемых команд меню. Вы можете изменить расположение стандартной панели инструментов, разместив ее в нижней части главного окна, справа или слева. Для этого с помощью кнопки мыши захватите любую границу панели и переместите ее в любое удобное для вас место.

Описание наиболее часто используемые команд панели инструментов приведено в табл. 14 Приложения.

к началу

Окно конструктора форм

Окно конструктора форм является основным рабочим окном, в котором выполняется визуальное проектирование приложения. Это окно показано на рисунке.

Рис. 4 Окно конструктора форм

Вызвать это окно можно из главного меню командой Object (Объект) меню View (Вид) или командой View Object контекстного меню объекта, находящегося в группе Forms в проводнике проекта.

В окне конструктора форм визуально конструируются все формы приложения с использованием инструментария среды разработки.

Для точного позиционирования объектов в форме в окне имеется сетка. Размер ячеек сетки можно менять. При необходимости сетку можно отключать, воспользовавшись параметрами диалогового окна Options, открываемого командой Options (Параметры) из меню View (Вид).

Размер формы в окне можно изменять, используя маркеры выделения формы и мышь. Для изменения размера формы необходимо установить указатель мыши на маркер и, когда он примет вид двунаправленной стрелки, перемещать до получения требуемого размера.

к началу

Панель элементов управления

Панель элементов управления — основной рабочий инструмент при визуальной разработке форм приложения (рис. 5).

Панель элементов управления вызывается из меню View (Вид) командой Toolbox (Панель элементов управления). Для вызова этой панели можно воспользоваться также кнопкой Toolbox на стандартной панели инструментов.

Рис. 5. Панель элементов управления Visual Basic 6

В составе панели элементов управления содержатся основные элементы управления форм — метки, текстовые поля, кнопки, списки и другие элементы для быстрого визуального проектирования макета формы. На панели представлены кнопки, назначение которых описано в табл. 1.15.

Для размещения элементов управления в форме с помощью панели элементов выполните следующие действия:

1. Выделите требуемый элемент управления с помощью мыши.

2. Перейдите в окно конструктора форм. Указатель мыши при этом превратится в крестик, при помощи которого можно установить местоположение размещаемого объекта. Левой кнопкой мыши зафиксируйте позицию нового объекта и, удерживая кнопку, задайте размеры объекта.

к началу

Окно редактора меню

В окне редактора меню Menu Editor (рис. 6) можно создавать или редактировать строку меню для формы.

Рис. 6 Окно редактора меню

Для проектирования меню всех видов используется редактор меню Menu Editor (Редактор меню) среды проектирования IDE.

Редактор меню вызывается одним из следующих способов:

- командой Menu Editor (Редактор меню) меню Tools (Инструменты);

- нажатием кнопки Menu Editor на стандартной панели инструментов;

- нажатием комбинации клавиш <Ctrl>+<E>.

Редактор создает меню для активного в данный момент окна, то есть, если активно MDI-OKHO, проектируется меню для него, если активна дочерняя форма, проектируется меню для дочерней формы.

к началу

Окно свойств

Окно Properties (Свойства) предназначено для отображения и настройки свойств формы, а также размещенных в ней объектов. В нем, например, содержатся такие свойства выбранного объекта, как позиция в форме, высота, ширина, цвет (рис. 7).

Рис. 7 Окно свойств

Диалоговое окно Properties вызывается командой Properties Window (Окно свойств) из меню View (Вид), кнопкой Properties Window на стандартной панели инструментов или командой Properties контекстного меню выбранного объекта. Поскольку форма и элементы управления каждый сами по себе являются объектами, набор свойств в этом окне меняется в зависимости от выбранного объекта. При помощи вкладок Alphabetic (По алфавиту) и Categorized (По категориям) свойства объекта можно просмотреть в алфавитном порядке или по группам (категориям) соответственно.

В нижней части окна вы всегда найдете подсказку, поясняющую назначение выбранного атрибута объекта. Более подробную информацию найдете в справочной системе Visual Basic 6, нажав клавишу <Fl>. При этом необходимо предварительно выделить интересующее вас свойство.

Используя диалоговое окно Properties, можно изменить установленные по умолчанию свойства объектов. Часть свойств объекта, например, размеры и расположение объектов, можно задать перемещением объекта и изменением его размеров с помощью мыши в конструкторе форм.

Свойства, установленные в окне свойств, допускается изменять при выполнении приложения, написав соответствующие коды в процедурах, создаваемых с помощью редактора кода.

Как правило, форма содержит много объектов. Если выбрать сразу несколько объектов, то в окне свойств отобразятся общие для этих объектов свойства.

В начале изучения Visual Basic 6 в окне свойств Properties предпочтительнее пользоваться вкладкой Categorized (По категориям), так как на ней все свойства сгруппированы по типам и поэтому более понятны. На рис. 6 показана именно эта вкладка. В дальнейшем лучше пользоваться вкладкой Alphabetic (По алфавиту), где требуемое свойство можно быстрее найти по алфавиту.

Рассмотрим основные группы свойств, представленные на вкладке Categorized окна Properties.

Свойства, определяющие внешний вид объекта.

В группе Appearance (Оформление) окна Properties содержатся свойства объекта, которые задают атрибуты его внешнего вида. Основные свойства данной группы:

Caption | - задает текст в строке заголовка объекта;
BorderStyle | - задает стиль рамки объекта;
Palette | - устанавливает цветовую палитру;
Picture | - назначает значок, картинку для объекта. Используя данное свойство формы, можно задать фоновое графическое изображение.

Свойства, определяющие поведение объекта.

Свойства объектов, отвечающие за их поведение, собраны в группе Behavior (Поведение). Основные свойства данной группы:

Causes Validation | - устанавливает признак проверки условия достоверности данных при выходе из объекта;
Enabled | - разрешает или запрещает доступ к объекту;
MaxLength | - устанавливает максимальную длину данных в объекте;
Visible | - устанавливает видимость объекта.

Свойства, определяющие шрифт

Группа Font (Шрифт) содержит всего одно свойство Font, позволяющее с помощью диалогового окна Выбор шрифта задать шрифт текста объекта, размер, начертание.

Общие свойства

Свойства группы Misc задают общие атрибуты объекта, в том числе для его идентификации.

Name | - задает имя объекта;
Text | - устанавливает текст в поле по умолчанию;
Index | - задает уникальный индекс объекта в коллекции;

По имени, указанному в свойстве Name (Имя), объект идентифицируется в форме и в тексте программы. Поэтому необходимо иметь в виду, что в одной форме не может быть двух объектов с одинаковыми именами. По умолчанию это свойство устанавливается автоматически. Вместо имени, заданного по умолчанию, лучше использовать имя, отражающее его смысловое значение.

Свойства позиционирования

Группа Position (Расположение) окна Properties служит для позиционирования объектов в системе координат формы и установки размеров объектов.

Left | - задает положение объекта по горизонтальной оси от левого края формы или, в общем случае, от объекта-контейнера;
Top | - задает положение объекта по вертикальной оси от его верхнего края до верхней стороны формы;
Width | - задает горизонтальный размер (ширину) объекта;
Height | - задает вертикальный размер (высоту) объекта.

Свойства шкалы размеров объекта

Свойства группы Scale (Масштаб) устанавливают шкалу максимальных размеров объектов в системе координат формы.

ScaleLeft | - задает максимальное положение объекта по горизонтальной оси;
ScaleTop | - задает максимальное положение объекта по вертикальной оси;
ScaleWidth | - задает максимальный горизонтальный размер (максимальная ширина);
ScaleHeight | - задает максимальный вертикальный размер (максимальная высота).

к началу

Окно просмотра объектов

Для просмотра всех элементов, входящих в состав проекта. Visual Basic 6 предоставляет очень удобную возможность — окно просмотра объектов Object Browser (рис. 8).

Рис. 8. Окно просмотра объектов

В этом окне можно получить доступ не только ко всем элементам, которые входят в проект, но и их свойствам, методам, событиям. Окно просмотра объектов обычно не визуализировано и его можно вызвать командой Object Browser (Браузер объектов) из меню View (Вид).

к началу

Окно макета формы

Окно макета формы Form Layout (Макет формы) (рис. 9) вызывается командой Form Layout Window из меню View.

Рис. 9. Окно макета формы

В этом окне показывается уменьшенное изображение проектируемой формы в том виде, как эта форма будет выглядеть на экране монитора при выполнении приложения. Размеры формы в окне макета Form Layout пропорциональны размерам изображения монитора в этом же окне, то есть все реальные пропорции в точности соблюдены. Для проверки формы в работающем приложении откройте окно макета формы и запустите форму командой Start (Старт) из меню Run (Запуск).

При этом форма запускается точно в том виде, как она будет выглядеть в работающем приложении.

к началу

Окно редактора исходного кода

Редактор кода (рис. 10) — это мощный встроенный редактор с удобными средствами ввода исходного кода программы.

Рис.10 Редактор кода

Из меню View (Вид) перейти в редактор кода можно с помощью команды Code (Код). Для быстрого открытия окна редактора кода достаточно дважды щелкнуть левой кнопкой мыши, установив указатель на форме приложения. После начала редактирование кода программы имя открытого окна появляется и в списке команд перехода между окнами Window (Окно) главного меню. Переход между макетом и окном редактора кода можно выполнять, используя список меню Window.

Рис. 10. Окно редактора исходного кода

к началу

Окно проводника проекта

Окно проводника проекта Project (рис. 11) очень похоже на аналогичное окно проводника системы Windows и позволяет легко и быстро просматривать состав и свойства выбранного проекта, перемещаться между проектами, если их открыто сразу несколько, копировать необходимые объекты из окна одною проекта в другой, как это осуществляется в проводнике системы Windows.

Рис. 11. Окно проводника проекта

Проводник проекта можно вызвать командой Project Explorer (Проводник проекта) меню View (Вид) или комбинацией клавиш <Ctrl>+<R>.

При нажатии правой кнопки мыши в окне проводника появляется контекстное меню, содержащее команды для добавления, сохранения, удаления форм, элементов управления и других объектов.

Панель управления окна проводника проекта содержит три кнопки, которые имеют следующее назначение:

View code | - открывает окно редактора с кодом программы, выбранного в проводнике объекта;
View Object | - открывает в конструкторе форм выбранный объект;
Toggle Folders | - включает/выключает отображение папок.

к началу

Окно локальных переменных

Окно Locals (Локальные) предназначено для просмотра списка локальных переменных приложения и контроля за их значениями (рис. 12). Вызывается это окно командой Locals Window (Окно локальных переменных) меню View (Вид).

Рис. 12. Окно Locals

В окне Locals можно просмотреть локальные переменные, объявленные в текущей процедуре, их тип и значения. Эта информация автоматически появляется в окне при его вызове. Данное окно используется для отладки и проверки работы приложений. С помощью него можно проконтролировать все локальные переменные в точках останова программы.

При работе с окном Locals (Локальные) необходимо иметь в виду, что глобальные переменные в этом окне для просмотра недоступны.

Для выбора интересующей процедуры используется поле со списком. Нажав на кнопку с многоточием, можно выбрать интересующую процедуру из списка. Если значения переменных или их названия не помещаются в столбцах, то требуемые столбцы можно расширить, перемещая при помощи левой кнопки мыши границы столбцов в заголовке. Если окно открыто постоянно, то данные между точками останова программы при работе приложения автоматически обновляются.

В окне Locals можно не только просматривать переменные и их значения в данный момент работы программы. Очень полезным свойством этого окна является возможность изменять значения переменных для проверки реакции программы на эти значения. Для этого в столбце Value (Значение) необходимо щелкнуть на изменяемом значении. При этом значение переведется в режим редактирования, и его можно будет изменить. Клавишей <Enter> или перемещением указателя мыши на другое поле устанавливается новое значение, если оно имеет допустимое значение.

к началу

Окно контроля работы приложения

Для более полного контроля работы приложения (рис. 13) используется окно Watches (Наблюдение).

Рис. 13. Окно Watches

Это окно вызывается командой Watch Window (Окно наблюдения) меню View (Вид) и предназначено для определения значений выражений. В окне Watches можно выполнять действия, аналогичные выполняемым в окне Locals (Локальные). Так же, как и Locals, окно Watches используется при отладке приложения и проверке его работы.

к началу

Окно ручного ввода и выполнения команд

Окно Immediate (Непосредственное выполнение) предназначено для ручного ввода и выполнения команд Visual Basic 6 (рис. 14). Это окно появляется автоматически при прерывании работы программы в точках останова программы.

Рис. 14. Окно Watches

Для выполнения команды или оператора Visual Basic необходимо набрать строку команды и нажать клавишу <Enter>.

В сочетании с окнами Locals (Локальные) и Watches (Наблюдение), окно Immediate является удобным средством для отладки и проверки работы программы в пошаговом режиме. Проверяемые части или блоки программы можно копировать из программных модулей приложения в окно Immediate, и после проверки и внесения необходимых изменений по результатам контроля возвращать в модуль приложения.

к началу

Настройка среды разработки

Для настройки среды разработки программы Visual Basic используется диалоговое окно Options (Параметры), вызываемое из меню Tools (Сервис) командой Options (Параметры). Окно содержит шесть вкладок:

Editor (Редактор)

Editor Format (Форматы редактирования)

General (Основные настройки)

Docking (Инструменты среды)

Environment (Среда проектирования)

Advanced (Расширенные настройки)

Для настройки среды разработки (IDE) на вкладках используются группы флажков, переключателей, раскрывающиеся списки.

При изменении параметров для сохранения варианта настройки необходимо выйти из диалогового окна Options, нажав кнопку ОК.

Для отказа от всех осуществленных на вкладках изменений нажмите кнопку Отмена.

Рис. 15 Вкладка Editor

Рис. 16 Вкладка Editor Format

к началу

Вкладка настроек редактора

Самая первая вкладка диалогового окна Options — Editor (Редактор) (рис. 15). Здесь можно установить параметры работы редактора исходного кода приложения. Используя флажки группы Code Settings (Установки редактора кода), устанавливаются следующие параметры:

Auto Syntax Check (Автоматический контроль синтаксиса) | — автоматический контроль синтаксиса при вводе исходного кода приложения в редакторе;
Require Variable Declaration (Требование объявления переменных) | — если этот флажок установлен, любые переменные можно использовать только после их объявления;
Auto List Members (Автоматический вывод списка возможных свойств и методов объекта) | — автоматический вывод свойств и методов объекта при вводе текста программы. При этом методы и свойства отображаются в позиции курсора и их можно легко выбрать;
Auto Quick Info (Автоматический вывод синтаксиса функций) | — разрешение или запрет вывода информации о функциях и их параметрах при вводе текста программы;
Auto Data Tips (Автоматическое отображение значений) | — при отладке приложения отображает значение переменной, находящейся под указателем мыши;
Auto Indent (Автоматическая расстановка) | — автоматическая расстановка отступа при вводе программы. Отступы делают программу структурированной и понятной при чтении. Для сложных программ отступы просто обязательны.

В поле Tab Width указывается количество пробелов отступа при нажатии клавиши <ТаЬ>. По умолчанию установлено значение 8, но его можно изменить.

В группе Window Settings (Настройки окна) устанавливаются параметры, связанные с фрагментами текста:

Drag-and-Drop Text Editing (Перетаскивание текста) | — разрешает перетаскивание фрагментов текста программы;
Default to Full Module View (Отображение всех процедур) | — позволяет отображать в редакторе сразу все процедуры текущего объекта. Если этот флажок не установлен, процедуры можно просматривать по очереди;
Procedure Separator (Разделитель текста процедур) | — в режиме просмотра всех процедур проекта устанавливает между ними разделитель.

к началу

Вкладка стилей текста

На вкладке Editor Format (рис. 16) настраиваются стили текста исходного кода приложения — используемый шрифт, цвета, размер текста исходного кода в зависимости от назначения текста кода. Используя параметры данной вкладки, можно выделить цветом, шрифтом и размером шрифта основные элементы программы, например, основной текст, текст комментариев, точки остановки.

Для настройки форматов элементов кода необходимо выполнить следующее:

1. Выбрать в области Code Colors из списка типов программного текста настраиваемый тип.

2. Используя раскрывающиеся списки Foreground и Background, установить цвет текста и фона.

3. С помощью списков Font и Size задать наименование шрифта и его размер.

4. В области Sample просмотреть полученный результат осуществленных изменений.

5. Повторяя пункты с 1-го по 4-й, изменить все необходимые стили текста окна редактора кода.

6. Для сохранения установленных параметров, нажать кнопку ОК.

Рис. 17 Вкладка General

Рис. 18 Вкладка Docking

к началу

Вкладка настроек общих свойств среды

На вкладке General (рис. 17) диалогового окна Options размещены параметры, которые предназначены для управления общими свойствами среды проектирования. В области Form Grid Settings (Настройка сетки форм) находятся следующие параметры настройки:

Show Grid (Отображать сетку) | — устанавливает режим отображения линий координатной сетки при разработке макетов форм. Используя расположенные под флажком поля Width (Ширина) и Height (Высота), можно установить ширину и высоту ячеек сетки.
Align Controls to Grid (Привязать элементы управления к сетке) | — задает привязку элементов управления к шагу сетки при размещении их в макете формы.

В области Error Trapping (Реакция на ошибки) можно установить один из трех переключателей, которые задают вариант реакции приложения на возникающие при его работе ошибки:

Break on All Errors (Приостанавливаться по всем ошибкам) | — приостанавливать выполнение приложения при возникновении любой ошибки;
Break in Class Module (Приостанавливаться по ошибкам в классах) | — приостанавливать выполнение приложения при возникновении любой ошибки в модуле класса;
Break on Unhandled Errors (Приостанавливаться по неуправляемым ошибкам) | — приостанавливать выполнение приложения при возникновении любой необработанной ошибки, то есть при такой ошибке, для которой нет функции перехвата.

В области Compile (Компиляция) можно установить флажки, управляющие процессом компиляции программы:

Compile on Demand (Компиляция по мере необходимости) | — компиляция будет осуществляться только для тех разделов программы, которые необходимо выполнять. При этом при выполнении команды Start (Запустить) из меню Run (Запуск) приложение будет запускаться быстрее;
Background Compile (Фоновая компиляция) | — этот флажок дает возможность использовать время ожидания программы для ее компиляции.

Кроме перечисленных параметров, на этой вкладке есть еще два флажка следующего назначения:

Show ToolTips (Отображать подсказки) | — при установке этого флажка Visual Basic 6 отображает подсказку с описанием свойств объекта в макете формы, когда указатель мыши удерживается на объекте некоторое время;
Collapse Proj, Hides Windows (Сворачивать проект, скрыть окна) | — этот флажок заставляет сворачиваться все связанные с проектом окна при свертывании окна проекта.

к началу

Вкладка настройки окон

На вкладке Docking (рис. 18) диалогового окна Options все флажки объединены в одну группу Dockable Эти флажки определяют, какие окна среды разработки могут закрепляться ("приклеиваться") к краям главного окна программы Visual Basic. Наименования окон среды разработки перечислены в виде флажков. Настройка заключается в установке флажков для соответствующих им окон.

Immediate Window | — окно Immediate (Непосредственное выполнение)
Locals Window | — окно Locals (Локальные)
Watch Window | — окно Watches (Наблюдение)
Project Explorer | — проводник проекта
Properties Window | — окно свойств
Object Browser | — браузер объектов
Form Layout | — окно макета форм
Toolbox | — панель элементов управления
Color Palette | — цветовая палитра

Рис. 19 Вкладка Environment

Рис. 20 Вкладка Advanced

к началу

Вкладка Environment

Вкладка Environment (рис. 19)диалогового окна Options содержит три области. В области When Visual Basic starts (При запуске Visual Basic) можно установить переключатели:

Prompt for project (Приглашение для выбора образца проекта) | — указывает на необходимость открытия диалогового окна New Project (Новый проект) при запуске Visual Basic 6;
Create default project (Создавать проект по умолчанию) | — при запуске Visual Basic 6 создается установленный по умолчанию тип проекта.

Область When a program starts (При запуске программы) управляет возможностью сохранения проекта при запуске его на выполнение. Впоследствии при работе с большим проектом от сохранения можно отказаться для экономии времени. В данной группе переключателей устанавливается одна из следующих опций:

Save Changes (Сохранять изменения) | — сохранять изменения всегда;
Prompt To Save Changes (Сохранять изменения по запросу) | — сохранять проект с предварительным запросом на сохранение;
Don't Save Changes (He сохранять изменений) | — не сохранять осуществленных изменений.

Область Show Templates For (Показывать шаблоны) содержит список шаблонов, появляющихся в соответствующих диалоговых окнах при создании объектов. Используя расположенные здесь флажки, можно отказаться от части шаблонов, которые в данный момент не интересны. Для этого необходимо снять соответствующий флажок. Например, если вы не хотите, чтобы при создании форм появлялось диалоговое окно со списком шаблонов форм, вам необходимо снять флажок Form.

Поле Template Directory (Каталог шаблонов) вкладки назначает папку поиска шаблонов по умолчанию.

к началу

Вкладка Advanced

На вкладке Advanced (рис. 20) диалогового окна Options расположены три флажка, имеющих следующее назначение:

Background Project Load (Фоновая загрузка проекта) | — разрешает загрузку проекта в фоновом режиме, что дает возможность во время загрузки другого проекта продолжать работу над текущим;
Notify when changing shared project items (Сообщать об изменениях элементов проекта) | — сообщает об изменении общего для нескольких проектов объекта при одновременной работе над этими проектами;
SDI Development Environment (Назначить однодокументныи интерфейс) | — устанавливает однодокументныи интерфейс (SDI, Single-Document Interface) среды проектирования. По умолчанию используется многодокументный интерфейс (MDI, Multiple-Document Interface).

Используя поле External HTML Editor (Внешний редактор HTML) вкладки Advanced, можно установить редактор для работы с HTML-страницами.

к началу

ПРИЛОЖЕНИЕ

Команды меню File

Команда | Назначение
New Project (Новый проект) | Создает новый проект
Open Project (Открыть проект) | Открывает существующий проект
Add Project (Добавить проект) | Добавляет проект в группу для параллельной работы над несколькими проектами, копирования форм из проекта в проект или для его отладки
Remove Project (Исключить проект) | Удаляет проект из группы проектов
Save Project Group (Сохранить группу проектов) | Сохраняет группу проектов
Save Project Group As (Сохранить группу проектов как) | Сохраняет группу проектов под другим именем
Save <имя формы> (Сохранить форму) | Сохраняет форму с прежним именем
Save <имя формы> As (Сохранить форму как) | Сохраняет форму под другим именем
Print (Печать) | Открывает диалоговое окно Print
Print Setup (Настройка печати) | Открывает диалоговое окно настройки печати
Make <имя проекта>.ехе (Создать ехе-файл проекта) | Создает выполняемый файл текущего проекта
Make Project Group (Создать группу проектов) | Создает группу проектов
Exit (Выход) | Осуществляет выход из Visual Basic 6. В том случае, если в окне программы находятся не сохраненные результаты работы, появятся запросы о необходимости сохранения проектов, форм и других файлов

к началу

Команды меню Edit

Команда | Назначение
Undo (Отменить) | Отменяет предыдущую команду
Redo (Повторить) | Восстанавливает предыдущую команду
Cut (Вырезать) | Вырезает фрагмент текста
Сору (Копировать) | Копирует фрагмент в буфер обмена
Paste (Вставить) | Копирует содержимое из буфераобмена
Remove (Переместить) | Перемещает выделенное
Delete (Удалить) | Удаляет выделенное
Delete Table from Database (Удалить таблицу из базы данных) | Удаляет таблицу из базы данных
Select All (Выделить все) | Выделяет все
Select All Columns (Выделить все колонки) | Выделяет все колонки
Table: Set Primary Key (Таблица: Установить первичный ключ) | Определяет первичный ключ таблицы
Table: Insert Column (Таблица: Вставить поле) | Вставляет поле в таблицу
Table: Delete Column (Таблица: Удалить поле) | Удаляет поле из таблицы
Find (Найти) | Вызывает диалоговое окно поиска
Find Next (Найти следующее) | Ищет следующее значение, заданное для поиска
Replace (Заменить) | Ищет значение, заданное для поиска, и заменяет его новым значением
Go To Row: First (Перейти на запись: Первая) | Устанавливает указатель на первую запись
Go To Row: Last (Перейти на запись: Последняя) | Устанавливает указатель на последнюю запись
Go To Row: Next (Перейти на запись: Следующая) | Устанавливает указатель на следующую запись
Go To Row: Previous (Перейти на запись: Предыдущая) | Устанавливает указатель на предыдущую запись
Go To Row: Row (Перейти на запись: Запись) | Устанавливает указатель на запись с заданным номером
Go To Row: New (Перейти на запись: Новая) | Вставляет новую запись

к началу

Команды меню View

Команда | Назначение
Code (Код) | Открывает окно редактора программного кода
Object (Объект) | Открывает окно конструктора форм
Object Browser (Браузер объектов) | Открывает окно браузера объектов
Immediate Window (Окно непосредственного выполнения) | Открывает окно, предназначенное для ввода и непосредственного выполнения команд
Locals Window (Окно Локальные) | Открывает окно, предназначенное для просмотра значений переменных
Watch Window (Окно Наблюдение) | Открывает окно просмотра значений выражений
Project Explorer (Проводник проекта) | Открывает окно проводника проектов
Properties Window (Окно свойств) | Открывает окно свойств объектов Properties
Form Layout Window (Окно макета формы) | Открывает окно макета формы
Toolbox (Панель инструментов) | Отображает панель элементов управления
Data View Window (Окно просмотра данных) | Открывает окно просмотра данных
Color Palette (Цветовая палитра) | Отображает цветовую палитру
Toolbars (Панели инструментов) | Открывает меню, предназначенное для отображения в окне программы Visual Basic следующих панелей: Debug (Отладка), Editor (Редактор), Form Edit (Редактор форм), Standard (Стандартная панель инструментов)

к началу

Команды меню Project

Команда | Назначение
Add Form (Добавить форму) | Добавляет в окно проекта форму
Add MDI Form (Добавить форму окна MDI) | Добавляет MDI-форму
Add Module (Добавить модуль) | Добавляет программный модуль
Add Class Module (Добавить класс) | Добавляет пользовательский класс
Add User Control (Добавить элемент управления) | Добавляет пользовательский элемент управления
Add Property Page (Добавить страницу свойств) | Добавляет стандартную форму настройки свойств
Add WebClass (Добавить Web-класс) | Добавляет Web-класс
Add Data Report (Добавить отчет) | Добавляет в проект отчет
Add DHTML Page (Добавить страницу DHTML) | Добавляет страницу DHTML
Add Data Environment (Добавить среду данных) | Добавляет среду базы данных
Add File (Добавить файл) | Добавляет файл
Remove (Исключить) | Исключает файл из проекта
References (Ссылки) | Вызывает окно включения ссылок проекта на библиотеки
Components (Компоненты) | Открывает диалоговое окно Components, позволяющее добавить на панель элементов управления компоненты для их дальнейшего включения в проект приложения
Project Properties (Свойства проекта) | Открывает окно свойств проекта Project Properties

к началу

Команды меню Format

Команда | Назначение
Align (Выровнять) | Открывает меню, содержащее команды выравнивания объектов
Make Same Size (Установить подобный размер) | Открывает меню, содержащее команды, управляющие размерами объектов в форме
Horizontal Spacing (Горизонтальный интервал) | Устанавливает интервал между объектами в горизонтальном направлении
Vertical Spacing (Вертикальный интервал) | Устанавливает интервал между объектами в вертикальном направлении
Center in Form (Центрирование в форме) | Центрирует объекты в форме
Order (Порядок) | Направляет выбранный объект в нижний или верхний слой формы

к началу

Команды меню Debug

Команда | Назначение
Step Into (Шаг с заходом в процедуры) | Осуществляет пошаговое выполнение процедуры, включая также вызываемые ею процедуры
Step Over (Шаг без захода в процедуры) | Осуществляет пошаговое выполнение процедуры без трассировки вызываемых ею процедур
Step Out (Шаг с выходом из процедуры) | Выполнение программы осуществляется до выхода из текущей процедуры
Add Watch (Добавить окно Watch) | Открывает окно Add Watch (Добавить наблюдение) для ввода выражений, за значениями которых будет вестись наблюдение
Edit Watch (Открыть окно Edit Watch) | Открывает диалоговое окно Edit Watch для редактирования или удаления выражений, за значениями которых ведется наблюдение
Quick Watch (Открыть окно Quick Watch) | Открывает окно Quick Watch для просмотра значения выбранного выражения
Toggle Breakpoint (Установить точку останова) | Устанавливает точку останова
Clear All Breakpoints (Отменить все точки останова) | Удаляет все точки останова
Set Next Statement (Определить следующий оператор) | Устанавливает следующий оператор
Show Next Statement (Показать следующий оператор) | Показывает следующий оператор

к началу

Команды меню Run

Команда | Назначение
Start (Запустить) | Запускает приложение на выполнение
Start with Full Compile (Запустить с полной компиляцией) | Запускает приложение на выполнение с полной компиляцией
Break (Приостановить) | Останавливает выполнение приложения
End (Конец) | Прекращает выполнение приложения
Restart (Перезапустить) | Перезапускает приложение

к началу

Команды меню Query

Команда | Назначение
Run (Запустить) | Выполняет запрос
Clear Results (Очистить результаты) | Очищает результаты запроса
Verify SQL Syntax (Проверить синтаксис SQL) | Проверяет синтаксис запроса
Group By (Группировать) | Группирует данные в запросе
Change Type: Select (Модификация: Выбрать) | Создает запрос для выборки данных
Change Type: Insert (Модификация: Вставить) | Создает запрос, предназначенный для добавления данных в таблицу, используя значения других таблиц
Change Type: Insert Values (Модификация: Вставить значения) | Создает запрос, предназначенный для добавления данных в таблицу, используя заданные значения
Change Type: Update (Модификация: Изменить) | Создает запрос, предназначенный для изменения данных
Change Type: Delete (Модификация: Удалить) | Создает запрос, предназначенный для удаления данных
Change Type: Make Table (Модификация: Создать таблицу) | Создает новую таблицу на основе результатов выборки
Add to Output (Добавить поля) | Добавляет поля в список полей формируемой выборки
Sort Ascending (Сортировка по возрастанию) | Назначает сортировку по возрастанию
Sort Descending (Сортировка по убыванию) | Назначает сортировку по убыванию
Remove Filter (Удалить фильтр) | Удаляет фильтр
Select All Rows From <Table A > (Выбрать все записи из первой таблицы) | Создает внешнее соединение, которое выбирает все записи из первой таблицы, даже если они отсутствуют во второй таблице
Select All Rows From <ТаЫе В > (Выбрать все записи из второй таблицы) | Создает внешнее соединение, которое выбирает все записи из второй таблицы, даже если они отсутствуют в первой таблице

к началу

Команды меню Diagram

Команда | Назначение
New Text Annotation (Новый текст пояснения) | Добавляет пояснительный текст
Set Text Font (Установить шрифт) | Устанавливает шрифт
Add Related Tables (Добавить связанную таблицу) | Добавляет связанную таблицу
Show Relationship Labels (Показать связи) | Показывает наименования связей
Modify Custom View (Изменить представление) | Изменяет вид отображения таблиц в диаграмме
View Page Break (Показывает постраничную разбивку) | Показывает разбивку на страницы
Recalculate Page Break (Пересчитать постраничную разбивку) | Пересчитывает разбивку на страницы
Arrange Selection (Выравнивать выбранные) | Выравнивает выбранные таблицы
Arrange Tables (Выравнивать все таблицы) | Выравнивает все таблицы
Autosize Selected Tables (Авторазмер выделенных таблиц) | Автоматически устанавливает размер выбранных таблиц

к началу

Команды меню Tools

Команда | Назначение
Add Procedure (Добавить процедуру) | Добавляет процедуру
Procedure Attributes (Атрибуты процедуры) | Устанавливает атрибуты процедуры
Menu Editors (Редактор меню) | Вызывает окно редактора меню
Options (Параметры) | Открывает диалоговое окно Options для настройки параметров программы Visual Basic
SourseSafe (Хранилище) | Управляет хранилищем проектов

к началу

Команды меню Add-Ins

Команда | Назначение
Visual Data Manager (Менеджер баз данных) | Запускает менеджера управления базой данных
Add-In Manager (Менеджер надстроек) | Открывает диалоговое окно Add-In Manager, позволяющее добавить надстройку в Visual Basic 6

к началу

Команды меню Window

Команда | Назначение
Split (Разделить) | Разделяет окно
Tile Horizontally (Горизонтально) | Размещает окна горизонтально
Tile Vertically (Вертикально) | Размещает окна вертикально
Cascade (Каскадом) | Размещает окна каскадом
Arrange Icons (Упорядочение значков) | Изменяет размещение значков окон

к началу

Команды меню Help

Команда | Назначение
Context (Содержание) | Вызывает справочную систему с активной вкладкой Содержание
Index (Указатель) | Вызывает справочную систему с активной вкладкой Индекс
Search (Поиск) | Вызывает справочную систему с активной вкладкой Поиск
Technical Support (Техническая поддержка) | Вызывает справочную систему с информацией о службе технической поддержки Microsoft
Microsoft on the Web (Microsoft в Web) | Вызывает страницу Microsoft в Internet
About Visual Basic (0 Visual Basic) | Вызывает справочную информацию о пакете Visual Basic 6

к началу

Кнопки стандартной панели инструментов

Название (по всплывающей подсказке) | Назначение
Add Standard EXE Project (Добавить стандартный проект) | Добавляет стандартный ехе-проект
Add Form (Добавить форму) | Добавляет форму в проект
Menu Editor (Редактор меню) | Вызывает редактор меню
Open Project (Открыть проект) | Открывает проект
Save Project (Сохранить проект) | Сохраняет проект
Cut (Вырезать) | Вырезает информацию в буфер обмена
Copy (Копировать) | Копирует в буфер обмена
Paste (Вставить) | Вставляет информацию из буфера обмена
Find (Найти) | Осуществляет поиск информации по контексту
Can't Undo (Отмена предыдущего) | Отменяет предыдущее действие
Can't Redo (Отмена повторного) | Восстанавливает отмененное действие
Start (Запустить) | Запускает программу на выполнение
End (Закончить) | Прекращает выполнение программы
Break (Прервать) | Прерывает выполнение программы
Project Explorer (Проводник проекта) | Открывает окно проводника проектов
Properties Window (Окно свойств) | Открывает окно свойств
Form Layout Window (Окно макета форм) | Открывает окно макета формы
Object Browser (Браузер объектов) | Открывает окно браузера объектов
Toolbox (Панель элементов управления) | Открывает панель элементов управления
Data View Window (Окно просмотра данных) | Открывает окно просмотра данных
Visual Component Manager (Менеджер визуальных компонентов) | Открывает окно управления визуальными компонентами Visual Component Manager

к началу

Кнопки панели элементов управления

Название (по всплывающей подсказке) | Назначение
Pointer (Указатель) | Используется для позиционирования маркера (указателя) мыши
PictureBox (Графическое окно) | Размещает в форме графическое окно, предназначенное для объединения элементов в группы, для вывода в него графических изображений, а также текста, графических элементов и анимации
Label (Метка) | Размещает в форме объекты, предназначенные для создания текстовой информации, надписей и примечаний
TextBox (Текстовое поле) | Размещает в форме текстовое поле, предназначенное для ввода текстовой информации, чисел и дат
Frame (Рамка) | Создает в форме рамку с заголовком для группировки объектов в логическую группу
CommandButton (Кнопка управления) | Размещает в форме кнопки управления для инициации действий, выполнения команд, запуска программ
CheckBox (Флажок) | Размещает в форме флажок, предназначенный для формирования условий выполнения программ или каких-либо настроек, работающий по принципу "да — нет"
OptionBufrton (Переключатель) | Создает в форме переключатели для выбора режима работы или настроек выполнения программы
ComboBox (Поле со списком) | Создает в форме объект, содержащий одновременно поле ввода и раскрывающийся список
ListBox (Список) | Создает в форме список для выбора одного или нескольких значений из предлагаемого списка значений
HScrollBar (Горизонтальная полоса прокрутки) | Размещает в форме горизонтальную полосу прокрутки, используемую в качестве ползунка для выбора значения из заданного диапазона
VScrollBar (Вертикальная полоса прокрутки) | Размещает в форме вертикальную полосу прокрутки, используемую в качестве ползунка для выбора значения из заданного диапазона
Timer (Таймер) | Размещает в форме таймер
DriveListBox (Список устройств) | Создает в форме список устройств
DirListBox (Список папок) | Создает в форме древовидный список папок
FileListBox (Список файлов) | Создает в форме список файлов
Shape (Очертание) | Создает в форме геометрические фигуры, такие как прямоугольник, квадрат, круг, эллипс, прямоугольник и квадрат со скругленными углами
Line (Линия) | Создает линии
Image (Изображение) | Создает в форме поля, предназначенные для отображения графических изображений
Data (Данные) | Создает элемент управления данными в базе данных для перемещения по записям и отображения результата навигации

к началу